Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-21-06, 10:29 AM   #1
mturcotte
Registered User
 
Join Date: Jul 2006
Posts: 1
Default Dell M70 with Quadro FX Go1400 with 1920x1200 LCD + external (DVI) Dell 2405FPW

Hi,

I just installed SuSE Linux ENterprise Desktop 10 on my Dell Precision M70. Everything worked fine in both modes I typically use:
1) Docked and using only my external DELL 2405FPW connected to the DVI port of my docking station (in 1920X1200 resolution)
2) Undocked and using only the built-in 1920X1200 LCD (Sharp I think).

However, as soon as I installed (automated process through Yast Online Update) the NVidia drivers to enable the Xgl and 3D Desktop enhancements, I could never get anything on my 2405FPW when docked. From this point on, the only thing working is in undocked mode (only the 1920X1200 LCD).

Being far from an expert in Xorg.conf editing, I started doctoring my Xorg.conf based on different posts I googled but I'm still unable to get anything from my 2405FPW. I also added the following to the /etc/profile.local (and checked that these environment variables are indeed loaded):

__GL_SYNC_DISPLAY_DEVICE=DFP-1
__GL_SYNC_TO_VBLANK=1

In fact, not being sure whether to point it to DFP-1 or DFP-0, I tried both without any success.

Any help will be appreciated.

Thanks,

Martin

Here's my Xorg.conf:

# /.../
# SaX generated X11 config file
# Created on: 2006-07-20T22:00:02-0400.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
# FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
# FontPath "/usr/X11R6/lib/X11/fonts/PEX"
# FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
# FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/CID"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
# FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
# FontPath "/usr/X11R6/lib/X11/fonts/xtest"
# FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "10"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.1"
Option "BottomEdge" "650"
Option "Buttons" "5"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "1"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "ALPS;Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "Sysp"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 30-95
Identifier "DFP-0"
ModelName "M70-LCD"
Option "DPMS"
VendorName "DELL"
VertRefresh 60-75
UseModes "Modes[0]"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 30-95
Identifier "DFP-1"
ModelName "2405FPW"
Option "DPMS"
VendorName "DELL"
VertRefresh 60-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1920x1200" 239.63 1920 2064 2272 2624 1200 1201 1204 1251
Modeline "1920x1200" 236.35 1920 2064 2272 2624 1200 1201 1204 1251
Modeline "1920x1200" 232.88 1920 2064 2272 2624 1200 1201 1204 1250
Modeline "1920x1200" 154.13 1920 1968 2000 2080 1200 1203 1209 1235 -hsync -vsync
Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1280x1024" 132.75 1280 1368 1504 1728 1024 1025 1028 1067
Modeline "1280x1024" 130.91 1280 1368 1504 1728 1024 1025 1028 1067
Modeline "1280x960" 126.27 1280 1368 1504 1728 960 961 964 1001
Modeline "1280x960" 124.54 1280 1368 1504 1728 960 961 964 1001
Modeline "1280x960" 122.69 1280 1368 1504 1728 960 961 964 1000
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 78.43 1024 1080 1192 1360 768 769 772 801
Modeline "1024x768" 77.25 1024 1080 1192 1360 768 769 772 800
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "800x600" 46.87 800 840 920 1040 600 601 604 626
Modeline "800x600" 46.15 800 840 920 1040 600 601 604 625
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "640x480" 29.43 640 664 728 816 480 481 484 501
Modeline "640x480" 29.03 640 664 728 816 480 481 484 501
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1920x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1920x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1920x1200" "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "DFP-0"
EndSection

Section "Device"
BoardName "Quadro FX Go1400"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "UseEdidFreqs"
Option "NoLogo"
Option "ConnectedMonitor" "DFP-0, DFP-1"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Option "TwinView"
Option "HorizSync" "DFP-0: 30-81; DFP-1: 30-81"
Option "VertRefresh" "DFP-0: 56-76; DFP-1: 56-76"
Option "MetaModes" "DFP-0: 1920x1200, DFP-1: 1920x1200"
Option "ModeValidation" "DFP-0: NoMaxPClkCheck,NoEdidMaxPClkCheck"
Option "TwinViewOrientation" "Clone"
Option "ConnectedMonitor" "DFP-0, DFP-1"
Option "XvmcUsesTextures" "true"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
mturcotte is offline   Reply With Quote
Old 07-21-06, 10:37 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Dell M70 with Quadro FX Go1400 with 1920x1200 LCD + external (DVI) Dell 2405FPW

Does this problem exist with Xgl enabled?

Please start X with the following command:
startx -- -logverbose 5

and then generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 07-21-06, 10:50 AM   #3
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: Dell M70 with Quadro FX Go1400 with 1920x1200 LCD + external (DVI) Dell 2405FPW

Wow I am having the problem on my M1710, except that so far ive never gotten it to work when the system is docked, I am using gentoo.
http://www.nvnews.net/vbulletin/showthread.php?t=73643
Xevious is offline   Reply With Quote
Old 07-21-06, 11:25 AM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Dell M70 with Quadro FX Go1400 with 1920x1200 LCD + external (DVI) Dell 2405FPW

Did you check the logfile to see if it rejects the 2405FPW and why?
I have one, on another system and videocard, and I know that some cards have a limit on DVI clockrate that is too low for the 2405FPW.

This is a "spec" limit, and when the driver does not check for it things just work OK. The "nv" driver doesn't check it and everything is fine. Same for old versions of the "nvidia" driver. Newer drivers make the check and reject the display.
In the newest versions you can tell the driver not to make the check.
pe1chl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.