Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-06-03, 11:59 PM   #1
silentdragon48
Registered User
 
Join Date: Feb 2003
Posts: 15
Question Linux retarted??? I'd say yes...

For reference here is what I'm running:
Red Hat 7.2 Kernel 2.4
CPU: AMD T-bird 1.333 GHz
Vid: Nvidia GeForce 4 Ti 4200

I used to run a slower setup with an SiS6326 attached to it. And I used to be able to get RH to start Xserver without a problem. Howerver, I got tired of that card and upgrading. While upgrading I had to blow away my install of Red Hat for my Windows files.

So, this is on a fresh new install of Red Hat 7.2 and Xserver just won't load. I downloaded the NVchooser.sh script and ran it and the thing told me to download 2 files: 1) NVIDIA_GLX-1.0-4191.i386.rpm and 2) NVIDIA_kernel-1.0-4191.rh72up.athlon.rpm. I went through the README.txt file too and did the install (you know rpm -ivh blah blah blah ) and it came across just fine. I tried configuring XF86Config in my /etc/X11 folder but the thing still won't run. If anyone has any helpful hints or a copy of a working XF86Config file that would be a great help.

Heck at this point I'm open to anything at all, any advice (maybe a tech. manual) would work.

If it would be of any help the next time I'm in Linux I could try to start Xserver again and copy down the error message and post it here, just let me know what will help so I can use Xserver in Linux again.
Thanks,
~SD48
silentdragon48 is offline   Reply With Quote
Old 02-07-03, 12:33 AM   #2
Noth
Registered User
 
Join Date: Nov 2002
Posts: 44
Default

You can't get X working so Linux is retarded? Christ.

Anyway the basic steps to install the drivers are:

1) Install the kernel driver and GLX files. I usually use the tar.gz files because they're simple (and I don't use RedHat).

2) The first step should load the kernel driver, type lsmod to see if 'nvidia' is in the list, if not type 'modprobe nvidia' and it should load.

3) Edit /etc/X11/XF86Config-4 and change the driver from 'nv' to 'nvidia'.

4) Start up X.

There are other things you can do to tweak things, mainly XF86Config-4 entries, but they're not necessary to get a working setup.
Noth is offline   Reply With Quote
Old 02-07-03, 02:07 AM   #3
junkieclown
Helium Abuser
 
junkieclown's Avatar
 
Join Date: Nov 2002
Location: Summers in Rangoon, but mostly in my evil underground lair and Volcano laboratory. though
Posts: 45
Default

The problem you're experiencing is that ti4200 cards are too new for the version of XFree86 bundled with your distribution to recognize. X can't probe the monitor to find out its capabilities, so unless your exact model is in the list of monitors redhat-config-xfree86 knows about you'll probably get a horrid looking display as the program defaults to safe values.

I could help you set up your card, but you have offended a Shaolin temple and you have offended Linux.
And you misspelled 'retarded' while trying to do it.

Well, on the other hand I recently badmouthed Nvidia for something that is not entirely their fault. So to atone for my own bad manners I will give you partial answers:

Find your monitor's manual or look up info on it at the manufacturer's website and discover its exact horizontal synch range and vertical refresh ranges.

run the program xf86config.
WHen asked about your monitor's characteristics select custom horizontal sync and put in exactly what you have discovered from the manual (for example 31.5 - 107 )
Don't put in guessed values.

Do the same when asked for vertical refresh ranges.

Select Nvidia Gforce 4 generic as your card. (This will setup your XF86Config to use the vesa driver )
set up screen resolutions for different color depths you might use: 24 bpp , 16bpp, 8bpp...
Let xf86config write out the new configuration file to the default location.

Now, having installed the Nvidia drivers and glx files, edit /etc/X11/XF86Config.

Change vesa driver to nvidia

Comment out anything about DRI --Nvidia doesn't use DRI and it will conflict.

Comment out anything about glcore
but leave 'load glx' alone.

If you have a USB mouse change whatever xf86config said your mouse is (/dev/mouse) to /dev/usbmouse.
eg; here's my Mouse section for my Logitech First / Pilot Wheel Mouse:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"

Know what you have and the protocol it's going to use. IMPS/2 is an Intellimouse type mouse. If you dont' know you'll need to experiment. The last line is for mapping the wheel of a wheelmouse to X's ideas of buttons for up and down.

That should do it. As long as you gave accurate info about your monitors' characteristics you should have a X display that fills your monitor's screen.

It helps to be in runlevel 3 when you're doing this stuff.

Last edited by junkieclown; 02-07-03 at 02:15 AM.
junkieclown is offline   Reply With Quote
Old 02-07-03, 07:42 AM   #4
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

And if that doesn't work, post what your Device and Modules sections of XF86Config (NOTE: if you have an XF86Config-4 file, then X will use it instead, and so should you -- this may be your entire problem...) look like, and the errors you're getting.

If you're getting an error about "failed to initialize kernel module", then check dmesg or /var/log/messages for why. You probably need to turn PnP OS to No, and Assign IRQ to (PCI) VGA to Yes in your BIOS, so check those as well.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-07-03, 09:27 AM   #5
silentdragon48
Registered User
 
Join Date: Feb 2003
Posts: 15
Default

oh heavens no, I did not mean that Linux is retarted. FYI: I was writing that post at 3 am or something local time so a lot of that came out wrong. I mean that I am retarted (yes my spelling is bad) when it comes to Linux. Good lord, I love linux, especially compared to Windows, I grew up with my Dad teaching me how to use UNIX, but never how to configure or troubleshoot anything.
~SD48
silentdragon48 is offline   Reply With Quote
Old 02-07-03, 09:39 AM   #6
zatnktel
Registered User
 
Join Date: Feb 2003
Location: australia
Posts: 8
Send a message via AIM to zatnktel
Default

one quick thing there is no XF86Config-4 in redhat only XF86Config if you need any help email me on
zatnktel@iprimus.com.au

install both the kernel rpm and the glx rpm then install the tar balls
with ./configure then make them make install
then edit the XF86Config file download the readme at the bottom of the driver section it will tell you ehat to change in the XF86Config

Last edited by zatnktel; 02-07-03 at 09:43 AM.
zatnktel is offline   Reply With Quote
Old 02-07-03, 02:35 PM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by zatnktel
install both the kernel rpm and the glx rpm then install the tar balls
Um... you don't have to install from tarball if the RPMs work... and if you do have to install from tarball, then get rid of the RPMs first.

Quote:
with ./configure ...
Again, there is no configure script in these drivers. Just run make as root, or make as a user and make install as root.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-07-03, 04:41 PM   #8
silentdragon48
Registered User
 
Join Date: Feb 2003
Posts: 15
Question

Ok here are 2 helpful things:
1) my XF86Config file (has extension .txt just for uploading purposes). Perhaps one of you hyper-smart and wonderfully helpful people can find/fix my stupid mistake.
2) The error messages recieved on the execution of the "startx" command

Error messages:
#: startx
execve failed for /etc/X11/X (errno 2)
**system waits for about a minute **
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

That's it folks, that's all I get. This sounds like it can't find the driver. Please do take a look at my XF86Config file, I'm seriously confused. Another note: This is still using the RPM installs that I listed above in my 1st post (I think). I have not downloaded the tar balls, and if I do have to use them which ones do I download? I feel really stupid, but honestly the more I work on this problem the more confused I become.

Help me... I'm an idiot....
~SD48
Stuck in runlevel 3, a lot like my cars, always in drive, never overdrive.
Attached Files
File Type: txt xf86config.txt (14.3 KB, 108 views)
silentdragon48 is offline   Reply With Quote

Old 02-07-03, 04:59 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

There's nothing wrong with that config file, at least not that I can see.

About your comment in there with VideoRam, that's not even relevant. The nVidia drivers don't even honor that setting if you uncomment it, so don't worry about it. Leave it commented out.

Quote:
execve failed for /etc/X11/X (errno 2)
errno == 2 means (check /usr/include/asm/errno.h) the file that you're trying to execute doesn't exist.

Are you sure you have X installed? If you are sure, post the first 30-40 lines of your startx script (should be /usr/X11R6/bin/startx). At the top, there will be a list of files that it looks for for settings like that. Mine lists (among others) $HOME/.xserverrc, and /etc/X11/xinit/xserverrc, with the fallback /usr/X11R6/bin/X. If either of the xserverrc files exist, post them as well. If not, make sure the fallback "defaultserver" exists, because that's what's trying to execute /etc/X11/X (which doesn't exist).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-07-03, 05:47 PM   #10
silentdragon48
Registered User
 
Join Date: Feb 2003
Posts: 15
Default

Ok, per your request I've posted the first 38 lines of my startx script (kinda garbled, but open it up in word and it seems fine, is that odd?) also, something wierd, it lists the file etc/X11/sinit/xserverrc, that file doesn't exist on my system. Does this sound like a need to reinstall X? If that is the case what do I need to do to make sure the install goes correctly. and thanks for the wonderful tip about errno.h and helping me out.
Attached Files
File Type: txt startx.txt (911 Bytes, 115 views)
silentdragon48 is offline   Reply With Quote
Old 02-07-03, 05:51 PM   #11
junkieclown
Helium Abuser
 
junkieclown's Avatar
 
Join Date: Nov 2002
Location: Summers in Rangoon, but mostly in my evil underground lair and Volcano laboratory. though
Posts: 45
Default

Here's a couple of things:

can you modprobe the nvidia module into the kernel?
lsmod first to see if nvidia is loaded. If not try to load it:
modprobe nvidia
If that doesn't work then there' s a problem with the Nvidia driver installation, and probably nothing further in this post will be useful until loading the nvidia module is straightened out.

If you can load the nvidia module, or if modprobe says nvidia is already loaded, then ...

Make sure the fontserver is running - and use chkconfig to have it started on boot. ::

service xfs restart
chkconfig --level 35 xfs on
-------------------------------------------------------
Edit /etc/X11/XF86Config and look for fontpath section (just below rgbpath in Section "FILES"

Comment out all the /usr/X11R6/lib/X11/font/ blahblah lines

change the fontpath section to look like this:

FontPath "unix/:7100"

# FontPath "/usr/X11R6/lib/X11/font/ blahblah"
# FontPath "/usr/X11R6/lib/X11/font/ blahblah"
etc...

(the FontPath "unix/:7100" line tells X to contact the fontserver for fonts)

This matter of the fontpath may not be so critical --it can be made to work either way-- but if you specify a font directory in XF86Config and it's not really there it's usual for the X server to bomb on start up. Probably best to change the FontPath to use xfs as described above.
The error message does say "File not found" - Fontpaths are files in the FILES section of the X config file --maybe this is the not found file the error message refers to.
Or it could be the mouse -- I'll get to that in a second.
-----------------------------------------
Now about the monitor section: you didn't say whether you found the manual to the monitor. Did you ?

Generic values offered in xf86config (eg; "a monitor that will do 1280x1024 at 60hz" ) will at least work , but produces a bad looking screen. If you know the ranges for certain you will get all the performance your monitor can give.

--------------------------------------------------

Now the mouse. This looks like it could be a problem that might produce the "FIle not found " error you see in your console.

Is your mouse USB and hooked up to a usb port?
Is it an Intellimouse?

Please feel free to post every little descriptive marking you can find on the mouse- the bottom of the mouse or the box.

Now about the missing file. Do you have a file named 'usbmouse' in /dev ?
That's how usb mice are set up in RH8, but looking at a RH7.2 server around here, I don't see any such /dev/usbmouse. I doubt you have one.

Saying "use /dev/usbmouse " was a bit of bad advice on my part. There is a difference in the way USB peripherals are handled between RH7 and RH8 and I'm not sure exactly how to refer to the mouse.

If you really have a USB mouse , you'll need to edit XF86Config so that the location /dev/usbmouse is changed to some usbmouse device file that actually exists like /dev/input/mice

or to create a symbolic link in /dev to that existing device file.
eg: ln -s /dev/input/mice /dev/usbmouse
and then keep the reference to usbmouse in the X config file. That may not work....

Once you're done changing /etc/X11/XF86Config , copy it over /etc/X11/XF86Config-4

anyway,
I'm looking for more information on that point about the usb mouse device file now.
------------------------------------
There is a separate issue of mouse configuration --how GPM uses the mouse when your in console mode. mouseconfig sets up the mouse options used by GPM in a file /etc/sysconfig/mouse
junkieclown is offline   Reply With Quote
Old 02-07-03, 06:03 PM   #12
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Quote:
Originally posted by silentdragon48
(kinda garbled, but open it up in word and it seems fine, is that odd?)
No, not really odd, but I'd be EXTREMELY careful opening ANYTHING up in Word. It has been known to take plaintext files (such as your startx script) and mangle them beyond all belief. Then again, so have Notepad and WordPad. If I were you, I'd use a Linux text editor, they at least won't go changing the file contents without you asking them to. But if the startx script on your system is the same as what's been posted here, it should be OK.

Quote:
also, something wierd, it lists the file etc/X11/sinit/xserverrc, that file doesn't exist on my system.
That should be fine. The script checks through all the settings at the top, and if any of them don't exist (like $HOME/.xinitrc for example), it skips to the next one. If neither of them exist (for example, if you had neither a $HOME/.xinitrc nor an /etc/X11/xinit/xinitrc), then it would go with the default one.

However, according to what you've posted here, there is no default set up. Which is probably the problem. Add a line to the file, that looks like the following:

defaultserver=/usr/X11R6/bin/X

to set up a default. Make sure that /usr/X11R6/bin/X exists, first, obviously.

Quote:
Does this sound like a need to reinstall X?
Probably not. Just edit the script by adding the defaultserver line, and that should fix it.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
EA gains Linux Attention. Better Quality Drivers Please! Ruinairas NVIDIA Linux 4 05-09-12 01:12 PM
295.49 (long-lived branch release) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-03-12 10:42 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 03:47 PM

All times are GMT -5. The time now is 07:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.