Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-28-06, 10:15 AM   #13
RussyB
Registered User
 
Join Date: Jul 2006
Posts: 5
Default Re: yet again screen frozen mouse moves bug

Quote:
Originally Posted by netllama
RussyB, I have a few questions:
0) Have you verified that you're using the latest BIOS for the motherboard?
1) If you set NvAGP to 0 in xorg.conf does that have any impact?
2) If you boot with the noapic and/or acpi=off kernel parameters, does that have any impact?
0) yes i have the latest BIOS

1) i have looked at xorg.conf and not sure what you mean on this

2) a bit avanced for me

sorry i'm fairly new to linux
RussyB is offline   Reply With Quote
Old 07-28-06, 11:29 AM   #14
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default Re: yet again screen frozen mouse moves bug

Hi,

I have an Nvidia 7800 GTX PCI Express and have had several problems with the system freezing but the pointer still working in Suse 10.1 x86_64 - I then installed Kubuntu 6.06 x86_64 and the same thing ... both with the 1.0-8762 AMD x86_64 driver

I am now back with Suse 10.1 and I have installed the legacy drivers (1.0-7182) instead and the system has been perfectly stable for over a week now and performance seems fine.

Hope this helps.
steerpike is offline   Reply With Quote
Old 07-28-06, 12:06 PM   #15
whitesuit
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: yet again screen frozen mouse moves bug

Ok, so I compiled the new kernel (2.6.17.7) completely without acpi support. Still the problem occurs. Something I've noticed, this time, before trying to reproduce the problem I left a media player open and playing music. When the problem happened the music continued to play (but the screen froze and mouse continued to move). No input was recognized (cntrl + alt + backspace didnt do anything). It seems it's not a kernel problem but a driver problem.

@ steerpike : I don't see why I should use legacy drivers if my card (Fx 5200) is not on the legacy list. But i appreciate the information. I'd like information from Nvidia if this is recommended.

Thank you,
whitesuit is offline   Reply With Quote
Old 07-28-06, 12:11 PM   #16
RussyB
Registered User
 
Join Date: Jul 2006
Posts: 5
Default Re: yet again screen frozen mouse moves bug

Quote:
Originally Posted by netllama
RussyB, I have a few questions:
0) Have you verified that you're using the latest BIOS for the motherboard?
1) If you set NvAGP to 0 in xorg.conf does that have any impact?
2) If you boot with the noapic and/or acpi=off kernel parameters, does that have any impact?
ok with a little help i have now booted with the "noapic quiet" kernel parameters
and it now seems alot happer ie not freezeing X within 5 mins, many thanks for your help
RussyB is offline   Reply With Quote
Old 07-28-06, 01:39 PM   #17
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: yet again screen frozen mouse moves bug

If booting with noapic fixes the problem then you're likely hitting a BIOS bug.

-Lonni
netllama is offline   Reply With Quote
Old 07-28-06, 04:37 PM   #18
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: yet again screen frozen mouse moves bug

steerpike, 1.0-7182 doesn't support the GeForce 7800 at all. You're likely falling back to a generic codepath with degraded performance.
netllama is offline   Reply With Quote
Old 07-28-06, 05:03 PM   #19
whitesuit
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: yet again screen frozen mouse moves bug

netllama, any more ideas of what I should try?
whitesuit is offline   Reply With Quote
Old 07-28-06, 05:41 PM   #20
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: yet again screen frozen mouse moves bug

I'm trying to locate your motherboard here to attempt to reproduce the crash. Does your motherboard have the VIA KT400 chipset?

Also, do you happen to have a null modem cable handy to setup a serial console?

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 07-28-06, 11:05 PM   #21
whitesuit
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Re: yet again screen frozen mouse moves bug

Quote:
Originally Posted by netllama
I'm trying to locate your motherboard here to attempt to reproduce the crash. Does your motherboard have the VIA KT400 chipset?
Yes, it has.

Quote:
Also, do you happen to have a null modem cable handy to setup a serial console?
To ssh to the machine ? I suppose I could do that. I'm sure the system doesn't lockup because as I described earlier the music continued to play when the problem happened.

I'm now testing the newly released ati drivers on my radeon to see if that will crash...I also had problems with the fglrx (ati's proprietary driver).

Thank you for the effort.
whitesuit is offline   Reply With Quote
Old 07-29-06, 04:36 AM   #22
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default Re: yet again screen frozen mouse moves bug

I understand that the legacy drivers don't properly support my 7800 gtx, but the performance seems fairly good (I'm using the system for work as opposed to games although opengl seems to run nicely) and the system is 100% stable with them.

The card runs perfectly under windows with the latest XP drivers and it's only since upgrading to Suse 10.1 that the problems with the linux drivers started (10.0 was fine).

I can't use the built in X nvidia driver as it will not seem to work at my monitors native res 1600x1200.

I would love for the proper drivers to work, but I can't be having random crashes the whole time so looks like I'm stuck with the legacy ones for the moment.

BTW I am running :

Suse 10.1 X86_64 (Also same problem with Kubuntu 6.06)
AMD X2 4400+
DFI Lanparty nF4 SLI-DR
Inno3d GeForce 7800 GTX 256mb 256bit PCI-E
Audigy2 ZS 7.1 Pci
NEC/Mitsubishi LCD2070NX
Hiper PSU 580w
4 x 512mb Crucial Ram
steerpike is offline   Reply With Quote
Old 07-30-06, 12:35 PM   #23
RussyB
Registered User
 
Join Date: Jul 2006
Posts: 5
Default Re: yet again screen frozen mouse moves bug

Quote:
Originally Posted by netllama
If booting with noapic fixes the problem then you're likely hitting a BIOS bug.

-Lonni

ok i was rong, x still freeze with noapic quiet, acpi off both and i tryed NvAGP0 in xorg.conf, still have freeze problem, if i use the "nv" driver no problems atall....

thx russ
RussyB is offline   Reply With Quote
Old 07-31-06, 08:48 AM   #24
mawahh
Registered User
 
Join Date: Jul 2006
Posts: 5
Default Re: yet again screen frozen mouse moves bug

Same problem here. I've got hangs almost daily after log in and starting firefox. Very annoying! Mouse moves still and I can change the terminal and kill X to start again. The "usual suspects" like NvAGP off etc did not dispose the problem.

Ubuntu 6.06
Asrock Mainboard 939NF4SATA2
GeForce 6100 onboard

BTW, GoogleEarth shakes 3d patterns randomly up, this is an old driver bug, also

http://bbs.keyhole.com/ubb/showthrea.../page/1#446278
http://www.secretlab.ca/google-earth-screenshot-1.png

When can we expect a driver update?
mawahh is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Doh, M$ Optical Intellimouse Explorer not good for games Creole General Hardware 18 09-28-02 09:55 PM

All times are GMT -5. The time now is 10:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.