Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-30-06, 11:51 AM   #1
pierrec
Registered User
 
Join Date: Jul 2006
Posts: 9
Default Intermittent freezing problem: I think I've cracked it!

My original problem is described in this thread: http://www.nvnews.net/vbulletin/showthread.php?t=74171

So I've been goofing around with settings for 2 solid days to get 3d apps to work, and I think I've finally found the problem. It seems that the nVidia driver overclocks the FX5200. I enabled CoolBits and this is what nvclock reports when the card starts:

Code:
ppc@akula:~$ nvclock -s
Card:           nVidia GeforceFX 5200
Card number:    1
Memory clock:   265.500 MHz
GPU clock:      249.750 MHz
(nvidia-settings doesn't even see the CoolBits turned on, oh well)

So, I lowered both the memory clock and GPU clock to 220MHz and, lo and behold, 3D works good and solid!

Now, I've played around with several frequencies, and the problem reoccurs more and more frequently as the frequency goes up. At 230MHz, Tuxracer halts after a little while, but not always, so I may lower it even further as I test some more, don't take 220MHz as a magic number. Also, setting the GPU clock higher than the memory clock makes the monitor scream for mercy and crashes the computer, so I'd advise to always set them both together at the same value if you don't want to brick your monitor, at least with the same card as mine.

After rebooting several times, I noticed that the default clock speeds (at least the memory clock speed) seems to vary somewhat at each restart. My guess is nVidia added some not-so-clever speed test that determines how hard the card can be driven. What would be good is if someone at nVidia is listening and tells us what the safe, bottom values are for these frequencies for each card (fat chance...). Also, as a side note, I don't know if this applies to video cards, but having severely underclocked (and smoked) PCs in the past, I'd advise against lowering the frequencies too much. The lowest I've tried for the FX5200 is 200MHz so far and it seems happy enough. But officially-sanctioned safe values from nVidia would be nice.

To make this report complete, I'm not certain this single solution is what got the 3D finally going (although I have a strong feeling it is), so I'll also detail what else I did since I ranted yesterday about this problem:

- Switched to linux-2.6.17.7: no result
- Enabled high-memory (since I have 1G of ram and an AGP aperture of 128M, I figured the total is over 1G so Linux might have some page table issues, who knows...): no result
- Enabled/installed the i2c temp sensors: no result, the video card doesn't overheat
- Tried to drop a 2 year-old nvidia binary core into the 8762 driver distribution and hacking files around to get it to compile and insmod without dependency problem: crashed the box
- Backed to version 7182-legacy of the nVidia driver: no result
- Backed to version 8756 of the nVidia driver: some results: oolite seemed to lock up less fast, a minute or two instead of seconds. In retrospect, I guess this driver uses more relaxed frequency settings.
- Underclocked the driver manually with nvclock: problem seemingly solved (I haven't tested a lot yet, but I'll sure play games all night tonight to check it out :-) )

If you have the frozen-3D problem, I hope this might help you too.

EDIT: oolite running for over 2 hours now in fullscreen and windowed mode, with all sorts of complex 3d things happening, and no trouble at all. It's rock solid.

Last edited by pierrec; 07-30-06 at 02:17 PM.
pierrec is offline   Reply With Quote
Old 08-01-06, 09:50 AM   #2
darwinfink
Registered User
 
Join Date: Aug 2006
Posts: 2
Talking Intermittent freezing problem: I know I've cracked it!

Solved!

I've tried your solution (keeps my vidcard cool ;-), but problems are remaining.

However I did some research on my own and discovered that this phenomenon is the result of at least 2 different problems:

1)
If your X crashes in use of GL: overclocking problem (nvclock fixes it)

2)
Lockup in Firefox (opening new tab) and/or kcontrol: causes nvrm (nvidia agp driver) to hang and because this driver has high priority everything hangs except the mouse cursor, which has the same priority.

(In my case dmesg reveales: NVRM: Xid: 13, 0000 02005600 00000056 00000c28 00230195 00000080)


Solution: Disable "RenderAccel" in your xorg.conf (#Option "RenderAccel" "True") and everything works just fine!
darwinfink is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Screen flash briefly problem tamahome NVIDIA Windows Graphics Drivers 8 09-19-02 12:07 PM
Win XP problem with regards to CD ROM MUYA Microsoft Windows XP And Vista 4 08-03-02 09:51 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 07:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.