Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-06, 01:06 AM   #1
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Enabling SLI == hardlock at startx

Tested the system under windows, seemed to work fine in the GRAW demo. Drivers recognized the dual-GPU configuration. In linux, I added a section for the second device and added Option SLI "true" in the Screen section with all the other options, but get a hard lock when I run startx. If I disable SLI, I get an error saying there's no device section for PCI:2:0:0, but there is. Even running nvdia-xconfig doesn't get me any where. Any ideas? I'm sure it's just something in my config that I missed...
Attached Files
File Type: zip nvidia-bug-report.log.zip (29.2 KB, 138 views)
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-01-06, 11:14 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Enabling SLI == hardlock at startx

If you're using SLI, you should only have one Device section. If you're not using SLI or TwinView, you need (at least) two device sections, each with a BusID option.

It would be useful to see whether booting with the pci=conf1 kernel parameter has any impact on the instability. Also removing the following options for test purposes:
CursorShadow
MultisampleCompatibility
XvMCUsesTextures
AllowGLXWithComposite
Coolbits
TripleBuffer
AddARGBGLXVisuals

You should also verify that you're using the latest BIOS for the motherboard, and test with a newer kernel (2.6.17.x).

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-02-06, 12:02 AM   #3
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Lonni,

With a stripped (very) xorg.conf, I was able to get into X. However, running glxgears resulted in an immediate hard lock.

I'm going to need a reason to compile a kernel from source before I try that, given that it usually takes several days for me to get a working .config that both compiles and boots. Just "try it" isn't really a sufficient reason. Is there a known problem with the ubuntu 2.6.15-26-k7 kernel?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-02-06, 01:00 AM   #4
mythtv_buster
Registered User
 
mythtv_buster's Avatar
 
Join Date: Aug 2006
Location: Northern CA
Posts: 6
Default Re: Enabling SLI == hardlock at startx

Quote:
Originally Posted by sphincter
I'm going to need a reason to compile a kernel from source before I try that, given that it usually takes several days for me to get a working .config that both compiles and boots.=
Hmmm. There is absolutely no need to start the kernel config from scratch with each new kernel and it sounds like you might be doing that.

1) Copy the .config file from current kernel source tree that works to the new/unbuilt kernel source tree.
2) Run "make oldconfig" in the new source tree. This will only ask you to configure things that are new since your previous kernel and will keep all your old settings. Generally you can take the default answer for the new items.
3) Make and install normally -- it should just work.

If you have any drivers outside of the kernel source tree, you will need to rebuild them too. Probably the only one you need to worry about is the nvidia driver though. This can be done after the new kernel is built and installed but before you boot using it. All in all it should take no more than an hour and that includes untarring the new kernel source tree.

I've built kernels probably at least 200 times over the years and this has never failed me. (I used to be in charge of the kernel, among other things, used in an embedded product so between that and my personal projects/machines the builds add up pretty quick.)
mythtv_buster is offline   Reply With Quote
Old 08-02-06, 07:56 AM   #5
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Thanks, but that never works for me when the .config comes from heavily patched kernels. But that's what I've usually done, and why it takes several days. I usually spend the first couple days just figuring out what parts of the .config depend on some patch that's not present in the generic kernel source. At least, that was my experience with Fedora. I'm on ubuntu now, so I don't know if that will still be the case or not.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-02-06, 09:51 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Enabling SLI == hardlock at startx

sphincter, the reason to try a newer kernel is because the Ubuntu kernel is a bit old, and you could be hitting a kernel bug.

Did you verify that you're using the latest BIOS for the motherboard?
Did you test the kernel parameters that I suggested?
netllama is offline   Reply With Quote
Old 08-02-06, 11:53 AM   #7
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Lonni,

Yes, but none of it seemed to make any difference.

Board is an Abit AN8-SLI running bios 20 (latest from site).
I booted with the kernel parameter, but it didn't make any difference. X still locked at start. I also had all the parameters you listed commented out.
I then used kde-guidance to gen a default xorg.conf, and I got in.
I then added the option to enable SLI and was able to get in after a couple of tries, but as soon as I ran glxgears, the system hard locked again.
Here's the xorg.conf that got me in.
Attached Files
File Type: txt xorg.conf.txt (4.9 KB, 206 views)
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-02-06, 11:56 AM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Enabling SLI == hardlock at startx

Have you tested with noapic and/or acpi=off as well?

Testing a 2.6.17.x kernel is the next useful experiment.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 08-02-06, 01:50 PM   #9
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

I'll test those parameters tonight and update the post. Then I'll be out of town until Sunday, so won't be able to try anything else until then. But I'll be on vacation for 10 days, so I'll have a lot of time to work on this.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-02-06, 10:02 PM   #10
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Well, booting with noapic and acpi=off gets me in X, but only because I'm now getting:

grep -i sli /var/log/Xorg.0.log
(**) NVIDIA(0): Option "SLI" "auto"
(**) NVIDIA(0): NVIDIA SLI enabled; using auto-selected rendering method.
(WW) NVIDIA(0): Failed to initialize SLI! Reason: Unknown error. Only one
(WW) NVIDIA(0): GPU will be used for this X screen. Please see the SLI

I'm thinking it may because I'm having to disable ACPI?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-02-06, 10:20 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Enabling SLI == hardlock at startx

Yes, SLI will not work without ACPI.
netllama is offline   Reply With Quote
Old 08-02-06, 10:48 PM   #12
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

I was able to get the system to go into X after several tries. The problem appears to be that I only need noapic, but with that kernel option, my USB receiver is not being recognized properly much of the time. This causes X to think there's no mouse. It's just reboot until the receiver is properly recognized and X starts. When they aren't, I get the splash and the video is hung until reboot. SSH'ing into the system doesn't let me just kill X and restart it.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
680 GTX SLI + 560 Physx bench for those interested gerardfraser NVIDIA GeForce 600 Series 2 06-20-12 04:34 AM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM

All times are GMT -5. The time now is 07:25 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.