Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-24-06, 08:25 AM   #37
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

I've also determined that this isn't related to APIC. Booting with noapic leaves

[17184644.496000] irq 7: nobody cared (try booting with the "irqpoll" option)
[17184644.496000] [<c014e31a>] __report_bad_irq+0x2a/0x90
[17184644.496000] [<c014daed>] handle_IRQ_event+0x3d/0x70
[17184644.496000] [<c014e427>] note_interrupt+0x87/0xe0
[17184644.496000] [<c014dc1c>] __do_IRQ+0xfc/0x110
[17184644.496000] [<c0105c69>] do_IRQ+0x19/0x30
[17184644.496000] [<c0103ef6>] common_interrupt+0x1a/0x20
[17184644.496000] [<c0101030>] default_idle+0x0/0x60
[17184644.496000] [<c010105c>] default_idle+0x2c/0x60
[17184644.496000] [<c010111b>] cpu_idle+0x6b/0xb0
[17184644.496000] handlers:
[17184644.496000] [<f8be8c90>] (ohci_irq_handler+0x0/0x8c0 [ohci1394])
[17184644.496000] [<f8be8c90>] (ohci_irq_handler+0x0/0x8c0 [ohci1394])
[17184644.496000] [<f955c467>] (nv_kern_isr+0x0/0x64 [nvidia])
[17184644.496000] Disabling IRQ #7


appearing in dmesg, instead of the system complaining about IRQ 58.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-24-06, 07:34 PM   #38
diablo266
Registered User
 
Join Date: Aug 2005
Posts: 3
Default Re: Enabling SLI == hardlock at startx

Quote:
Originally Posted by sphincter
Please file a bug report. NVIDIA can't verify that it's the same issue unless you do.

How do i go about fileing a bug report? Also, others on the ubuntu forums are having the same trouble: http://ubuntuforums.org/showthread.php?t=232635
diablo266 is offline   Reply With Quote
Old 08-24-06, 11:52 PM   #39
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

http://www.nvnews.net/vbulletin/showthread.php?t=46678
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-25-06, 09:08 AM   #40
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Good news, everyone! The 8774 driver has allowed me to get in and out of 3D apps twice now, without a lockup.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-26-06, 07:30 PM   #41
diablo266
Registered User
 
Join Date: Aug 2005
Posts: 3
Default Re: Enabling SLI == hardlock at startx

Quote:
Originally Posted by sphincter
Good news, everyone! The 8774 driver has allowed me to get in and out of 3D apps twice now, without a lockup.
was just wondering if you have had any more success sense you last posted? Is everything stable now?
diablo266 is offline   Reply With Quote
Old 08-26-06, 08:46 PM   #42
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

I just did a 100 mile ride at Hotter 'n Hell, so I haven't had a chance to do any testing since yesterday. I'll mess with it some more tomorrow after I go my morning ride.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-27-06, 10:20 PM   #43
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Bah.... it worked until I rebooted. Now the system locks up hard when I exit a 3D game/app, just like before.
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 08-31-06, 10:20 PM   #44
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

Something a bit different... the system didn't hard lock after adding both pci=conf1 and irqpoll to my kernel line, but X did lock and this showed in the dmesg output:
[17225140.124000] NVRM: Xid (0002:00): 2, CCMDs 00000000 0000004d 000002c0 0fff0000 00000006
[17225140.124000] NVRM: Xid (0001:00): 28, L0 -> L0
[17225140.308000] NVRM: Xid (0002:00): 28, L1 -> L0
[17225173.764000] NVRM: Xid (0002:00): 3, C 00000001 SC 00000005 M 000002fc Data 00000003
[17225191.412000] NVRM: Xid (0002:00): 3, C 00000001 SC 00000005 M 000002fc Data 00000003
[17225193.056000] NVRM: Xid (0002:00): 3, C 00000001 SC 00000005 M 000002fc Data 00000003
[17225194.704000] NVRM: Xid (0002:00): 3, C 00000001 SC 00000005 M 000002fc Data 00000003

any ideas?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote

Old 09-03-06, 08:17 PM   #45
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

No feedback on what those XID messages indicate?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-05-06, 04:14 PM   #46
sphincter
Registered User
 
sphincter's Avatar
 
Join Date: Mar 2003
Posts: 154
Default Re: Enabling SLI == hardlock at startx

I guess I could also mention that the locks now occur when the system tries to restore the desktop resolution. Is that any help?
__________________
It never gets easier, you just go faster. - Greg Lemond
sphincter is offline   Reply With Quote
Old 09-06-06, 03:47 PM   #47
am2020
Quadro4
 
Join Date: Aug 2002
Location: USA
Posts: 63
Default Re: Enabling SLI == hardlock at startx

I have a slightly different problem, but may be related. I have a dual dual-core opteron AMD system with dual FX4500 in SLI (HPXW9300)/

Running ubuntu 6.06 will only detect one of the cards. Doesn't matter what
kernel I use i686, x86_64, any of the 2.6.15.x kernels included. NONE will detect
both cards (as shown with lspci).

I will be waiting for next ubuntu 6.10 which uses kernel 2.6.17 (cross fingers.)
They are releasing it on late October. BTW, I tried their Knot2 (an early version)
and still no luck.

So far my second card is working well as a transducer from electricity to heat.......
am2020 is offline   Reply With Quote
Old 09-06-06, 03:53 PM   #48
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Enabling SLI == hardlock at startx

am2020,
The problem that you're reporting is unrelated to the rest of this thread. Your problem is a kernel PCI config space bug. You should report it back to Ubuntu.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
680 GTX SLI + 560 Physx bench for those interested gerardfraser NVIDIA GeForce 600 Series 2 06-20-12 04:34 AM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM

All times are GMT -5. The time now is 07:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.