Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-06, 09:47 PM   #1
Aphax
Registered User
 
Join Date: Nov 2005
Location: Netherlands
Posts: 19
Send a message via ICQ to Aphax Send a message via MSN to Aphax
Default 7950 GX2 - Failed to Initialise SLI with unknown error

I am trying to get SLI working with my XFX 7950 GX2 card on Gentoo Linux (kernel 2.6.17) with the 8762 drivers. Unfortunately during X startup, SLI fails to initialize, leaving the following message in my Xorg log:

Quote:
671 (**) NVIDIA(0): Option "SLI" "yes"
672 (**) NVIDIA(0): Enabling RENDER acceleration
673 (**) NVIDIA(0): NVIDIA SLI enabled; using auto-selected rendering method.
674 (WW) NVIDIA(0): Failed to initialize SLI! Reason: Unknown error (2). Only
675 (WW) NVIDIA(0): one GPU will be used for this X screen. Please see the SLI
676 (WW) NVIDIA(0): Appendix in the README for troubleshooting suggestions
I have checked the README SLI section but all seems to be in order, I have ACPI enabled in the kernel, and lspci seems to indicate that both devices are detected and connected to the PCI Bridge:

Quote:
03:00.0 3D controller: nVidia Corporation Unknown device 0294 (rev a1)
Subsystem: XFX Pine Group Inc. Unknown device 2214
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at e1000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at 9000 [size=128]
[virtual] Expansion ROM at e2000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0

04:00.0 VGA compatible controller: nVidia Corporation Unknown device 0294 (rev a1) (prog-if 00 [VGA])
Subsystem: XFX Pine Group Inc. Unknown device 2214
Flags: bus master, fast devsel, latency 0, IRQ 20
Memory at e3000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at e4000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at a000 [size=128]
[virtual] Expansion ROM at e5000000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [78] Express Endpoint IRQ 0
And the tree output (EDIT: Looks like some whitespace got stripped, the [0000:04] device is right below [0000:03]:

Quote:
-[0000:00]-+-00.0 Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub
+-01.0-[0000:01-04]----00.0-[0000:02-04]--+-00.0-[0000:03]----00.0 nVidia Corporation Unknown device 0294
| \-01.0-[0000:04]----00.0 nVidia Corporation Unknown device 0294
+-1b.0 Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller
+-1c.0-[0000:05]--
+-1c.2-[0000:06]----00.0 Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express
+-1d.0 Intel Corporation 82801G (ICH7 Family) USB UHCI #1
+-1d.1 Intel Corporation 82801G (ICH7 Family) USB UHCI #2
+-1d.2 Intel Corporation 82801G (ICH7 Family) USB UHCI #3
+-1d.3 Intel Corporation 82801G (ICH7 Family) USB UHCI #4
+-1d.7 Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller
+-1e.0-[0000:07]--
+-1f.0 Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge
+-1f.1 Intel Corporation 82801G (ICH7 Family) IDE Controller
+-1f.2 Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE
\-1f.3 Intel Corporation 82801G (ICH7 Family) SMBus Controller
My mainboard (if it matters) is a Gigabyte 8I945PL-G, but I should probably also note that SLI works perfectly under Windows. I have attached a zipped bug-report file.
Attached Files
File Type: zip nvidia-bug-report.log.zip (13.3 KB, 131 views)

Last edited by Aphax; 08-01-06 at 10:08 PM.
Aphax is offline   Reply With Quote
Old 08-02-06, 05:33 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: 7950 GX2 - Failed to Initialise SLI with unknown error

Does your motherboard support SLI? Although the card is a single board you still need a motherboard with SLI support and I don't think this Intel board supports that. But I'm not 100% sure though (some 945/965 can do it).

Or perhaps the drivers just don't support SLI on Intel boards yet that can also be the case.
Thunderbird is offline   Reply With Quote
Old 08-02-06, 08:26 AM   #3
Aphax
Registered User
 
Join Date: Nov 2005
Location: Netherlands
Posts: 19
Send a message via ICQ to Aphax Send a message via MSN to Aphax
Default Re: 7950 GX2 - Failed to Initialise SLI with unknown error

Well, SLI seems to work under Windows so yeah I believe it does, despite the board not being listed on the compatibility list. (the 7950 GX2 was actually traded for a defective 7900 GTX, unfortunately the PC shop assistant failed to mention the fact that it only works on a limited number of motherboards =/ )
Aphax is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 07:47 PM
295.40 295 cannot be compiled on 3.2 kernel delta32 NVIDIA Linux 4 05-27-12 10:47 PM
RPM Source problems LaoTzuTao NVIDIA Linux 10 01-19-03 06:15 AM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 03:54 AM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 10:53 PM

All times are GMT -5. The time now is 07:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.