Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-04-06, 12:53 PM   #1
Gaara
Registered User
 
Join Date: Aug 2006
Posts: 3
Unhappy 7800gt installing Linux issue

Whenever I attempt to install Linux in graphical mode I get a weird corruption that locks up the computer (except the mouse still moves on the screen). Some of the time I get a partial display of the install GUI but it always looks like my monitor was hit by a bat.

I'm running an Athlon x2 3800+
and a Geforce 7800gt

I've tried fedora 6, 5, 4 and Ubuntu. Both 32 and 64bit versions of each.
All of them do the exact same thing.

I ran a test on my 2 roommates computers. One of them had a Geforce 7800gt
and it acted the same as mine is.
The other installed perfectly ::angry face::

So my conclusion is that the 7800 isn't supported during an install. (Since it says "display device nVidia unknown 0900"...or something close to it before it loads x.)

So I install in text mode and get the nvidia drivers installed but when I startx the same problem happens.

I've seen this problem a bunch of times, and no one ever gets it resolved...the threads just die.

Long story short...I'm wondering if there is anyway to get the driver data from the .run file on nVidia's website and use it in a "linux dd" install? Maybe force the system to work with my card before it craps out.

Thanks in advanced for any help at all,
Gaara is offline   Reply With Quote
Old 08-04-06, 12:56 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7800gt installing Linux issue

No, you cannot install the nvidia X driver within anaconda without significantly re-engineering the Redhat install process. The simple solution to your problem is to perform a text based installation, and then install the nvidia X driver afterwards.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-04-06, 12:59 PM   #3
Gaara
Registered User
 
Join Date: Aug 2006
Posts: 3
Default Re: 7800gt installing Linux issue

Quote:
Originally Posted by netllama
No, you cannot install the nvidia X driver within anaconda without significantly re-engineering the Redhat install process. The simple solution to your problem is to perform a text based installation, and then install the nvidia X driver afterwards.

Thanks,
Lonni

Thanks for the quick reply,
I have installed in text mode and installed the nvidia drivers but X continues to not work. The same corruption/lock up happens.
Gaara is offline   Reply With Quote
Old 08-04-06, 01:01 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7800gt installing Linux issue

Please generate and post an nvidia-bug-report.log immediately after experiencing the instability.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-04-06, 01:30 PM   #5
Gaara
Registered User
 
Join Date: Aug 2006
Posts: 3
Default Re: 7800gt installing Linux issue

Here is the bug report you requested.
(sorry about the zip file, the upload limit was 100k and the file is 108k)
Attached Files
File Type: zip nvidia-bug-report.zip (20.5 KB, 118 views)
Gaara is offline   Reply With Quote
Old 08-04-06, 01:40 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7800gt installing Linux issue

According to your bug report, the driver wasn't installed (correctly):

(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.4
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "kbd"
(II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.0.0, module version = 1.0.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.5
(EE) No drivers available.


See:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Responds to Reports of Kepler V-Sync Stuttering Issue Rieper NVIDIA GeForce 600 Series 13 03-03-13 10:56 PM
302.17 for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-16-12 04:12 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM

All times are GMT -5. The time now is 02:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.