Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-03, 02:38 AM   #1
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default UT2003 upgrade problems here

Let me start off by saying that I am in NO WAY a guru when it comes to linux

That being said.....

Im running Mandrake 9.0, Newest nVidia drivers (4191's), Installed the drivers via this walk-thru (http://www.speculation.org/garrick/nvidiainstall.txt), All went well, The game ran so awsome.......

Now, I need to get to the origins of My problem here, I had borrowed a frinds copy to verify that it actually was able to be installed on linux & run good.....

So it did & I went & bought My own copy...

Me being a newb to linux didnt know that it has un-installs like Windows & just deleted the entire directory & tried re installing the game again....


Install was screwy & I had to find out where it was keeping setting that lingered over from the 1st install & get rid of them by deleting all the contents of /.ut2003 in root & My home directory

Now that being cleared up & did a full re install & the game again runs like nice, No glitches except for the whole reason I am here.....................

I donloaded the newest verion on the patch "ut2003lnx_full2166.sh.bin", tried to install & got the following results......


[root@localhost UT2003linuxup]# ./ut2003lnx_full2166.sh.bin
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2166 patch................... .................................................. ............................
================================================== ===========
Welcome to the Unreal Tournament 2003 for GNU/Linux 2166 patch
================================================== ===========

Would you like to read the README for this update? [Y/n]: n

================================================== ===========
Would you like to apply this update? [Y/n]: y

================================================== ===========
Performing update:
ERROR: No matching delta for /home/qwiqshot/games/ut2003/System/XWebAdmin.u
The program returned an error code (3)
[root@localhost UT2003linuxup]#


so I said hell maybe it was a bad file & dowloaded it from another site & got the same results, So I went & got the even newer one that just got released "ut2003lnx_full2186.sh.bin"

now when I tried running this file at 1st wouldnt even let root run it until I set the privilages the same as the other one & even then it shows up as brown text instead of the usual green like the other one does....

Anyways, Here is what I get when I try installing that upgrade

[root@localhost UT2003linuxup]# ./ut2003lnx_full2186.sh.bin
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2186 patch............................................. ....................
================================================== ===========
Welcome to the Unreal Tournament 2003 for GNU/Linux 2186 patch
================================================== ===========

Would you like to read the README for this update? [Y/n]: n

================================================== ===========
Would you like to apply this update? [Y/n]: y

================================================== ===========
Performing update:
ERROR: Can't find /home/qwiqshot/games/ut2003/System/XInterface.tmt
The program returned an error code (3)
[root@localhost UT2003linuxup]#




Any helpful tips other than try re installing the game would be greatly appreciated guys/gals

Qwaz



P.s. notice that the differance between the 2 is very slight

One asks for
XWebAdmin.u & the other asks for
XInterface.tmt

Last edited by Qwaz; 02-12-03 at 02:43 AM.
Qwaz is offline   Reply With Quote
Old 02-12-03, 03:33 AM   #2
PtrToNull
 
PtrToNull's Avatar
 
Join Date: Feb 2003
Location: Kuwait
Posts: 7
Default

Probably a stupid reply, but I noticed you're running as root, and I thought that UT2003 is fully installed in the user's home directory?

Can you try running it as qwiqshot?
__________________
Common sense is not so common.
PtrToNull is offline   Reply With Quote
Old 02-12-03, 03:58 PM   #3
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default

Runs under both Root & qwiqshot

I installed in via root incase My nephews come over & want to play, All I will have them do is log in as a guest & they will have access to the game

The upgrade is the only issue I am haveing troubles with at this time
Qwaz is offline   Reply With Quote
Old 02-13-03, 02:18 AM   #4
kgroombr
Using Linux Since 1995
 
Join Date: Sep 2002
Posts: 130
Default

If any of your files have been edited, that will cause this problem. I sometimes edit the startup script in the game directory with:

xgamma -gamma X.X

if the game doesn't have any option to change brightness in the game or add other options that can't be changed in the game.

If in doubt, delete the whole game directory, reinstall and apply the patch. The game files are kept in your home directory so you won't loose them.

Ken
__________________
Kenton A. Groombridge
kgroombr@comcast.net
http://home.comcast.net/~kgroombr/
kgroombr is offline   Reply With Quote
Old 02-13-03, 07:57 PM   #5
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default Fixed

POsted this in 2 catagories & have resolved allready


The resolution was simply running the AUTO UPDATER

Thats the Smoothest upgrade EVER!! !! !!


Thanks for the efforts tho!!!


Qwaz
Qwaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Linux performance of ut2003 Please Read... Linewbie NVIDIA Linux 17 09-23-02 09:02 AM
Leadtek Nforce problems druga runda CPUs, Motherboards And Memory 4 09-18-02 08:26 AM
To upgrade, or not to upgrade... jnd3 Microsoft Windows XP And Vista 18 09-13-02 11:09 AM

All times are GMT -5. The time now is 01:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.