Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-03, 01:42 PM   #1
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Question Installing nvidia 1.0-4191 and upgraded kernel 2.4.21-pre3

I've a gforce2(go) in my laptop w/ linux rh 8.0.

I've recently made a kernel upgrade (2.4.21-pre3) and now I can't start X.
What i've done was:
1. upgraded kenel
2. install nvidia kernel and glx (1.0-4191) tar.gz (all went well)
3. tried to start X and the Xserver crashes.

my XF86Config is like this:
Section "Module"
Load "dbe"
Load "glx"
Load "extmod"
Load "type1"
Load "freetype"
EndSection
Section "Device"
Identifier "NV AGP"
VendorName "nvidia"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection


Finally the error is: (nvidia part of XFree86.0.log)
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xE8000000
(WW) System lacks support for changing MTRRs
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***

(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Help me please
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote
Old 02-11-03, 05:04 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

When you configured your kernel, you didn't say "yes" to CONFIG_MTRR. It's under "Processor type and features", at least in menuconfig. It's labeled "MTRR (memory type range register) support". Enable that and recompile your kernel. You will probably need to also recompile NVIDIA_kernel after you boot the new kernel.

But that should just be a warning... as for the error, it worked before the kernel upgrade, I assume? Is there anything in dmesg or /var/log/messages from NVRM about it?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-11-03, 06:38 PM   #3
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Unhappy

Before Kernel upgrade it was working.
I couldn't find anything in /var/log/mesages or dmesg related to NVRM
I'm rebuilding the kernel because the MTTR flag was off.
I've placed the entire /var/log/XFree86.0.log in attatch.
thanks
Attached Files
File Type: txt xfree86.0.log.txt (14.7 KB, 113 views)
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote
Old 02-11-03, 07:27 PM   #4
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Default

I've recompiled the kernel and nvidia kernela and the warning vanished but the server still crashes.
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote
Old 02-11-03, 09:33 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

This was 2.4.21-pre3 from kernel.org, correct?

Are you sure DRM is disabled in the kernel config, as well? That MIGHT be a possibility, though I think it's kind of farfetched.

Try a tail -n 350 /var/log/messages >log.txt and post the log.txt here. It may actually not say NVRM, but there might be something informative in there anyway. I don't know of what else to look at, though...

Maybe try 2.4.20, since there is officially no support for the -pre kernels? I've never had problems with them, but maybe... Or maybe try -pre1 or -pre2, to see which version first had the problem introduced? Maybe try -pre4 as well? I don't know, I'm just throwing out ideas here...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-12-03, 09:45 AM   #6
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Default

Quote:
Originally posted by bwkaz
This was 2.4.21-pre3 from kernel.org, correct?

Are you sure DRM is disabled in the kernel config, as well? That MIGHT be a possibility, though I think it's kind of farfetched.
I had DRM suport in kernel with I810 and I830 as modules. Trying to rebuild it now.

Quote:
Try a tail -n 350 /var/log/messages >log.txt and post the log.txt here. It may actually not say NVRM, but there might be something informative in there anyway. I don't know of what else to look at, though...

Maybe try 2.4.20, since there is officially no support for the -pre kernels? I've never had problems with them, but maybe... Or maybe try -pre1 or -pre2, to see which version first had the problem introduced? Maybe try -pre4 as well? I don't know, I'm just throwing out ideas here...
Here is the log:
Attached Files
File Type: txt mesglog.txt (24.4 KB, 119 views)
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote
Old 02-12-03, 11:36 AM   #7
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

If removing DRM doesn't work, maybe adding an alias to load the apm module will? I noticed a couple of places right before X started up, where the log file said "unknown module char-major-10-134", and the character device with major 10 and minor 134 is /dev/apm_bios, which is the apm.o module.

Perhaps adding an alias char-major-10-134 apm to modules.conf and running /sbin/depmod -a might help? I sort of doubt that, but it's a slim possibility.

Could you attach a log.txt from dmesg as well?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-12-03, 12:16 PM   #8
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Unhappy Getting tired of trying..

Quote:
Originally posted by bwkaz
If removing DRM doesn't work, maybe adding an alias to load the apm module will? I noticed a couple of places right before X started up, where the log file said "unknown module char-major-10-134", and the character device with major 10 and minor 134 is /dev/apm_bios, which is the apm.o module.

Perhaps adding an alias char-major-10-134 apm to modules.conf and running /sbin/depmod -a might help? I sort of doubt that, but it's a slim possibility.

Could you attach a log.txt from dmesg as well?
Thanks for the suport.
Actually I'm not using apm but insted I'm using ACPI w/ my laptop, and by that I don't have apm suport in kernel. Is there a way to remove that mesage?

here is the log you asked.
Attached Files
File Type: txt dmesglog.txt (15.0 KB, 120 views)
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote

Old 02-12-03, 02:21 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Was this dmesg run after you tried to startx?

If so, I'm running out of ideas...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-12-03, 06:20 PM   #10
b3x
Registered User
 
Join Date: Feb 2003
Posts: 2
Default

do you by chance have 1gb (or more) of memory ?
b3x is offline   Reply With Quote
Old 02-12-03, 06:36 PM   #11
cyngen
Registered User
 
Join Date: Feb 2003
Posts: 10
Default

No I don't have more than 1GB memory. Why do u ask b3x?
bwkas I'm not completly sure but I think so, I'll try again and get back to you. Do you know what module is char-major-10-135?

thanks both
__________________
-------------------------------------
CYber
eNGEN
Registered Linux User #305020
-------------------------------------
cyngen is offline   Reply With Quote
Old 02-12-03, 07:27 PM   #12
b3x
Registered User
 
Join Date: Feb 2003
Posts: 2
Default

There is a thread on the Gentoo forums regarding this same issue ... many of us who are experiencing the problem have over 1gb memory ...

Though, the other common denominator is a recent upgrade to 2.4.20 ...

I have a queezy feeling that the problem lies within 2.4.20

FYI:
http://forums.gentoo.org/viewtopic.php?t=10872
b3x is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.