Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-12-03, 03:52 AM   #1
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default UT2003 Upgrade problems need help please

Let me start off by saying that I am in NO WAY a guru when it comes to linux

That being said.....

Im running Mandrake 9.0, Newest nVidia drivers (4191's), Installed the drivers via this walk-thru (http://www.speculation.org/garrick/nvidiainstall.txt), All went well, The game ran so awsome.......

Now, I need to get to the origins of My problem here, I had borrowed a frinds copy to verify that it actually was able to be installed on linux & run good.....

So it did & I went & bought My own copy...

Me being a newb to linux didnt know that it has un-installs like Windows & just deleted the entire directory & tried re installing the game again....


Install was screwy & I had to find out where it was keeping setting that lingered over from the 1st install & get rid of them by deleting all the contents of /.ut2003 in root & My home directory

Now that being cleared up & did a full re install & the game again runs like nice, No glitches except for the whole reason I am here.....................

I donloaded the newest verion on the patch "ut2003lnx_full2166.sh.bin", tried to install & got the following results......


[root@localhost UT2003linuxup]# ./ut2003lnx_full2166.sh.bin
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2166 patch................... .................................................. ............................
==================================================
===========
Welcome to the Unreal Tournament 2003 for GNU/Linux 2166 patch
==================================================
===========

Would you like to read the README for this update? [Y/n]: n

==================================================
===========
Would you like to apply this update? [Y/n]: y

==================================================
===========
Performing update:
ERROR: No matching delta for /home/qwiqshot/games/ut2003/System/XWebAdmin.u
The program returned an error code (3)
[root@localhost UT2003linuxup]#


so I said hell maybe it was a bad file & dowloaded it from another site & got the same results, So I went & got the even newer one that just got released "ut2003lnx_full2186.sh.bin"

now when I tried running this file at 1st wouldnt even let root run it until I set the privilages the same as the other one & even then it shows up as brown text instead of the usual green like the other one does....

Anyways, Here is what I get when I try installing that upgrade

[root@localhost UT2003linuxup]# ./ut2003lnx_full2186.sh.bin
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2186 patch............................................. ....................
==================================================
===========
Welcome to the Unreal Tournament 2003 for GNU/Linux 2186 patch
==================================================
===========

Would you like to read the README for this update? [Y/n]: n

==================================================
===========
Would you like to apply this update? [Y/n]: y

==================================================
===========
Performing update:
ERROR: Can't find /home/qwiqshot/games/ut2003/System/XInterface.tmt
The program returned an error code (3)
[root@localhost UT2003linuxup]#




Any helpful tips other than try re installing the game would be greatly appreciated guys/gals

Qwaz



P.s. notice that the differance between the 2 is very slight

One asks for
XWebAdmin.u & the other asks for
XInterface.tmt
Qwaz is offline   Reply With Quote
Old 02-12-03, 06:51 AM   #2
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Use the Loki Game updater to update UT2K3. As it will download and install the patch that's required. I use it, and I've had no problems with all the last patches.

You will find the program in your /usr/local/games/ut2003/updater directory. (loki_update)

Or just look in your menu's and you should see an icon which say's 'Loki Game Updater' and run that.

Also for future reference you can goto the UT2K3 forum, see link below for UT2K3 problems.

http://www.ina-community.com/forums/...s=&forumid=214

Last edited by Wolfman [TWP]; 02-12-03 at 06:55 AM.
Wolfman [TWP] is offline   Reply With Quote
Old 02-12-03, 08:43 AM   #3
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Your problem is that UT2k3 patches are not cumulative. The 2166 patch requires that all previous patches have been applied before it will work. Same with 2186 -- you need to apply 2166 (and all the patches before it) before you apply 2186.

loki_update does this automatically, though, so as Wolfman said, just use it.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-12-03, 04:18 PM   #4
Marty
Registered User
 
Join Date: Nov 2002
Posts: 17
Talking

Thank you Wolfman. I thought my Loki updater was broken. I kept trying to run the "update" file, not the "loki_update" It did just as you said, installed all the patches in order. I thought the first readme for install said if there was a linux update available, it would show up once you were logged into the game server, but this never appeared, so I thought my install was bad somehow. It ran great though, so I just never bothered. Anyway, thanks again.
Marty is offline   Reply With Quote
Old 02-12-03, 05:05 PM   #5
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default

Ill try this once I get home tonight

I didnt know there was an auto updater in there

Ill repost in here if it resolves My problem & thatnks for the tips!!

Qwaz
Qwaz is offline   Reply With Quote
Old 02-13-03, 08:55 PM   #6
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default Nice

Thats got to be the easiest upgrade program EVER


Thanks for the lead Guys/Gals

Qwaz
Qwaz is offline   Reply With Quote
Old 02-13-03, 09:14 PM   #7
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

No Problems, glad to be of help.

I pity the Windows users, as they have to do it manually. I use it for, Descent III, Heretic II, UT, UT2K3 etc.. As most of the titles were ported to Linux by Loki Games, which now no longer exists (Damn). It was great to see that Epic stuck to this format.
Wolfman [TWP] is offline   Reply With Quote
Old 02-15-03, 03:40 PM   #8
Qwaz
Registered User
 
Join Date: Jan 2003
Posts: 15
Default Well

From what I can see its being used by these guys exclusively


http://www.icculus.org/~icculus/ryan/resume.txt

They arent Epic are they?
Laters
Qwaz is offline   Reply With Quote

Old 02-15-03, 05:26 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

The guys at icculus.org aren't the only ones using Loki's tools. Id Software also is (RtCW had a Loki installer), and (as was mentioned previously) so is Epic now.

Which makes sense, the format is a decent one (it's kind of crappy that all the dependencies have to be packaged with the game, but I guess it saves versioning headaches, or something), and Loki had it open-sourced from the get-go, IIRC.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 02-16-03, 08:29 AM   #10
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

I run RTCW on Linux too, but I don't see it in my Loki Updater list??!!
Wolfman [TWP] is offline   Reply With Quote
Old 02-16-03, 09:23 AM   #11
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Yeah, I don't think it uses the updater (too old maybe?); I don't see it either. But the installer was definitely Loki's.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 04:55 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
Linux performance of ut2003 Please Read... Linewbie NVIDIA Linux 17 09-23-02 10:02 AM
Leadtek Nforce problems druga runda CPUs, Motherboards And Memory 4 09-18-02 09:26 AM
To upgrade, or not to upgrade... jnd3 Microsoft Windows XP And Vista 18 09-13-02 12:09 PM

All times are GMT -5. The time now is 05:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.