Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-06, 05:23 PM   #1
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default X crash at 100% CPU Usage

Hi,

I am running suse 10.1 x86_64, specs as follows :

Athlon X2 4400+ (no overclock)
2gb Ram (Corsair 4 x 512)
Nforce 4 Motherboard (DFI Lanparty)
Gforce 7800 gtx PCI-Express

The crash occurs both with the latest drivers and the previous ones.

X is crashing with the following :

NVRM: Xid (0005:00): 13, 0000 01019700 00004097 00001900 04ad0398 00400000

Any help would be much appreciated.

Thanks
steerpike is offline   Reply With Quote
Old 08-28-06, 05:35 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X crash at 100% CPU Usage

Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-29-06, 06:00 AM   #3
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default Re: X crash at 100% CPU Usage

Hi,

I have attached the bug report (had to zip it as it was too large).

Hope you can fix this for me as my workstation is a nightmare and unstable as anything. The only thing that works for me is reverting to legacy drivers which do not seem to crash. Default X driver is no good as it does not seem to want to work at 1600x1200 (native res).

Thanks

Steer.
Attached Files
File Type: zip nvidia-bug-report.log.zip (31.5 KB, 118 views)
steerpike is offline   Reply With Quote
Old 08-29-06, 10:45 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X crash at 100% CPU Usage

I have a few questions:
0) Are any specific steps required to trigger the crash, or is it seemingly random?
1) Have you verified that you're using the latest BIOS?
2) If you boot with the acpi=off and/or noapic kernel parameters, does that have any impact?
3) Does this crash reproduce if you are not using VMware?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 08-29-06, 11:04 AM   #5
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default Re: X crash at 100% CPU Usage

Quote:
Originally Posted by netllama
I have a few questions:
0) Are any specific steps required to trigger the crash, or is it seemingly random?
1) Have you verified that you're using the latest BIOS?
2) If you boot with the acpi=off and/or noapic kernel parameters, does that have any impact?
3) Does this crash reproduce if you are not using VMware?

Thanks,
Lonni
Hi,

0) The crash occurs completely randomly - sometimes after a few minutes other times after a few hours.

1) Is that BIOS for video or motherboard - motherboard is latest, video card i'm not sure - theres nothing new on the inno3d site.

2) Have tried lots of suggestions made in other posts including these, pci=nommconf and turning renderaccel on and off

3) I'm not 100% sure about vmware - I will try it with and without (although without is not a workable option on this workstation). I can tell you that with older Nvidia drivers (1.0-7182) under Suse 10.0 and the same version of VMWare it was rock solid stable.
steerpike is offline   Reply With Quote
Old 08-29-06, 11:45 AM   #6
jdtate101
Registered User
 
Join Date: Jul 2006
Posts: 11
Default Re: X crash at 100% CPU Usage

Are you using irq_balancer ????
As you have multiple core CPU, there is a major bug in irq_balancer in 10.1 with some motherboards which causes lockups at random times (specifically periods of low activity). Symtoms are:

1) Partial lockup with mouse still usable but disks not usable (ie lost irq to serial ata controller)
2) Jumpy mouse and keyboard input.
3) Full lock (lost irq to video controller)

Had this problem in both Ubuntu and Suse, took 6 weeks to track down ...now have both systems 100% stable.
jdtate101 is offline   Reply With Quote
Old 08-29-06, 05:51 PM   #7
steerpike
Registered User
 
Join Date: Jul 2006
Posts: 7
Default Re: X crash at 100% CPU Usage

Hi,

The log says skipped services : irq_balancer, microcode

so I assume that this is not being loaded.
steerpike is offline   Reply With Quote
Old 09-18-06, 03:38 PM   #8
marx
Registered User
 
Join Date: Sep 2006
Posts: 2
Default Re: X crash at 100% CPU Usage

Hello,

I am having the same problems, almost the same configuration (amd64 X2 4200+, 7300GT Silent, PCIe).

Freeze is random, i tried several things found here in the forums (acpi=off, noapic, irq sharing, RenderAccel off and such) -- no result.

There is a bug report log attached (run after the crash) and cupple of NVRM errors.

The problem has all the symptoms found in the forums -- 100% CPU, hw mouse cursor moving, dead keyboard. Only solution is remote login and reboot.

My mother board BIOS is the newest (Asus M2N-E). I am using IO_APIC interrupts right now.

marx (martin).


Running with vesa driver is fine. nv driver halts with X backtrace.
Attached Files
File Type: log nvidia-bug-report.log (97.1 KB, 119 views)
File Type: log nvrm.log (1.6 KB, 115 views)
File Type: txt interrupts.txt (803 Bytes, 115 views)
marx is offline   Reply With Quote

Old 02-24-07, 06:41 AM   #9
marx
Registered User
 
Join Date: Sep 2006
Posts: 2
Default Re: X crash at 100% CPU Usage

Hi there,

i like this thread :-(.

After some month of using free nv driver i again give a try to nvidia. The same results as before -- X crashed again, symptoms are the same.

Bellow is a generated bug report after the crash from single user mode before uninstallig nvidia drivers. I also tried to ssh into the freezed comp and run the bugreport directly, here with .after.crash.log extension; though, there were some warnings about the display, probably because of ssh forwarding.

regards, marx.
Attached Files
File Type: log nvidia-bug-report.log (103.6 KB, 94 views)
File Type: log nvidia-bug-report.log.after.crash.log (127.7 KB, 92 views)
marx is offline   Reply With Quote
Old 02-24-07, 09:25 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: X crash at 100% CPU Usage

1.0-8776 is no longer supported. If this problem persists with 1.0-9746, please provide a new bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM
Fedora 16, GTX 550Ti, random X hangs, "Attempted to yield the CPU..." MquwIBUO NVIDIA Linux 7 06-12-12 03:39 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM
Prime95 and CPU stress testing DaveW General Software 2 10-05-02 12:38 PM
Temp CPU until Barton... pelly CPUs, Motherboards And Memory 9 09-13-02 01:42 AM

All times are GMT -5. The time now is 10:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.