Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-02-08, 10:14 PM   #1
vytalelementz
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Still can not run X with latest nvidia driver

I am having trouble with the 173.14.x drivers. After I install and try to run x I still receive this error message:
Code:
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0. 
(EE) NVIDIA(0):     Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0):     additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
The dmesg still displays this output at the end:

Code:
NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:892)
NVRM: rm_init_adapter(0) failed
I use archlinux and I am using a GeForce 7900 GT card which appears to be supported, so I don't understand what the problem is. I am able to use 173.08 with no issues. Any suggestions is appreciated.
vytalelementz is offline   Reply With Quote
Old 07-03-08, 08:42 AM   #2
jrusinek
Registered User
 
Join Date: Jun 2008
Posts: 7
Default Re: Still can not run X with latest nvidia driver

that card fails to start in Ubuntu too.

in my computer I have 6200 and nVidia driver worked in Arch, but in openSUSE doesn't - nVidia provides broken packages...
jrusinek is offline   Reply With Quote
Old 07-03-08, 09:04 AM   #3
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Still can not run X with latest nvidia driver

Quote:
Originally Posted by vytalelementz View Post
I am having trouble with the 173.14.x drivers. After I install and try to run x I still receive this error message:
Code:
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0. 
(EE) NVIDIA(0):     Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0):     additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
The dmesg still displays this output at the end:

Code:
NVRM: failed to copy vbios to system memory.
NVRM: RmInitAdapter failed! (0x30:0xffffffff:892)
NVRM: rm_init_adapter(0) failed
I use archlinux and I am using a GeForce 7900 GT card which appears to be supported, so I don't understand what the problem is. I am able to use 173.08 with no issues. Any suggestions is appreciated.
Try some of the solutions in the COMMON PROBLEMS section of the README. Also in a search I did in this forum I saw that someone who had the same problem at the end found that it was an IRQ sharing problem.
gbil is offline   Reply With Quote
Old 07-03-08, 09:05 AM   #4
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Still can not run X with latest nvidia driver

Quote:
Originally Posted by jrusinek View Post
that card fails to start in Ubuntu too.

in my computer I have 6200 and nVidia driver worked in Arch, but in openSUSE doesn't - nVidia provides broken packages...
Very very very useful answer...
gbil is offline   Reply With Quote
Old 07-03-08, 10:34 AM   #5
vytalelementz
Registered User
 
Join Date: Jun 2008
Posts: 6
Default Re: Still can not run X with latest nvidia driver

Wow I can't believe the solution might have been under my nose in the "Common Problems" section. I'll work on this as soon as I can and will follow up with what exactly I have done to resolve this. Thanks to everyone for all the input.
vytalelementz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Lucid rt kernel can't load latest nvidia driver module, but generic does. marcod NVIDIA Linux 0 05-02-12 06:23 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Trouble with SuSE 8 & NVIDIA latest driver bughill NVIDIA Linux 3 08-20-02 12:31 PM

All times are GMT -5. The time now is 07:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.