Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-01-06, 05:19 PM   #1
kapa
Registered User
 
Join Date: May 2004
Posts: 4
Default Twinview

Hello,

could someone help me:

I have two Viewsonics' LCD monitors, VX2025VM and VP171B. I would like to use Twinview, and I have tried to use it, with no luck. My graphic card is Gainward GF4 Ti-4800SE, with DVI, D-sub and VIVO.

Has anyone working xorg.conf that would suit to my monitors? If yes, could that one post it in here

thanks and best regards, Kari
kapa is offline   Reply With Quote
Old 09-01-06, 05:25 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview

nvidia-xconfig --twinview

If that doesn't work, then you need to post a bug report, and or read the driver README for more details.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-01-06, 06:46 PM   #3
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: Twinview

This may help you...

http://www.nvnews.net/vbulletin/showthread.php?t=72080
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 09-01-06, 06:53 PM   #4
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: Twinview

Quote:
Originally Posted by netllama
nvidia-xconfig --twinview

If that doesn't work, then you need to post a bug report, and or read the driver README for more details.

Thanks,
Lonni
Is this what he should see running that command?

Code:
stormshadow:/etc# nvidia-xconfig --twinview

Using X configuration file: "/etc/X11/xorg.conf".
Option "TwinView" "True" added to Screen "Default Screen".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 09-01-06, 06:54 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview

carlos, Yes.
netllama is offline   Reply With Quote
Old 09-01-06, 07:43 PM   #6
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: Twinview

So after we run this command and recieve this output via CLI. What would be the next step as nothing happened to my 2nd LCD. It remained in sleep mode. Do I need to restart Gnome or still must we edit the .xorg.conf file further?
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 09-01-06, 08:17 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview

You need to (re)start X.
netllama is offline   Reply With Quote
Old 09-02-06, 05:33 AM   #8
kapa
Registered User
 
Join Date: May 2004
Posts: 4
Default Re: Twinview

Hi all,

I tried nvidia-xconfig --twinview, with little luck:

after making configuration, I restarted my X, and ... no success. I read Xorg.0.log file from /var/log directory, and it gave one hint: Only one display found.

This was because "ConnectedMonitor" were set to "DFP". Earlier I already met this problem. I tried to change the value to "DFP, CRT" (one of the LCDs is connected via analog D-sub), and that caused "white screen" (i.e. both displays became totally white, and I fear those could be broken if trying again)...

But, because I do not want to give up, I continued

Finally, after few unsuccessful tries, I found the configuration for me. It is:

For some reason my graphic card needs to be used in "CRT, DFP" mode. If I put the definition otherway, it leads to problem. But if I do not define Connected monitors at all, the order of identified displays is "analog, digital". So, after discovering this, I needed to change the order of the desktop from "DFP, CRT" to "CRT, DFP".

Here is cut from Xorg.0.log file after changing the configuration:

(**) NVIDIA(0): Option "UseEdidFreqs" "True"
(**) NVIDIA(0): Option "TwinView" "True"
(**) NVIDIA(0): Option "TwinViewOrientation" "LeftOf"
(**) NVIDIA(0): Option "MetaModes" "1280x1024@1280x1050,1680x1050"
(**) NVIDIA(0): Option "Rotate" "off"
(**) NVIDIA(0): Option "Coolbits" "1"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): enabled on all display devices.
(**) NVIDIA(0): TwinView enabled
(**) NVIDIA(0): Disabling static screen rotation.
(II) NVIDIA(0): NVIDIA GPU GeForce4 Ti 4800 SE at PCI:2:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.28.20.21.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 Ti 4800 SE at
(--) NVIDIA(0): PCI:2:0:0:
(--) NVIDIA(0): ViewSonic VP171b (CRT-1)
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0)
(--) NVIDIA(0): ViewSonic VP171b (CRT-1): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): ViewSonic VX2025wm (DFP-0): External Single Link TMDS
(II) NVIDIA(0): Assigned Display Devices: CRT-1, DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1280x1024@1280x1050,1680x1050"
(II) NVIDIA(0): Virtual screen size determined to be 2960 x 1050


And this I got with this configuration:

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Option "Rotate" "off"
# Option "ConnectedMonitor" "DFP"
# DefaultDepth 24
Option "CoolBits" "1"
Option "TwinView" "True"
Option "TwinViewOrientation" "LeftOf"
Option "UseEdidFreqs" "True"
Option "MetaModes" "1280x1024@1280x1050,1680x1050"
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1
024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "10
24x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection


The advice to use nvidias own xconfig tool helped me in clarifying the cause of problems, so thank you "very many" for advices
Because, now twinview rocks

This is a bit hard to explain (with my english) but hopefully you understand
kapa is offline   Reply With Quote

Old 09-02-06, 08:34 AM   #9
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Re: Twinview

Quote:
Originally Posted by netllama
You need to (re)start X.
Thanks - this worked for me no sweat. I am guessing if I ever wanted to stop this, I would just edit "Twinview" to false and then restart X, right?
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 09-02-06, 10:23 AM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview

Correct
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 10:36 AM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 03:09 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.