Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-02-06, 03:54 AM   #1
koos
Registered User
 
Join Date: Aug 2005
Posts: 8
Default 1.0.8774 doesn't work for TV or DVB card

Hi,
On a debian/testing P4 system lk 2.6.17.11 w/ GF5200 and both a PCI TV and DVB-S card, the XVideo for these devices doesn't work anymore, even if I disable the composite extension (though the xorg.log file says the ext. is disable, but it enables the internal composite anyway).
The output that I get, eg. w/ xawtv, looks like those cards that if you look a while at it, suddenly some depth is visible.
I also got two crashes allready, see attachments for the first crash kern.log. The second crash happend suddenly when I typed a key, I heard a beep and then I couldn't do anything anymore. The mouse still moved, didn't click though, and a running 'xawtv -c /dev/video0 -remote' (which was the only way to get TV out of the bttv TV card) kept on running as well. Machine was quite dead though, I couldn't ssh to that machine as well, though ping did get reply's. Unfortunately no log of this crash.
Attached Files
File Type: log Xorg.0-nocomp.log (21.6 KB, 109 views)
File Type: log kern.log (9.9 KB, 107 views)
File Type: log Xorg.0.log (22.1 KB, 109 views)
koos is offline   Reply With Quote
Old 09-02-06, 07:00 AM   #2
Mattia
Registered User
 
Join Date: Mar 2006
Posts: 49
Default Re: 1.0.8774 doesn't work for TV or DVB card

Tvtime works great
Mattia is offline   Reply With Quote
Old 09-02-06, 05:39 PM   #3
koos
Registered User
 
Join Date: Aug 2005
Posts: 8
Default Re: 1.0.8774 doesn't work for TV or DVB card

> Tvtime works great
Yes, but doesn't do Tvtime also postprocessing, so basically the same as -remote arg for xawtv?

Anyhow, I've installed the xorg-7.1 from debian/experimetal and it doesn't solve the issue. Though composite w/ video from mplayer or xine work great. I have set my xorg.conf back to 16bit colors to reduse CPU load, but I must say having fullscreen video composed w/ the background image is really really cool. Also no crashes till now.

When xawtv, or kwintv, starts I get a
ioctl VIDIOCCAPTURE(1): Invalid argument
on the console where X is started. Like said, the 'XvPutVideo' doesn't work, but neither any xoverlay from these v4l applications. Do I need to set an option for this (Readme.txt has some about overlay, but seems to talk about GL)?

One unrelated thing is that with GF5200 and 1920/1200 the stability is worse than before (ie. more horz. noise lines) compared to the previous NVidia driver. Here also the 16bit colors helped, but not enough. And w/ the previous driver it was only w/ the first minute after starting X, or when overscaling a fullscreen video, this driver seems to become worse in time when having fullscreen video resulting to also having sometimes black screens flashing in between.
koos is offline   Reply With Quote
Old 09-04-06, 02:53 AM   #4
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: 1.0.8774 doesn't work for TV or DVB card

The problem is another..all tv-apps(xawtv,kdetv)require dga for see video from dvb-card,nvidia has removed the dga from their drivers.
U have this solution,downgrade to 8178 wich have dga,or use xawtv with
xawtv -no-xv -no-dga -no-gl,is a bad solution(cpu at 10% and over..),but i think is the only solution
For the crash,after upgrade the driver,before turn on tv u have to reboot your pc.
meskalamdug is offline   Reply With Quote
Old 09-04-06, 02:54 AM   #5
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: 1.0.8774 doesn't work for TV or DVB card

Quote:
Originally Posted by Mattia
Tvtime works great
Wich version of tvtime?
Thanks
meskalamdug is offline   Reply With Quote
Old 09-04-06, 02:55 AM   #6
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: 1.0.8774 doesn't work for TV or DVB card

I still don't understand why nvidia removed dga..
meskalamdug is offline   Reply With Quote
Old 09-04-06, 02:44 PM   #7
koos
Registered User
 
Join Date: Aug 2005
Posts: 8
Default Re: 1.0.8774 doesn't work for TV or DVB card

Thanks for the info. I'm using mplayer now and that seems to be quite modest with CPU usage. And watching TV through another app, and/or projected on a background image is so cool, that I forgive NVidia for not fixing this issue just yet.
koos is offline   Reply With Quote
Old 09-04-06, 02:45 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 1.0.8774 doesn't work for TV or DVB card

meskalamdug,
The reason why DGA support was removed has been explained in several other threads of this forum, as well as the driver README. Its also the same reason as I provided to you via email when you emailed linux-bugs@nvidia.com. The reason is going to remain the same regardless of the number of times you ask.

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 09-04-06, 02:50 PM   #9
Mattia
Registered User
 
Join Date: Mar 2006
Posts: 49
Default Re: 1.0.8774 doesn't work for TV or DVB card

Quote:
Originally Posted by meskalamdug
Wich version of tvtime?
Thanks
I use tvitime 1.0.1 as frontend of VDR.
Mattia is offline   Reply With Quote
Old 09-04-06, 03:09 PM   #10
pgs
Registered User
 
Join Date: Apr 2006
Posts: 73
Default Re: 1.0.8774 doesn't work for TV or DVB card

Quote:
Originally Posted by meskalamdug
The problem is another..all tv-apps(xawtv,kdetv)require dga for see video from dvb-card,nvidia has removed the dga from their drivers.
U have this solution,downgrade to 8178 wich have dga,or use xawtv with
xawtv -no-xv -no-dga -no-gl,is a bad solution(cpu at 10% and over..),but i think is the only solution
For the crash,after upgrade the driver,before turn on tv u have to reboot your pc.
No, sorry, the problem is not with DGA, but with the direct v4l to xvideo overlay.
One feature of the xvideo extension is the capability to capture from v4l and display the picture (with proper color space conversion and scaling) without any CPU intervention. This does not work for driver after 8178.
So, the problem is not with missing DGA, which returns an error with xawtv, but with a known bug with the driver, which, hopefully, will be fixed in 9xxx.
At least this is the promise... :-)
pgs is offline   Reply With Quote
Old 09-04-06, 11:56 PM   #11
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: 1.0.8774 doesn't work for TV or DVB card

Quote:
Originally Posted by pgs
No, sorry, the problem is not with DGA, but with the direct v4l to xvideo overlay.
One feature of the xvideo extension is the capability to capture from v4l and display the picture (with proper color space conversion and scaling) without any CPU intervention. This does not work for driver after 8178.
So, the problem is not with missing DGA, which returns an error with xawtv, but with a known bug with the driver, which, hopefully, will be fixed in 9xxx.
At least this is the promise... :-)
Whooooooops!
I think was dga.

Ok,we will wait the 9xxx driver
meskalamdug is offline   Reply With Quote
Old 09-04-06, 11:56 PM   #12
meskalamdug
Registered User
 
Join Date: Apr 2006
Posts: 103
Default Re: 1.0.8774 doesn't work for TV or DVB card

Quote:
Originally Posted by Mattia
I use tvitime 1.0.1 as frontend of VDR.
I try now tvtime with new driver...
i hope work
meskalamdug is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 04:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.