Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-01-06, 09:42 PM   #1
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Twinview, AMD64, X hangs

I recently built a new computer (this week, in fact!), and slapped Linux on with the intent of playing some of my favorite games. Since I have 2 monitors, I immediately configured X.org for TwinView (which i have no prior experience with). I managed to get it working to my satisfaction except for one thing.

When I started Quake 4, and got to the first level load screen, the following events occured:
  • Everything is just peachy up to the end of loading. Suddenly, a red horizontal moire pattern flashes up the screen, and texture corruption is visible around the "loading" text.
  • Text changes to "Click to begin", texture corruption still evident, no other visible problems.
  • Click and screen blanks, renders the starfield skybox. Nothing visibly wrong for less than a second.
  • Texture corruption appears on starfield (this time, a vertical blue moire pattern), background is unrecognizable, skybox shape clearly visible.
  • Floating corpse passes into view, music turning ominous, no texture corruption visible.
  • Visuals freeze. Console unresponsive. Music still playing for several minutes. System rendered unusable.
Wash, rinse, repeat. When X locks in this fashion, no amount of coaxing will release the video driver. I'm forced to reboot to make it usable again. (From past experience I know that all background processes still run - for which I have evidence even now - and it's possible to SSH in. Typically, kill is ineffective - and hangs - against the X server. Haven't tried this recently, as I haven't a second machine set up for it.)

I decided to try UT2004 to see if it was a Quake issue. This time, there is no texture corruption whatsoever, and it hangs similarly at the load screen.

I can try also NWN and UT2003 (if I can find the CD key for it) if needbe.

A few minutes ago, I tried Quake 4 windowed. Result: I played through the first level without incident. Perfectly smooth frame rate, no problems except the glare of white windows in the background.

Is this a known issue? Is there a workaround?

I'll reconfigure X to shut off TwinView and post my results later. Report log attached.
Attached Files
File Type: zip nvidia-bug-report.log.zip (21.3 KB, 135 views)
grey wolf is offline   Reply With Quote
Old 09-01-06, 10:01 PM   #2
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

Yep, just tried without TwinView. Quake 4 played like a champ in fullscreen. (Next to see if quake4-smp works like it should. )
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote
Old 09-05-06, 12:03 PM   #3
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

Bump so I'm not forgotten. Also, I've run into larger problems: Until I updated my motherboard BIOS to version 1.30, I could not start X no matter what configuration I tried - either with the nvidia or nv driver. Now, I can get X to start, but as soon as GL is initialized, the server hangs. I'm beginning to suspect defective hardware, but I have no idea which hardware is bad.
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote
Old 09-05-06, 12:27 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview, AMD64, X hangs

I believe that there was another thread on this forum where someone reported that the motherboard you are using has known hardware problems in specific revisions, and the only solution was an RMA.

-Lonni
netllama is offline   Reply With Quote
Old 09-05-06, 01:20 PM   #5
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

Yes, I read that thread thoroughly, and I'm very unclear bout whether it is a problem. I assume you are referring to http://www.nvnews.net/vbulletin/show...t=K9N+Platinum

According to the thread at the MSI forums, the problem is capacitor C565 has the wrong capacity. I've also seen a list of serial numbers which are supposedly affected. I'll post again tonight if my motherboard comes up clean.

I'm really not looking forward to an RMA.
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote
Old 09-05-06, 08:59 PM   #6
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

It appears my motherboard is not one of the afflicted. The problematic boards seem to have serial numbers containing -040-, -050-, and -080-, and mine is -070-, so an RMA doesn't seem to be called for.

If you could suggest how I could proceed, that would be stellar. I'm at a complete loss as to what I can do. Disabling ACPI and APIC have no effect on the behavior of the system, and while I can startx successfully, I see some intermittent video corruption and initializing OpenGL crashes the driver.

I've grabbed a few more nvidia-bug-report logs, all of which look harmless to me - all captured seconds after starting X:
nvidia-bug-report-renderaccel-[01].log: these two files are started with no special kernel options. One for RenderAccel 1, and another off.
nvidia-bug-report-no-acpi.log: kernel with acpi=off.
nvidia-bug-report.log: kernel with acpi=off and noapic.

I've experimented with various ACPI BIOS settings, and I've even tried disabling NUMA and ACPI support in fresh kernel compiles, all to no effect. I get identical results through all of these configurations.

Again, motherboard doesn't seem suspicious. What do I check next?
Attached Files
File Type: zip nvidia-bug-report.zip (78.0 KB, 111 views)
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote
Old 09-06-06, 10:00 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Twinview, AMD64, X hangs

I'm afraid that I don't have any other suggestions at this time.
netllama is offline   Reply With Quote
Old 09-06-06, 11:07 AM   #8
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

I'll head down to CompuCare, then, and pick up a new video card. (Probably grab an ATi just to see whether it's the MB or video that's barfing.) I'll feel so dirty.
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote

Old 09-07-06, 08:36 PM   #9
grey wolf
Registered User
 
Join Date: Apr 2004
Posts: 11
Default Re: Twinview, AMD64, X hangs

I feel like such a tool, with so many posts to my own thread.

Everything I tried pointed to one thing: bad video card.

I just put in a new eVGA 7600GS. So far no bugginess. I will declare my problem solved when I decide to RMA the XFX.
__________________
--
grey wolf

AMD Athlon 64 X2 3800+
OCZ Gold PC2-6400 @ 5-5-5-12, 800MHz
MSI K9N Platinum (nForce 570 Ultra)
XFX GeForce 7600GS 256MB
grey wolf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 16, GTX 550Ti, random X hangs, "Attempted to yield the CPU..." MquwIBUO NVIDIA Linux 7 06-12-12 03:39 PM
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 12:46 PM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 03:24 AM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 04:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 03:20 AM

All times are GMT -5. The time now is 09:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.