Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-28-06, 09:23 PM   #25
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Talking Re: Composited XVideo flicker

Great! Big thanks for your hard work and involvement Lonni!
piotrq__ is offline   Reply With Quote
Old 09-29-06, 09:15 AM   #26
shijtin
Registered User
 
Join Date: Aug 2006
Posts: 9
Default Re: Composited XVideo flicker

Quote:
Originally Posted by netllama
Thanks, I've finally reproduced the tearing with mvice.avi, and opened bug 257335.

-Lonni
It is I who should thank you

And thanks for this excellent beta driver, apart from the tearing in videos with composition and memory limitation with direct rendering, I've no other problems.
shijtin is offline   Reply With Quote
Old 09-29-06, 10:00 AM   #27
Alejandro Nova
Registered User
 
Join Date: Sep 2006
Posts: 26
Default Re: Composited XVideo flicker

Thanks! This have taught me a lesson: if I can, I must report any bug I see. Thanks also for your beta driver!

BTW, all what I was experiencing was without Compiz/Beryl (without AIGLX, I even have it disabled in my xorg.conf). It was with KWin+kompmgr+XComposite extension.

Alejandro Nova™

Edit: Uploading my nvidia-bug-report.log
Attached Files
File Type: gz nvidia-bug-report.log.gz (18.1 KB, 164 views)

Last edited by Alejandro Nova; 09-29-06 at 11:38 AM.
Alejandro Nova is offline   Reply With Quote
Old 09-29-06, 11:45 AM   #28
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Composited XVideo flicker

This bug was investigated overnight, and it was determined that this isn't an nvidia driver bug, but a compositor bug, as the compositor isn't able to sync to VBLANK.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 12:53 PM   #29
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: Composited XVideo flicker

Hmmm... So since this is not the driver's then what can we do to somehow fix, or workaround this annoying thing ?
piotrq__ is offline   Reply With Quote
Old 09-29-06, 01:49 PM   #30
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Composited XVideo flicker

You should report it as a sync to VBLANK bug to whichever compositing manager you're using.

-Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 05:09 PM   #31
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Composited XVideo flicker

Also, make sure that you disable XV sync-to-vblank in nvidia-settings if you're using a compositor. This option syncs rendering of the video into the offscreen pixmap, which isn't what you want. You want to sync the compositor's rendering to the screen.
AaronP is offline   Reply With Quote
Old 09-29-06, 05:56 PM   #32
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: Composited XVideo flicker

I keep that disabled as you advised, but i noticed that players like MPlayer, or Xine re-enable this seting when XV output optionis used. I checked this using xvattr and what I got was:

Name: XV_SYNC_TO_VBLANK
Flags: XvGettable XvSettable
Min value: 0
Max value: 1
Current value: 0

Opened a movie with mplayer, then closed it and:

Name: XV_SYNC_TO_VBLANK
Flags: XvGettable XvSettable
Min value: 0
Max value: 1
Current value: 1

Last edited by piotrq__; 09-29-06 at 06:07 PM.
piotrq__ is offline   Reply With Quote

Old 09-30-06, 03:46 AM   #33
Belegdol
Registered User
 
Join Date: Oct 2004
Posts: 118
Default Re: Composited XVideo flicker

Quote:
Originally Posted by AaronP
Also, make sure that you disable XV sync-to-vblank in nvidia-settings if you're using a compositor. This option syncs rendering of the video into the offscreen pixmap, which isn't what you want. You want to sync the compositor's rendering to the screen.
There are 3 Sync To Vblank options, 2 xvideo (video texture and video blitter) and opengl. So the two xvideo ones should be disabled, right?
Belegdol is offline   Reply With Quote
Old 09-30-06, 05:41 AM   #34
MrMadPL
Registered User
 
Join Date: Sep 2006
Posts: 27
Lightbulb Re: Composited XVideo flicker

The "Video Texture Adaptor" and "Video Blitter Adaptor"
option should be switche off.
But the problem is like mentioned above - that the Mplayer or Xine will
switch them back to on at playback start.
If You want to test it will help in your case or not then start the playback - next
make the video pause (not stop !) and then turn the "Video Texture Adaptor" to
off and un-pause playback.
In my case it helps - much more less choppy playback then before ...
But how to make it permanent ? Beryl patch neccessary ?
MrMadPL is offline   Reply With Quote
Old 09-30-06, 08:37 AM   #35
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: Composited XVideo flicker

I guess that a patch for MPlayer should do the job. I'm gonna talk to MPlayer devs today and see if I can convince them, I'll hack something myself if I don't (I'm not quite actually a C programmer, but I'll do my best ) :-)

@MrMadPL Where did you get that Video Texture Adapter ? I can't see it neither in xvinfo nor in xvattr, or my display is too dusty... :-) (got a GeForce 3 Ti200)
piotrq__ is offline   Reply With Quote
Old 09-30-06, 10:29 AM   #36
MrMadPL
Registered User
 
Join Date: Sep 2006
Posts: 27
Lightbulb Re: Composited XVideo flicker

@piotrq__
this setting is visible in xvinfo but i'm using the nvidia-settings to check it and toggle ....

xvinfo (partial output):
Code:
Adaptor #1: "NV17 Video Texture"
[...]
 "XV_SYNC_TO_VBLANK" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 0)
Regarding patch - IMHO this should be a patch to Beryl - cause
a) this XV_SYNC_TO_VBLANK should remain on while not using composite manager
b) as mentioned in other thread currently there are some problems in beryl to fully respect
VSync

better to request a patch on Beryl/Compiz forum ...

PS: Already posted a bug for Beryl:
http://bugs.beryl-project.org/ticket/240

Last edited by MrMadPL; 09-30-06 at 10:40 AM.
MrMadPL is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xvideo crash elanthis NVIDIA Linux 5 10-29-02 08:12 PM

All times are GMT -5. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.