Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-29-06, 08:36 AM   #1
esteel
Registered User
 
esteel's Avatar
 
Join Date: Sep 2006
Posts: 5
Default driver has several problems with dualhead display

Hi.

Xinerama seems to only work right if the primary monitor is on the left side. The following snipplet from my xorg.conf does not work:

Code:
Section "Device"
	Identifier	"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 GT]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Screen		0
	Option		"UseDisplayDevice"	"DFP-0"
	Option		"NoLogo"		"1"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 GT]"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 GT] 2"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Screen		1
	Option		"UseDisplayDevice"	"CRT-0"
	Option		"NoLogo"		"1"
EndSection

Section "Screen"
	Identifier	"Default Screen 2"
	Device		"NVIDIA Corporation NV43 [GeForce 6600/GeForce 6600 GT] 2"
	Monitor		"Generic Monitor 2"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	Screen		1 "Default Screen2" LeftOf "Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	Option		"Xinerama"
EndSection
With the previous version of the driver the left monitor went black and a window appeared on the right monitor and the application did just hang. With the 8874 version the application seems to start but is unable to grap the mouse.. I either have to move the primary monitor to the left side
Code:
	Screen		1 "Default Screen2" RightOf "Default Screen"
Or turn xinerama off with
Code:
#	Option		"Xinerama"
. This applies to 1.0-8774 and to the previous driver version. I have not tested others then those two.

Also the current 1.0-8774 seems to have general problems with xinerama. When i have the primary screen on the left side and start any 3d opengl application the display turns black and hangs. Sometimes it helps to switch to one of the text consoles with e.g. Alt-F1 and back to X with Alt-F7. Most of the time the application can continue then, toggle gamma and start.. I did not have had this problem with the previous version of the driver.

Twinview is currently not a solution as it used the CRT monitor as primary monitor but i want the TFT to be the primary monitor. I have read the next version will include a config option for this so maybe twinview might be a solution then but those xinerama problems should be solved too.
__________________
i support free software: http://www.fsfe.org/en/fellows/esteel
a great free and opensource FPS game: http://nexuiz.com
esteel is offline   Reply With Quote
Old 09-29-06, 12:02 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: driver has several problems with dualhead display

If this problem reproduces with the 1.0-9625 driver, please provide the following:
0) An nvidia-bug-report.log generated while the problem(s) are present
1) Details on which application(s) are required to reproduce the problem(s)
2) Details on how to reproduce the problem(s)

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 04:24 PM   #3
esteel
Registered User
 
esteel's Avatar
 
Join Date: Sep 2006
Posts: 5
Default Re: driver has several problems with dualhead display

1.0-9625 does again work with xinerama. It was strange as the version before 1.0-8774 did also work fine.

However 9625 does still not work with the "LeftOf" option in xorg.conf.
0) When i start a opengl fullscreen application it just hangs till i switch to a text console and back again then the opengl application continued. Sometimes i need to switch several times.. So i did
Code:
sleep 20; nvidia-bug-report
as root and started the application in the meanwhile. Find the logfile attached.
1) Any 3d opengl fullscreen application behaves that way for me. For example planet penguin racer (ppracer) which should be in most linux distris. Other examples i tried are quake3, quake4, Nexuiz..
2) The line
Code:
	Screen		1 "Default Screen 2" LeftOf "Default Screen"
seems to be the cause of that problem. When i change it to RightOf everything just works fine. Thats the solution i use right now and i had to switch my monitors because of that . As the xorg.conf is part of the report i think i do not need to append it here.
Attached Files
File Type: log nvidia-bug-report.log (127.9 KB, 109 views)
__________________
i support free software: http://www.fsfe.org/en/fellows/esteel
a great free and opensource FPS game: http://nexuiz.com
esteel is offline   Reply With Quote
Old 09-29-06, 04:49 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: driver has several problems with dualhead display

I'm not able to reproduce this problem. Regardless of whether I have LeftOf or RightOf, ppracer starts up just fine here with 1.0-9625. Is this problem window manager or user specific?

-Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 05:06 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: driver has several problems with dualhead display

Actually, I'm seeing a different problem only when specifying LeftOf orientation with ppracer, where the mouse cursor is missing. I've opened bug 257584 for that problem.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 05:54 PM   #6
esteel
Registered User
 
esteel's Avatar
 
Join Date: Sep 2006
Posts: 5
Default Re: driver has several problems with dualhead display

I have had that mouse problem a few times myself but i can't reproduce it right now.
But my problem seems to occur when i move the mouse while the application does start. When i'm not holding still after clicking the ppracer menu entry. And once it did hang like this it hangs then again even if i do not move the mouse during the next start then. Maybe both errors are caused by the same thing..
__________________
i support free software: http://www.fsfe.org/en/fellows/esteel
a great free and opensource FPS game: http://nexuiz.com
esteel is offline   Reply With Quote
Old 10-01-06, 08:53 AM   #7
miguelnetto
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: driver has several problems with dualhead display

I have the same problem related by esteel with two monitors LG L1950H and Nvidia 6600 GT - to left...no way.
miguelnetto is offline   Reply With Quote
Old 10-01-06, 09:05 AM   #8
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: driver has several problems with dualhead display

I am having basically the same problem:
http://www.nvnews.net/vbulletin/showthread.php?t=77500
I am using a dual screen setup with xinerama, I have two displays, primary 2560x1600 (on the right) and secondary 3840x2400 (on the left), so the primary display is the right display, however 3d programs and mplayer always start on the left They also lock up whenever I try to use the native resolution on either LCD getting like .05 FPS, works fine on resolutions which are not the native, i have more detials including a log on the topic I started. I am using the newest beta drivers.
Xevious is offline   Reply With Quote

Old 10-01-06, 09:13 AM   #9
miguelnetto
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: driver has several problems with dualhead display

Bingooooo! I solve my problem!!!!!

In

Code:
Option "UseDisplayDevice"	"CRT-0"
and

Code:
Option "UseDisplayDevice"	"DFP-0"
Just delete the -0 in both options

Now works fine!

In time: nvidia drive 1.0-8774

Last edited by miguelnetto; 10-01-06 at 09:29 AM.
miguelnetto is offline   Reply With Quote
Old 10-01-06, 09:36 AM   #10
esteel
Registered User
 
esteel's Avatar
 
Join Date: Sep 2006
Posts: 5
Default Re: driver has several problems with dualhead display

I do not have those -0 in my config currently but still have this problem
__________________
i support free software: http://www.fsfe.org/en/fellows/esteel
a great free and opensource FPS game: http://nexuiz.com
esteel is offline   Reply With Quote
Old 10-01-06, 11:12 AM   #11
Xevious
Registered User
 
Join Date: Aug 2002
Posts: 291
Default Re: driver has several problems with dualhead display

I wasnt even usin gthe UseDisplayDevice option in my config, and even if I do it doesnt make a difference, absolutely same behaviour as before. both of my displays are DFP, DFP-0 and DFP-1, so removing the numbers wouldnt really work for me.
Xevious is offline   Reply With Quote
Old 10-01-06, 02:50 PM   #12
miguelnetto
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: driver has several problems with dualhead display

Well...look this section in my xorg.conf (my video card is a Nvidia 6600 GT - DFP and CRT output - in two displays LG L1950H):

(Note: I have instalade a PCI capture card Matrox RTX 100 recognized by Fedora with lspci command:
07:00.0 Display controller: Matrox Graphics, Inc. MGA G550 AGP (rev 01) - this cause several problems in Fedora installation because he recognize that is my first video card. My "fast solution" to recognize Nvidia 6600 GT: uninstall the Matrox RTX 100 and install Fedora, then reinstall Matrox. That is the reason to put BusID "PCI:1:0:0" in my xorg.conf at both videocard sections)

Code:
Identifier     "Multihead layout"
	Screen      1  "Screen0" 0 0
	Screen      0  "Screen1" RightOf "Screen1"
The first line in Identifier section is Screen 1 point to Screen0 at coordinates 0 0. This jump the signal to digital monitor output to left, your real frontend position.
The second line is Screen 0 (CRT output in Nvidia 6600 GT) point to Screen 1 "RightOf" Screen1. Make no sense, but work very well here.
Sorry my bad english and see my complete xorg.conf attached

More one information in Indentifier "Videocard1" (DFP) ---> The line Screen 1 . In the "Videocard0" (CRT) dont put the Line Screen 0

Quote:
Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV43 [GeForce 6600 GT]"
Option "UseDisplayDevice" "DFP"
BusID "PCI:1:0:0"
Screen 1
Desktop Snapshot

Reference: HOWTO Dual Monitors
Attached Files
File Type: txt xorg.conf.copy.txt (2.3 KB, 130 views)

Last edited by miguelnetto; 10-04-06 at 07:05 PM.
miguelnetto is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 10:55 AM
F1 2002 problems with driver 40.41 arutten NVIDIA Windows Graphics Drivers 6 10-01-02 08:07 AM
RH7.3 & nVidia driver problems BigChin NVIDIA Linux 4 10-01-02 02:33 AM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 07:45 AM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 01:25 PM

All times are GMT -5. The time now is 10:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.