Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-29-06, 08:01 PM   #1
Risujin
Registered User
 
Join Date: Sep 2006
Posts: 5
Unhappy Linux beta 9625 color corruption

This is on a Geforce 3 TI. Have a look at this:


After installing Xorg 7 the 8774 driver wouldnt even start! The beta driver gives the color corruption in the image above. It seems like when writing the color value to a pixel the blue is written into the red bits somehow. 3D performance is really slow as well. Color is corrupted this way in all color depths (24, 16, and 8). My Xorg settings worked under 7xxx and have almost nothing in them (I tried various options to no avail).

Any ideas?
Attached Files
File Type: zip nvidia-bug-report.log.zip (31.1 KB, 108 views)
Risujin is offline   Reply With Quote
Old 09-29-06, 08:55 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux beta 9625 color corruption

I have a few questions:
0) Does this problem persist if you're not using the Composite extension?
1) Does this problem occur as soon as X starts?
2) Does this color corruption appear in a screenshot as well (rather than external image)?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-29-06, 09:11 PM   #3
Risujin
Registered User
 
Join Date: Sep 2006
Posts: 5
Arrow Re: Linux beta 9625 color corruption

(Sorry about the large image, I didn't know how to make a thumbnail )

Thanks for your reply,

0) I tried commenting out the composite extension and various other parts of my xorg.conf to no avail.
1) The color is corrupted right off the bat and can be seen in GDM. The color corruption does not appear in a screenshot.
2) Using the GIMP color sampler I can pick around and get the correct RGB values.

Also look closely at the photo, I took it of GIMP on purpose. The bottom three color bars should be (from the bottom up) blue, green, and red fading from 0 to 255 but instead the blue bar is solid black (!), green is correct but segmented into blocks (not visible in photo, sorry, it is divided into about 16 blocks), the red bar is also divided into 16 blocks (which can be seen) but each block fades from red to blue!
Risujin is offline   Reply With Quote
Old 10-01-06, 09:43 PM   #4
Risujin
Registered User
 
Join Date: Sep 2006
Posts: 5
Unhappy Re: Linux beta 9625 color corruption

... any ideas?
Risujin is offline   Reply With Quote
Old 10-02-06, 12:00 AM   #5
Risujin
Registered User
 
Join Date: Sep 2006
Posts: 5
Thumbs up Re: Linux beta 9625 color corruption

Problem solved (or deferred?)

nVidia doesn't officially list it as such but the Geforce 3 TI series is apparently a legacy GPU as this is the only driver which will work (on Linux anyway). Thanks for backporting the legacy driver to Xorg7, and please PLEASE keep supporting the legacy gpus!

Risujin is offline   Reply With Quote
Old 10-02-06, 10:41 AM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Linux beta 9625 color corruption

The Geforce3 Ti 200 is not a legacy GPU at this time, and is supported by 1.0-8774 & 1.0-9625.

-Lonni
netllama is offline   Reply With Quote
Old 10-06-06, 09:34 AM   #7
Risujin
Registered User
 
Join Date: Sep 2006
Posts: 5
Thumbs down Re: Linux beta 9625 color corruption

Thats the official line but believe me, I tried both drivers and it isn't so. Perhaps these bugs will be fixed in the future but for now the Legacy Driver is the way to go for the Geforce 3.
Risujin is offline   Reply With Quote
Old 11-03-06, 11:35 PM   #8
kunjan
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Linux beta 9625 color corruption

I have the same problem, but on a different card with 9625 driver. I have a Geforce4 440 Go card.

I took some pictures, here http://kunjan.net/a/aiglx.html

any ideas why this would happen?
kunjan is offline   Reply With Quote

Old 11-04-06, 12:13 PM   #9
stef
Registered User
 
Join Date: Jul 2005
Posts: 9
Default Re: Linux beta 9625 color corruption

I've experienced a similar color corruption with 9625 beta driver and a 6600GT AGP card.
I've run the driver on a Ubuntu 6.10 (Xorg 7.1).
In detail the corruption is evident in the black zones of every type of images.
The corruption occurs with composite extensions enabled in xorg.conf and after some time.
Now I'm just reverted to the latest stable driver and the problem seems solved.
If useful I can take some screenshots or fill a bug report.
stef is offline   Reply With Quote
Old 11-05-06, 12:18 AM   #10
kunjan
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Linux beta 9625 color corruption

yup its mostly evident in the blacks, sometimes in the dark shades. not really sure why this is happening.. but i cant run beryl
kunjan is offline   Reply With Quote
Old 11-06-06, 11:51 AM   #11
stef
Registered User
 
Join Date: Jul 2005
Posts: 9
Default Re: Linux beta 9625 color corruption

I've made further tests with 9625 and 8776 driver.
My xorg.conf doesn't activate any composite extension but with both drivers, beta and stable, after a while I experience color corruption.
My Ubuntu 6.10 runs xorg 7.1.1
May be the color corruption is related to Xorg 7.1?
With my previous Slackware 11 ( Xorg 6.9) I've had no problem at all with 9625 or 8776 driver, also with composite enabled.
stef is offline   Reply With Quote
Old 11-06-06, 05:46 PM   #12
kunjan
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Linux beta 9625 color corruption

Quote:
Originally Posted by stef
May be the color corruption is related to Xorg 7.1?
With my previous Slackware 11 ( Xorg 6.9) I've had no problem at all with 9625 or 8776 driver, also with composite enabled.
I had switched to "nv" driver. i just noticed today that my X was running in 16 bit color depth. So I changed it to 24 bits, and the color corruption showed up again.

Yup looks like its an Xorg 7.1.1 bug. Let me google first before I file a bug with Xorg.

Also where do I file a bug report for it? Ubuntu? or Xorg?
kunjan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux for Tegra release 15 AaronP NVIDIA Linux 1 06-12-12 05:39 PM
302.11 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-19-12 10:21 AM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM

All times are GMT -5. The time now is 02:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.