Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-06, 10:32 AM   #1
meff
Registered User
 
Join Date: Feb 2005
Posts: 16
Default 1.0.9625 Switching from VT to X = Black screen freeze

Hi all! I have everything working on Debian/sid i386 with building the debs of the 0.1.0 tag of svn Beryl, on a NV6600.. Except a huge problem

Ctrl-Alt-F1 and back to my X session (Ctrl-Alt-F7) sometimes works, but most of the time I get a hardlock on a black screen but the mouse still moves.. Is this a known problem and is any fix available?

For some background, my box is a Pentium-D 830, 1.5gb ram, kernel 2.6.17-2-686.
Usually, the VT to X works a few times, then bam, black screen and I can't do anything.. SysRQ-K does nothing, so I just SysRQ-S-U-B to reboot.

I can't find errors anywhere, I've checked my syslog, parts of /var/log, and my Xorg.0.log .. Nothing.

Note: I just rebuilt the 1.0.9625 deb patched with Zander's i2c patch, still freezes.

I'd really love to get this working, anyone with an idea please reply

-r

Attached is my xorg.conf
Also just attached is my Xorg.0.log.old

A few other notes: Switching works fine with Compositing OFF, ON is when it freezes often.

I have tried removing the DRI sections from my xorg.conf, no help.
Attached Files
File Type: txt xorg.conf.txt (3.2 KB, 192 views)
File Type: txt Xorg.0.log.old.txt (26.8 KB, 158 views)
meff is offline   Reply With Quote
Old 09-30-06, 07:26 PM   #2
meff
Registered User
 
Join Date: Feb 2005
Posts: 16
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Here is also the report, attached.

Thanks anyone who can help
Attached Files
File Type: log nvidia-bug-report.log (87.9 KB, 184 views)
meff is offline   Reply With Quote
Old 09-30-06, 11:53 PM   #3
Tester
Registered User
 
Join Date: Jun 2003
Location: Montreal, Canada
Posts: 5
Send a message via ICQ to Tester
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Happens here too, I'm using a very recent compiz snapshot.
Tester is offline   Reply With Quote
Old 10-01-06, 02:48 AM   #4
ecastro
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

It happens to me too...

What i've noticed is that in the background everything is still running fine... for example... I was doing an "emerge --sync" in a terminal inside a X session, then i did alt+f1 and back to X with alt+f7 i got a black screnn with the mouse still moving but no key response. As i was hearing the harddisk working i just wait a couple of minutes for the "emerge --sync" to finish (i guess when it was done because obviously i wasnt able to see anything) and then turnned off the pc and back on again... when it booted i noticed that the "emerge --sync" command was completed. So, even with the black screen there and no key response, the process was still running in the background.

Some other times i've noticed too that pressing "ctrl+alt+backspace" did kill the X server.
ecastro is offline   Reply With Quote
Old 10-01-06, 08:10 AM   #5
meff
Registered User
 
Join Date: Feb 2005
Posts: 16
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Yeah but mostly it just locks up harder when I try a SysRQ Kill or Ctrl-Alt-Bkspace.. Hmm..

Any NVidia folk know whats going on here?
meff is offline   Reply With Quote
Old 10-01-06, 07:49 PM   #6
jeisom
Registered User
 
Join Date: Dec 2005
Location: My own little world
Posts: 117
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

I get it too , but usaully ctr-alt-sysrq-r will allow switching bact to a vt. then
killall -9 beryl sometimes allow maintain the login
jeisom is offline   Reply With Quote
Old 10-07-06, 10:20 AM   #7
meff
Registered User
 
Join Date: Feb 2005
Posts: 16
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Possible solution, working for me (so far) I've done about 20 switches, no black screen.

Open beryl settings manager, disable "sync to vblank" then reload beryl just to make sure, then switch around your VTs..

Let me know how it goes
meff is offline   Reply With Quote
Old 10-07-06, 10:38 AM   #8
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

yeah, sysrq-r and killing beryl solves the hang for me too.

Just kill it, switch back and start kwin.

Sometimes after 'r-ing' X doesn't like the keyboard at all. But restarting X is faster than rebooting and the mouse usually works
energyman76b is offline   Reply With Quote

Old 11-02-06, 12:52 AM   #9
jesse kahtava
Registered User
 
Join Date: Nov 2003
Location: ontario
Posts: 7
Send a message via ICQ to jesse kahtava
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Disabled:
General Options --> Sync To VBlank

Seems to be working for me, too!!
jesse kahtava is offline   Reply With Quote
Old 12-27-06, 08:32 PM   #10
ecastro
Registered User
 
Join Date: Aug 2006
Posts: 7
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

worked for me too!
ecastro is offline   Reply With Quote
Old 01-01-07, 07:35 AM   #11
Belegdol
Registered User
 
Join Date: Oct 2004
Posts: 118
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

Well, disabling syncing to vblank is not the thing I like. Is this compiz or nvidia driver problem? Happens with 1.0-9631 as well.

Last edited by Belegdol; 01-01-07 at 07:46 AM.
Belegdol is offline   Reply With Quote
Old 03-22-07, 05:09 AM   #12
szotag
Registered User
 
Join Date: Mar 2007
Posts: 1
Default Re: 1.0.9625 Switching from VT to X = Black screen freeze

I got the same error as you guys, I tried to following setups, and getting a little desperate:

My machine is:
- AMD Athlon 1800+
- nForce2 chipset (AGP, etc.)
- GeForce 6600GT
- Debian GNU/Linux (no framebuffer, PREEMPT kernel)

What happens:
When I switch between text consoles and X, it sometimes
hangs the window manager (all applications seem to be running, only they do not respond to window events, buttons and such)
Sometimes it does not do this on the first try, but 99 times out of
100 it does it the first time. When this happens, I can still switch
back to console, and kill my window manager, restart it, and then all works fine. All subsequent switches work!

What I tried:
1.
- X.org 7.1
- Linux 2.6.14
- nForce drivers from NVidia 1.0-0283
- Blackbox window manager 0.62.1pre0
- nVidia video driver 1.0-9629
Logs do not contain any information about this (system log, X log). DRI, is working. Glxinfo says direct render ok. Glxgears works, 3D applications work. Only switches seem to be unstable, but after switching to console, restarting the window manager from console, all seems fine.

2.
- Upgraded to nVidia video driver 1.0-9755
The same as above.

3.
- Tried beryl window manager v0.2.0 (from beryl debian repo)
- Added required config to xorg.conf (AddARGBGLXVisuals,RenderAccel,AllowGLXWithComposi te) and enabled xcomposite extension.
The window manager started up good, effects worked. Switching to console and then back resulted in white rectangles where the windows used to be, and black background, where blue used to be. Mouse pointer seems to work, switching back and forth still works, but it hangs after a while (unable to switch or do anything), with the mouse pointer still working, and background applications still running.

4.
- Installed compiz 0.2.2-1 from Debian unstable
When switching back from console, all is black, mouse pointer moves. After a few switches it hangs, just like beryl, with mouse pointer still moving, but unable to switch or kill X with crtl+alt+backspace.

5.
- Upgraded to X.org 7.2
Compiz produces the same.

6.
- Switched back to beryl to test with X.org 7.2
Nothing changed.

7.
- Switched to blackbox (my original windowmanager)
Still, window manager hangs on first switch.

8.
- Upgraded to Linux 2.6.20.3
Tried again all three window manager, still they produce the same errors as above.

9.
- Added NoAVP 0 to xorg.conf
Tried with all three wm-s, still the same.

10.
- Disabled Vsync with beryl.
Still the same.

I do not know what to do, it seems I am unable to put together a working X.

I hope somebody can help,
Robert.
szotag is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GT240M - black screen with newer drivers > 275.33 and win 7 doktor5000 NVIDIA GeForce 200 Series 1 07-08-12 11:17 AM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Black screen after switching between graphical virtual consoles five times rrr-wtf NVIDIA Linux 1 05-21-12 04:40 PM
Black screen and lockup on startx. redmoose NVIDIA Linux 4 09-18-02 11:53 AM
kernel 2.4.19 and 2960 -> black screen osterhase NVIDIA Linux 7 08-22-02 06:24 PM

All times are GMT -5. The time now is 04:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.