Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-30-06, 08:44 PM   #1
openmedia
Registered User
 
Join Date: Aug 2006
Posts: 33
Default Beta Drive 9625 bugs with PAL TV Out

I've attached the nvidia-bug-report.log files as requested.

My problems are that for most of the TV Out modes the driver doesn't appear to support 50Hz. I can reporoduce this on most 6200 class cards, in particular the 6150 chipsets uses on Asus A8N-VM CSM and M2NPV-VM Motherboards.

Note that this problem also exists for the 8xxx series driver as well.

As well as being able to support 50Hz video over DVI/HDMI I need to support 50Hz Pal Video over COMPOSITE/SVIDEO/COMPONENT.

Problem shows up as follows for SD PAL video modes

COMPOSTITE + HD576i with 720x576 reports 59.96 Hz.
SVIDEO + HD576i with 720x576 reports 59.96 Hz.
COMPONENT + HD576i with 720x576 reports 59.96 Hz.

Now the one that does appear to work

COMPONENT + HD576p with 720x576 reports 50.00 Hz.

This is also an issue with HD resolutions over COMPONENT If I enable 720p or 1080i over COMPONENT the refresh rate is also NTSC (60.02 Hz) rather than PAL.

I've attached the bug reports for SVIDEO + HD576i, COMPONENT + HD576p and COMPONENT + HD720p.

Steve
Attached Files
File Type: gz nvidia-bug-report.svideo_576i.log.gz (29.2 KB, 108 views)
File Type: gz nvidia-bug-report.composite_576p.log.gz (28.9 KB, 99 views)
File Type: gz nvidia-bug-report.composite_720p.log.gz (28.9 KB, 97 views)

Last edited by openmedia; 10-08-06 at 03:33 PM.
openmedia is offline   Reply With Quote
Old 10-08-06, 02:56 PM   #2
openmedia
Registered User
 
Join Date: Aug 2006
Posts: 33
Default Re: Beta Drive 9625 bugs with PAL TV Out

Any chance on some feedback for these TV-Out issues?
openmedia is offline   Reply With Quote
Old 10-08-06, 03:02 PM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Beta Drive 9625 bugs with PAL TV Out

How did you get your "reports"?
On the PC side or from the TV?

It may be that although some methods tell you the refresh is 60Hz, it actually is 50Hz.
pe1chl is offline   Reply With Quote
Old 10-08-06, 03:33 PM   #4
openmedia
Registered User
 
Join Date: Aug 2006
Posts: 33
Default Re: Beta Drive 9625 bugs with PAL TV Out

Quote:
Originally Posted by pe1chl
How did you get your "reports"?
On the PC side or from the TV?

It may be that although some methods tell you the refresh is 60Hz, it actually is 50Hz.
I have now checked screen with PAL HD576i profiles over SVIDEO/COMPOSITE/COMPONENT/DVI. The only one that reports 50Hz is DVI when using nvidia-settings.

Then I tried PAL 576p over SVIDEO/COMPOSITE/COMPONENT/DVI. I can't get a picture over SVIDEO/COMPOSITE, but they all report 50Hz under nvidia-settings.

I have no way to check at the display side of things the real refresh rate, but judging by the amount of motion blur I have on PAL videos that I don't see on NTSC videos I'm assuming the display is running at 60Hz.

Oh and i've corrected my original posting as I kept saying COMPOSITE when I mean COMPONENT.

Steve
openmedia is offline   Reply With Quote
Old 10-08-06, 05:34 PM   #5
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Beta Drive 9625 bugs with PAL TV Out

Try setting "Sync to VBlank" in the OpenGL settings and run glxgears to see what the vblank rate really is.
pe1chl is offline   Reply With Quote
Old 10-09-06, 05:59 AM   #6
openmedia
Registered User
 
Join Date: Aug 2006
Posts: 33
Default Re: Beta Drive 9625 bugs with PAL TV Out

Quote:
Originally Posted by pe1chl
Try setting "Sync to VBlank" in the OpenGL settings and run glxgears to see what the vblank rate really is.
Great.. Thanks for that. Its just nvidia-settings reporing the wrong value, it really is 50Hz.

Hmm.. Very odd. Still doesn't explain why NTSC video looks better on a PAL TV than PAL video..

Steve
openmedia is offline   Reply With Quote
Old 10-09-06, 11:11 AM   #7
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Beta Drive 9625 bugs with PAL TV Out

Quote:
Originally Posted by openmedia
Its just nvidia-settings reporing the wrong value, it really is 50Hz.
I think it is a very longstanding bug (I noticed the same when I first had a TV card several years ago).
Apparently it is not considered imporant enough.
pe1chl is offline   Reply With Quote
Old 02-20-07, 06:14 AM   #8
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: Beta Drive 9625 bugs with PAL TV Out

Quote:
Originally Posted by openmedia
Great.. Thanks for that. Its just nvidia-settings reporing the wrong value, it really is 50Hz.

Hmm.. Very odd. Still doesn't explain why NTSC video looks better on a PAL TV than PAL video..

Steve
I suspect there may be some kind of misunderstanding between the (wrong) frequency reported by the system and the video player which tries to sync to a 60hz display while it is running at 50hz
Could it be?
kokoko3k is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Western Digital drive performance Nemesis General Hardware 6 08-15-02 07:29 AM

All times are GMT -5. The time now is 12:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.