Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-03-06, 09:56 AM   #1
alex31
Registered User
 
Join Date: Dec 2002
Posts: 47
Default problem upgrading from cg 1.4.1 to cg 1.5

Hello,

After upgrading to Cg 1.5, some of my fragment shader (which runs fine with cg 1.4.1) no more load : they continue to compile fine, bit i have an error when loading the shader.

After some investigation, i saw that the problem is with texRECT family of functions :

1/ if a shader contains f3texRECT, there is an error, replacing f3texRECT by texRECT solve the problem.

2/ texRECT use to be polymorphic, there is both texRECT(samplerRECT, float3) and
texRECT(samplerRECT, float2), with prior version of Cg both of these function run fine, but with Cg 1.5, only texRECT(samplerRECT, float3) load correctly.

I have made tests with both a 7900gt card and a quadro 4400, with linux 8774 and 9625 beta,
with same results.

Does this is due to new spec of Cg, or is this just temporary bugs that's belongs to Cg 1.5 ?

Alexandre
alex31 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 10:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 04:14 PM
Screen flash briefly problem tamahome NVIDIA Windows Graphics Drivers 8 09-19-02 01:07 PM
funny problem with 2960 and GF4 konsti NVIDIA Linux 3 09-03-02 08:08 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM

All times are GMT -5. The time now is 07:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.