Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-27-06, 08:20 PM   #1
collision
Registered User
 
Join Date: Sep 2006
Posts: 3
Exclamation nvidia drivers on FreeBSD 6.1 RELEASE/GeForce 7600 GS

Im trying to install my nvidia GeForce 7600 GS PCI-Express on fbsd 6.1 released.
I installed the drivers from the ports and trying to start "startx" I get this error:

http://freebsd.pastebin.com/795820

Any help will be much appreciated! Thanks in advance.
collision is offline   Reply With Quote
Old 09-29-06, 04:16 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia drivers on FreeBSD 6.1 RELEASE/GeForce 7600 GS

I'm afraid I can't access the log file at the indicated URL; please attach the X log file to this thread.
zander is offline   Reply With Quote
Old 10-03-06, 02:10 AM   #3
betatest04
Registered User
 
Join Date: Aug 2004
Location: Adelaide, Australia
Posts: 6
Default Re: nvidia drivers on FreeBSD 6.1 RELEASE/GeForce 7600 GS

Zander, it looked like this:
----8<----
xauth: creating new authority file /home/collision/.serverauth.30870
/usr/X11R6/bin/xauth: creating new authority file /home/collision/.Xauthority
/usr/X11R6/bin/xauth: creating new authority file /home/collision/.Xauthority
/usr/X11R6/bin/xauth: (argv):1: bad display name "gothik.BSDlatino.org:0" in "list" command
/usr/X11R6/bin/xauth: (stdin):1: bad display name "gothik.BSDlatino.org:0" in "add" command


X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: FreeBSD 6.1 i386 [ELF]
Current Operating System: FreeBSD gothik.BSDlatino.org 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Sun May 7 04:42:56 UTC 2006 root@opus.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386
Build Date: 24 March 2006
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 27 20:09:11 2006
(==) Using config file: "/etc/X11/xorg.conf"
NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

X connection to :0.0 broken (explicit kill or server shutdown).
/usr/X11R6/bin/xauth: (argv):1: bad display name "gothik.BSDlatino.org:0" in "remove" command
---->8----

with the "(EE)" lines highlighted.



collision, I also use 6.1-RELEASE (an SMP build as well), on an AMD64 with a GeForce 7300GS, with no major problems (currently using -8762 about to try -8774 to see if it fixes a niggling glxinfo issue).

Judging by the error message present, the first question that springs to mind, is "_Is_ there a /dev/nvidia0 present?".

If you do something like "ls -l /dev/nvidia0", what do you get? (here, I get:
----8<----
crw-rw-rw- 1 root wheel 0, 51 Oct 3 15:31 /dev/nvidia0
---->8----
as a result of the nvidia kernel module being loaded properly).

If you get something like "ls: /dev/nvidia0: No such file or directory", then have a look in your /boot/loader.conf. Does it contain the lines:
----8<----
linux_load="YES"
nvidia_load="YES"
---->8----

somewhere in it? If not, then that is where your problem is (incorrectly installed nvidia driver). If it does contain those lines and you do not get /dev/nvidia0 (or /dev/nvidia* actually), then you are obviously having other problems, and more info will be needed.

HTH,
MFM
betatest04 is offline   Reply With Quote
Old 10-06-06, 11:24 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: nvidia drivers on FreeBSD 6.1 RELEASE/GeForce 7600 GS

What does the output of `dmesg` look like immediately following the X start failure?
zander is offline   Reply With Quote
Old 10-12-06, 07:46 PM   #5
collision
Registered User
 
Join Date: Sep 2006
Posts: 3
Default Re: nvidia drivers on FreeBSD 6.1 RELEASE/GeForce 7600 GS

Hey fellas, thanks for all possible solutions to the presented problem.
I solved the error in question by updating the 'nvidia' driver ports and reinstalling it.

It's clear now that you may have problems installing your video card
on a fresh setup of FreeBSD.
I would recommend updating your ports before installing your drivers.
collision is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA drivers 302.17 for Linux, FreeBSD and Solaris News Archived News Items 0 06-16-12 07:20 AM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
NVIDIA drivers 302.11 for Linux, FreeBSD and Solaris News Archived News Items 0 05-19-12 11:20 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 04:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.