Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-08-06, 05:41 PM   #1
rockowallaby
Registered User
 
Join Date: Oct 2006
Posts: 1
Default Floppy drive does not work with nVidia drivers

First, I'd like to say overall the nVidia drivers have been quite good on my system and card. One of the main reasons I bought the card I have is because I heard nVidia has native FreeBSD drivers. The only problem I've had so far, which doesn't affect me all that often, is that the floppy drive does not work when the nVidia kernel module is loaded. It's very strange! I'm currently on version 1.0-8774 of the drivers.

Below is my dmesg output, which should hopefully provide the needed information. The important section (I think) is this. I think when I looked up error code 12 it said something about memory (I think about allocating it). I tried playing with BIOS settings with no luck, and when I remove the preloaded nvidia driver the floppy works fine. Any ideas? Thanks.

-----
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
device_attach: fdc0 attach returned 12
----





Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 6.0-RELEASE #6: Sat Mar 18 20:59:54 EST 2006
rocko@wallaby.rockonet:/usr/src/sys/i386/compile/WALLABYKERNEL
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ (2211.34-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x20fb1 Stepping = 1
Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE ,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH, MMX,FXSR,SSE,SSE2,HTT>
Features2=0x1<SSE3>
AMD Features=0xe2500800<SYSCALL,NX,MMX+,<b25>,LM,3DNow +,3DNow>
Hyperthreading: 2 logical CPUs
real memory = 1073676288 (1023 MB)
avail memory = 1037438976 (989 MB)
ACPI APIC Table: <Nvidia AWRDACPI>
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID: 0
cpu1 (AP): APIC ID: 1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 1.1> irqs 0-23 on motherboard
acpi0: <Nvidia AWRDACPI> on motherboard
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi0: Power Button (fixed)
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
pci_link0: <ACPI PCI Link LNK1> on acpi0
pci_link1: <ACPI PCI Link LNK2> irq 5 on acpi0
pci_link2: <ACPI PCI Link LNK3> irq 3 on acpi0
pci_link3: <ACPI PCI Link LNK4> on acpi0
pci_link4: <ACPI PCI Link LNK5> on acpi0
pci_link5: <ACPI PCI Link LUBA> on acpi0
pci_link6: <ACPI PCI Link LUBB> on acpi0
pci_link7: <ACPI PCI Link LMAC> on acpi0
pci_link8: <ACPI PCI Link LACI> on acpi0
pci_link9: <ACPI PCI Link LMCI> on acpi0
pci_link10: <ACPI PCI Link LSMB> on acpi0
pci_link11: <ACPI PCI Link LUB2> on acpi0
pci_link12: <ACPI PCI Link LIDE> on acpi0
pci_link13: <ACPI PCI Link LSID> irq 11 on acpi0
pci_link14: <ACPI PCI Link LFID> irq 5 on acpi0
pci_link15: <ACPI PCI Link LPCA> on acpi0
pci_link16: <ACPI PCI Link APC1> irq 0 on acpi0
pci_link17: <ACPI PCI Link APC2> irq 0 on acpi0
pci_link18: <ACPI PCI Link APC3> irq 0 on acpi0
pci_link19: <ACPI PCI Link APC4> irq 0 on acpi0
pci_link20: <ACPI PCI Link APC5> irq 16 on acpi0
pci_link21: <ACPI PCI Link APCF> irq 0 on acpi0
pci_link22: <ACPI PCI Link APCG> irq 0 on acpi0
pci_link23: <ACPI PCI Link APCH> irq 0 on acpi0
pci_link24: <ACPI PCI Link APCJ> irq 0 on acpi0
pci_link25: <ACPI PCI Link APCK> irq 0 on acpi0
pci_link26: <ACPI PCI Link APCS> irq 0 on acpi0
pci_link27: <ACPI PCI Link APCL> irq 0 on acpi0
pci_link28: <ACPI PCI Link APCZ> irq 0 on acpi0
pci_link29: <ACPI PCI Link APSI> irq 0 on acpi0
pci_link30: <ACPI PCI Link APSJ> irq 0 on acpi0
pci_link31: <ACPI PCI Link APCP> irq 0 on acpi0
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pci0: <memory> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xd5002000-0xd5002fff at device 2.0 on pci0
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: nVidia OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 10 ports with 10 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfeb00000-0xfeb000ff at device 2.1 on pci0
ehci0: [GIANT-LOCKED]
usb1: EHCI version 1.0
usb1: companion controller, 4 ports each: usb0
usb1: <EHCI (generic) USB 2.0 controller> on ehci0
usb1: USB revision 2.0
uhub1: nVidia EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub1: 10 ports with 10 removable, self powered
atapci0: <nVidia nForce4 UDMA133 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 6.0 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <nVidia nForce4 SATA150 controller> port 0x9f0-0x9f7,0xbf0-0xbf3,0x970-0x977,0xb70-0xb73,0xd400-0xd40f mem 0xd5001000-0xd5001fff irq 20 at device 7.0 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
atapci2: <nVidia nForce4 SATA150 controller> port 0x9e0-0x9e7,0xbe0-0xbe3,0x960-0x967,0xb60-0xb63,0xc000-0xc00f mem 0xd5000000-0xd5000fff irq 21 at device 8.0 on pci0
ata4: <ATA channel 0> on atapci2
ata5: <ATA channel 1> on atapci2
pcib1: <ACPI PCI-PCI bridge> at device 9.0 on pci0
pci_link17: BIOS IRQ 20 for 0.7.INTA is invalid
pci_link18: BIOS IRQ 21 for 0.8.INTA is invalid
pci5: <ACPI PCI bus> on pcib1
emu10kx0: <Creative Audigy 2 Value (Unknown model) [SB????]> port 0xa000-0xa03f irq 17 at device 7.0 on pci5
pcm0: <EMU10Kx PCM Interface> on emu10kx0
pcm0: <SigmaTel STAC9750/51 AC97 Codec>
fwohci0: <Texas Instruments TSB43AB22/A> mem 0xd4008000-0xd40087ff,0xd4004000-0xd4007fff at device 11.0 on pci5
fwohci0: OHCI version 1.10 (ROM=1)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 00:11:d8:00:00:72:a8:15
fwohci0: Phy 1394a available S400, 2 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
skc0: <Marvell Gigabit Ethernet> port 0xa400-0xa4ff mem 0xd4000000-0xd4003fff irq 17 at device 12.0 on pci5
skc0: Marvell Yukon Lite Gigabit Ethernet rev. (0x9)
sk0: <Marvell Semiconductor, Inc. Yukon> on skc0
sk0: Ethernet address: 00:15:f2:1d:29:97
miibus0: <MII bus> on sk0
e1000phy0: <Marvell 88E1000 Gigabit PHY> on miibus0
e1000phy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX-FDX, auto
pcib2: <ACPI PCI-PCI bridge> at device 11.0 on pci0
pci4: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 12.0 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 13.0 on pci0
pci2: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 14.0 on pci0
pci1: <ACPI PCI bus> on pcib5
nvidia0: <GeForce 6200 TurboCache(TM)> mem 0xd0000000-0xd0ffffff,0xc0000000-0xcfffffff,0xd1000000-0xd1ffffff irq 18 at device 0.0 on pci1
nvidia0: [GIANT-LOCKED]
acpi_tz0: <Thermal Zone> on acpi0
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
device_attach: fdc0 attach returned 12
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77b irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/16 bytes threshold
ppbus0: <Parallel port bus> on ppc0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
device_attach: fdc0 attach returned 12
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
orm0: <ISA Option ROM> at iomem 0xd0000-0xd3fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
acd0: DMA limited to UDMA33, device found non-ATA66 cable
acd0: CDRW <LITE-ON COMBO SOHC-5236V/R$07> at ata1-master UDMA33
ad8: 152627MB <Seagate ST3160827AS 3.42> at ata4-master SATA150
SMP: AP CPU #1 Launched!
cd0 at ata1 bus 0 target 0 lun 0
cd0: <LITE-ON COMBO SOHC-5236V R$07> Removable CD-ROM SCSI-0 device
cd0: 33.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
Trying to mount root from ufs:/dev/ad8s1a
lpt0: switched to polled extended mode
rockowallaby is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA and J├╝lich Join Forces to Drive GPU Computing Innovation News Archived News Items 0 06-18-12 09:50 PM
Geforce 440 Go, SuSE 8.0, and new Nvidia drivers loudawg NVIDIA Linux 4 06-01-04 12:54 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 04:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ę1998 - 2014, nV News.