Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-09-07, 10:53 AM   #1
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Restart GDM to get Direct Rendering?

Alright, so the good news is, that I got Beryl working with the 9631 Nvidia Drivers in Edgy...with direct rendering!

BUT! The bad news is, direct rendering is disabled when I boot up ubuntu. Rather, I have to restart GDM, press ctrl-alt-f1, login again from the command line, then type startx.

Magically, when I get back to my desktop, direct rendering is enabled!

I hope this is some kind of strange phenomenon and not something I need to do everytime....

Anyone got any ideas? Thanks!
silverbolt027 is offline   Reply With Quote
Old 02-09-07, 01:13 PM   #2
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Re: Restart GDM to get Direct Rendering?

Is there bug report I can add to help anyone? And if so, how/which bug report do you want?

Thanks!
silverbolt027 is offline   Reply With Quote
Old 02-09-07, 01:24 PM   #3
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Restart GDM to get Direct Rendering?

http://www.nvnews.net/vbulletin/showthread.php?t=46678
netllama is offline   Reply With Quote
Old 02-09-07, 02:27 PM   #4
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Re: Restart GDM to get Direct Rendering?

ahhh sorry about that.

Anyways, here are the logs, one without direct rendering (when Ubuntu starts), and one with direct rendering (after I restart GDM and X).

Thanks!

FYI- I don't think the *without-direct-rendering* log was created with "startx -- -logverbose 6" because I don't know how to startx after a reboot with that option...is there a way to do that?
Attached Files
File Type: zip nvidia_logs.zip (67.7 KB, 86 views)
silverbolt027 is offline   Reply With Quote
Old 02-09-07, 02:34 PM   #5
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Restart GDM to get Direct Rendering?

I don't see anything unusual in your bug reports.

How or where are you determining that direct rendering is disabled?

Also, it sounds like you're starting X via two different mechanisms. When you boot, GDM is started, however I'm assuming that GDM isn't running at all if you're running 'startx'. Can you confirm it this is the case, and if so, test whether (re)starting GDM fixes the problem, or if GDM is the problem?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 02-10-07, 10:00 AM   #6
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Re: Restart GDM to get Direct Rendering?

I determine if direct rendering is enabled or not by running the command:

Code:
glxinfo | grep direct
direct rendering: Yes or No
Yes GDM is running on boot, but once I run the command:

Code:
sudo /etc/init.d/gdm restart
It brings me to a black screen (so maybe it isn't running?). So I press ctrl-alt-f1, login via command prompt, then type startx.

I will see if it is actually restarted when I run the above command.

Any ideas? Thanks!
silverbolt027 is offline   Reply With Quote
Old 02-10-07, 10:04 AM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Restart GDM to get Direct Rendering?

It sounds like GDM is what's broken, not X.
netllama is offline   Reply With Quote
Old 02-10-07, 10:29 AM   #8
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Re: Restart GDM to get Direct Rendering?

Yea, you're right....I just checked, when GDM is running, direct rendering is broken, and when GDM isn't running, direct rendering works...

So can I turn off GDM?
silverbolt027 is offline   Reply With Quote

Old 02-10-07, 11:04 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Restart GDM to get Direct Rendering?

I think you need to talk to some Ubuntu folks about this, as I'm not aware of anyone else hitting this problem, so something is likely misconfigured on your system.
netllama is offline   Reply With Quote
Old 02-11-07, 11:10 AM   #10
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: Restart GDM to get Direct Rendering?

Hmmm... I think there's something wrong with your GDM config. Isn't GDM bringing XGL up instead of the standard Xorg server?
Try launching you X session thru' GDM, and then type: ps aux | grep -i Xgl
And post the result here.

You can also try the command gnome-xgl-settings --disable-xgl (I'm not sure if it's present in ubuntu tho' )

You might also wanna take a look here and remove those entries they metion to disable XGL's autostart with GDM: http://wiki.beryl-project.org/wiki/T..._Gnome_Session
piotrq__ is offline   Reply With Quote
Old 02-11-07, 08:12 PM   #11
silverbolt027
Registered User
 
Join Date: Feb 2007
Posts: 7
Default Re: Restart GDM to get Direct Rendering?

Thanks for the advice netllama and piotrq!

I actually found the problem was with the /etc/gdm/gdm.conf-custom file that was mentioned in that link. I had previously (when I first setup beryl) followed a tutorial that told me to enter an xgl server in that conf file. I commented out those lines, restarted and presto!

Thanks for the troubleshooting help! =D

ps- this command: "gnome-xgl-settings --disable-xgl" doesn't work in Ubuntu.
silverbolt027 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[GeForce 8800 GTS] 2D rendering regression (extreme slowdown) introduced with 295.49 Seb L. NVIDIA Linux 0 06-22-12 06:48 AM
Nvidia driver stopped working after X restart and Kernel taint msgs during boot mikejuni NVIDIA Linux 10 05-21-12 08:30 PM
Remote rendering???? nVIDIOT@NASA NVIDIA Linux 1 08-16-02 01:00 PM

All times are GMT -5. The time now is 06:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.