Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-24-03, 04:00 AM   #1
Ryo-Ohki
Fanatic Cabbit
 
Ryo-Ohki's Avatar
 
Join Date: Nov 2002
Location: Masaki Shrine
Posts: 94
Default Unreal Tournament and gamma issue ?

Hi there,

I'm using the system in my sig (drivers versions as mentioned) and I finally got around installing the original Unreal Tournament (GOTY edition), with the installer from Loki (v436).

I'm primarily using the SDL renderer and the games runs quite well (doesn't get below 110 fps), BUT I have this annoying issue with the gamma setting I can get around, mind you, but can't find a solid fix for it.

When I start the game for the first time, the gamma setting in the intro cutscene is adequate, and the UT main menu also shows up normally when I get to it. However, when I enter a map, I can see the image is suddenly over-exposed. I have to set the gamma compensation to 1 or 2 to get it to an acceptable level, and if I don't, upon returning to the UT menu, the display becomes over-exposed too.

Now, back with a correct gamma setting for gameplay, if I quit the game with that setting, the next time I enter it, the intro custscene is DARK beyond dark and the UT main menu shows up black - I can hear it reacting to commands but I can't see anything. And if I press F11 only once during the intro, things returns to a somehow normal state.


I tried switching to the OpenGL renderer, but it also exhibits funky gamma issues (albeit not as precisely depictable) and performance stinks in comparison, so I'm not really interested in it for UT.


I still have to mention UT2003 is also installed under Linux on this machine, is set to use the OpenGL renderer, but works really great. Any idea ?
__________________
Proud owner of a Hercules Radeon 9800 Pro

Tsunami
Intel P!!!-S Tualatin 1266MHz | ASUS TUSL2-C i815EP | 512MB PC-133 | Antec True Power 380W
MSI GeForce 4 Ti4200 @ 250/515 | Creative SoundBlaster Live! | D-Link DFE-528TX 10/100
2 x Seagate Baraccuda IV 60GB ATA-100 7200 RPM HDDs | Pioneer DVD-117 16x/40x DVD-ROM
Windows 2000 Server SP2
DirectX 8.1 (4.08.01.0881) - nVidia Detonator 43.45 - 3DMark2001 : 8433

Windows 98SE
DirectX 8.1 (4.08.01.0881) - nVidia Detonator 30.82 (WHQL) - 3DMark2001 :

Slackware Linux 8.1
nVidia Linux IA32 Driver 1.0-4191
Ryo-Ohki is offline   Reply With Quote
Old 02-24-03, 07:56 AM   #2
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default

Try editing the gamma setting in the Unrealtournament.ini file. Which is located in you home directory under .loki/ut/System

I had that problem too, and from memory, editing that *.ini file manually seemed to have fixed it. I'm using NV 4191 drivers...

The section to edit is in the [SDLDrv.SDLClient] section. I have my gamma set to 0.600000.

And make sure that the Gamma extension is enabled in the [SDLGLDrv.SDLGLRenderDevice] section.

Should read :-

UseGammaExtension=1

Set the gamma level which best suits you and your system config.
Wolfman [TWP] is offline   Reply With Quote
Old 02-24-03, 12:43 PM   #3
Ryo-Ohki
Fanatic Cabbit
 
Ryo-Ohki's Avatar
 
Join Date: Nov 2002
Location: Masaki Shrine
Posts: 94
Default

Quote:
Originally posted by Wolfman [TWP]
Try editing the gamma setting in the Unrealtournament.ini file. Which is located in you home directory under .loki/ut/System

The section to edit is in the [SDLDrv.SDLClient] section. I have my gamma set to 0.600000.

And make sure that the Gamma extension is enabled in the [SDLGLDrv.SDLGLRenderDevice] section.
Awesome, it works. Thanks a lot !

I knew it had to do with this file, however, to determine the correct item to modify was another story...

Thanks again.
__________________
Proud owner of a Hercules Radeon 9800 Pro

Tsunami
Intel P!!!-S Tualatin 1266MHz | ASUS TUSL2-C i815EP | 512MB PC-133 | Antec True Power 380W
MSI GeForce 4 Ti4200 @ 250/515 | Creative SoundBlaster Live! | D-Link DFE-528TX 10/100
2 x Seagate Baraccuda IV 60GB ATA-100 7200 RPM HDDs | Pioneer DVD-117 16x/40x DVD-ROM
Windows 2000 Server SP2
DirectX 8.1 (4.08.01.0881) - nVidia Detonator 43.45 - 3DMark2001 : 8433

Windows 98SE
DirectX 8.1 (4.08.01.0881) - nVidia Detonator 30.82 (WHQL) - 3DMark2001 :

Slackware Linux 8.1
nVidia Linux IA32 Driver 1.0-4191
Ryo-Ohki is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:32 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.