Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-05-06, 04:13 PM   #1
LightKnight
Registered User
 
Join Date: Nov 2006
Posts: 5
Default Can only get 640x480 on my GeForce 6100...

Hi there,

lspci tells me I've got a GeForce 6100 on my MB, but I can't get it to work with my Samsung 204B LCD at resolutions other than 640x480 using the "nvidia" driver. Using either the "vesa" driver it works at 1600x1200.

I suspect this is the root of the problem - an excerpt from Xorg.0.log:

(WW) NVIDIA(0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU GeForce 6100 at PCI:0:5:0
(--) NVIDIA(0): VideoRAM: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.51.22.28.10
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6100 at PCI:0:5:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1600x1200"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480

But I have no idea how to improve upon that. Using the "vesa" driver, it works at 1600x1200 but the screen updates slowly when e.g. dragging windows, and I can't get the screen saver to turn the monitor off.

Why is it that "vesa" can figure out to use 1600x1200, but "nvidia" can't? All I did to get vesa was change the driver from "nvidia" to "vesa" and remove Load "glx"

I've put as many relevant files as I can think of here:
http://www.morch.com/misc/nvidiaGeForce6100/

I'm running on debian etch as e.g. nvidia-bug-report.log in the above location will confirm.

What to do now? What is the next step?

Peter
LightKnight is offline   Reply With Quote
Old 11-05-06, 04:46 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can only get 640x480 on my GeForce 6100...

Please start X with the following command:s
tartx -- -logverbose 6

and then generate and attach an nvidia-bug-report.log

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-05-06, 06:31 PM   #3
LightKnight
Registered User
 
Join Date: Nov 2006
Posts: 5
Default Re: Can only get 640x480 on my GeForce 6100...

I think I added a zip file with the logverbose 6 nvidia-bug-report.log, but I also added
nvidia-bug-report.log.verbose6
to
http://www.morch.com/misc/nvidiaGeForce6100/
Attached Files
File Type: zip nvidia-bug-report.log.verbose6.zip (26.3 KB, 114 views)
LightKnight is offline   Reply With Quote
Old 11-05-06, 06:34 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Can only get 640x480 on my GeForce 6100...

Here's the problem:

(--) NVIDIA(0): --- EDID for CRT-0 ---
(--) NVIDIA(0):
(--) NVIDIA(0): No EDID Available.

No EDID means that the driver falls back to a safe default of 640x480. You'll need to set UseEDID to false, and provide a modeline.
netllama is offline   Reply With Quote
Old 11-06-06, 09:46 AM   #5
LightKnight
Registered User
 
Join Date: Nov 2006
Posts: 5
Default Re: Can only get 640x480 on my GeForce 6100...

Thanks, netllama!

That lead me in the right direction. I first found a modeline. After -logverbose 6 told me that the HorizSync was illegal, I googled for one of those and found it. Seeing that working, I then discovered that the mouse cursor was missing and found a solution to that, too.

I ended up with these diffs:
morch.com/misc/nvidiaGeForce6100> diff -uw xorg.conf.orig xorg.conf
--- xorg.conf.orig 2006-11-06 08:38:05.000000000 +0100
+++ xorg.conf 2006-11-06 08:39:45.000000000 +0100
@@ -47,6 +47,11 @@
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
+ Option "UseEDID" "False"
+ Option "HWCursor" "off"
+ ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
+ HorizSync 31-101
+ VertRefresh 60-160
EndSection

Section "Device"
@@ -67,7 +72,7 @@
SubSection "Display"
Viewport 0 0
Depth 24
- Modes "1600x1200"
+ Modes "1600x1200@60"
EndSubSection
EndSection

Why EDID detection doesn't work, how the modeline was derived at or what the "correct" HorizSync line should be I interpret "as magic".

Now it works. I've attached my working xorg.conf file as a .zip in case others need it.

Thanks!

Peter
Attached Files
File Type: zip xorg.conf.zip (845 Bytes, 176 views)
LightKnight is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
What You Can Expect From GeForce GRID News Archived News Items 0 06-04-12 04:20 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 05:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.