Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-01-06, 09:05 PM   #1
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default NX7600GT not working

Here's what I have
  1. EPoX GeForce 6100 motherboard (9GF6100-M)
  2. MSI NX7600GT nvidia card
  3. 2 GIG RAM
  4. DELL LCD monitor

The on board nvidia 6100 works fine. When I put the NX7600GT in X locks up. I just installed the beta nvidia drivers 0-9626. That's when I noticed two GPU's. The "nvidia-settings" tool says there are two GPU's. Both are on the same IRQ (50).

How come the system sees two GPU's?

The BIOS doesn't have an option to turn of the onboard video. I checked more then once.

Is there a way to turn off the onboard video in Linux or X?

Again, onboard works fine. When I put the NX7600GT card in X locks up.

I've attached Xorg.0.log. It also shows two GPU's.
Attached Files
File Type: log Xorg.0.log (27.0 KB, 101 views)
dhull is offline   Reply With Quote
Old 11-01-06, 09:46 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NX7600GT not working

You do have two GPUs. The onboard plus the 7600GT. Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-01-06, 10:16 PM   #3
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

I've attached the nvidia error log. I hope I did this right and that eveyone has enough information.
Attached Files
File Type: log nvidia-bug-report.log (109.1 KB, 98 views)
dhull is offline   Reply With Quote
Old 11-01-06, 10:39 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NX7600GT not working

I have a few questions:
0) Have you verified that you're using the latest BIOS for the motherboard?
1) Why are you setting the NvAGP option when you have no AGP hardware?
2) Does this problem persist with a more recent kernel (2.6.18.x)?
3) If you boot with the acpi=off and/or noapic kernel parameters, does that have any impact?
4) Is it possible to disable the C51 GPU in the BIOS?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-02-06, 01:09 AM   #5
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

Here's what I have tried so far.
  1. NvAGP off
  2. acpi=off
  3. 2.6.18.1 kernel

Turning NvAGP off seems to work better. However, X still locks up when running 3D games.

Turning acpi=off seemed to make things worse.

Running the 2.6.18.1 kernel also seemed to make things worse. However, I did notice in dmesg that IRQ sharing is on. I didn't notice it in the older kernel but it could be there and I just missed it.

Oh, the BIOS doesn't have a way to turn the on board video off. I don't know why they took this option out. All they give you are boot options. Which card gets started first or something like that. Putting in the NX7600GT switched it from on board to he NX7600GT. This is what the documentation tells you to do. Just put in the card and boot.

My next step is to upgrade the BIOS. If there is an upgrade.

I'm wondering if I'm the only one having this problem. Has this combination of onboard nvidia and another pcie nvidia card been tested before?

I'm wondering if the nvidia driver is having trouble figuring out what to do with two cards on the same IRQ. Just a thought.

Time to search for a BIOS update.
dhull is offline   Reply With Quote
Old 11-02-06, 03:55 AM   #6
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

I updated the BIOS. I can now turn of the onboard video card. Yes! However, things are still not working. I've attaced a nvidia log file and a screen shot.

I have a question about agpgart. If I'm using pcie why do I need agpgart? Should this be turned off or is it still used?

A lot of instructions tell you to switch between agpgart and the nvidia agp driver. I don't know how to get them to switch. Every time I load the nvidia driver agpgart loads. Maybe I'm missing something here.

All I know at this point is that I've tried a lot of different things and it's still not working. I would say things are just as bad as they were when I started. Nothing seams to make a difference. I think something is better but after using it for a while it seams to be just as bad.

Does the Linux driver work with pcie cards?
Attached Thumbnails
Click image for larger version

Name:	Screenshot1.png
Views:	120
Size:	92.9 KB
ID:	21606  
Attached Files
File Type: log Xorg.0.log (27.0 KB, 76 views)
dhull is offline   Reply With Quote
Old 11-02-06, 03:56 AM   #7
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

I attached the Xorg file insed of the nvidia file. Here it is.
Attached Files
File Type: log nvidia-bug-report-2.log (135.1 KB, 93 views)
dhull is offline   Reply With Quote
Old 11-02-06, 12:10 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: NX7600GT not working

This looks like the current problem:
(WW) NVIDIA(0): WAIT (0, 6, 0x0000, 0x00002eb8, 0x00002eb8)

In some cases the WAIT warnings are due to a kernel or BIOS bug.

Does removing "quiet splash" from your GRUB configuration (and rebooting) help?
Did you try booting with noapic ?

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 11-02-06, 03:01 PM   #9
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

I removed "quiet splash" and it didn't help. I removed "quiet splash" and added noacpi and that didn't help.

I'm noticing some strange output in dmesg. Not sure if this informaiton will be any help but I've attached dmesg. I saved the file right after I loged in. Eveything that happend at boot should be in there.

This is a normal boot. I left in "quiet splash" and didn't add "noacpi".
dhull is offline   Reply With Quote
Old 11-03-06, 12:42 AM   #10
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

looks like dmesg didin't get attached. Here it is.
Attached Files
File Type: log dmesg.log (22.7 KB, 96 views)
dhull is offline   Reply With Quote
Old 11-03-06, 01:07 AM   #11
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: NX7600GT not working

I can't see why the kernel attempts to use the agpgart driver when your using a PCI-E graphics card I have an idea worth trying, you can disable agpgart from the kernel command line by adding agp=off to the end of it.. That way the agp stuff should be totally disabled.. Especially since it's not needed for pci-e.. It's worth a shot..

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 11-03-06, 07:10 PM   #12
dhull
Registered User
 
Join Date: Oct 2006
Posts: 11
Default Re: NX7600GT not working

I've tried adding "agp=off" to the end of the kernel line. It doesn't do anything. The "agpgart" module still loads.

I'm trying to turn all agp items in the kernel off. However, it's not letting me turn of /dev/agpgart. It's either compiled in or as a module. I can't turn it off. I'm using kernel 2.6.18.1.

Can you run without "agpgart"?

If you can how do I turn it off?
dhull is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tony Hawk devs working on Call of Duty News Gaming Headlines 0 06-15-12 11:30 AM
RH7.3, 3123, was working, now it isn't phips NVIDIA Linux 2 10-03-02 03:08 PM
Nvidia 3123 not working on Mandrake 8.2 UP with Geforce 440 MMX tariqf NVIDIA Linux 1 09-17-02 09:22 AM
TV-out not working nomatter what driver.. Dr_Gigolo NVIDIA Windows Graphics Drivers 11 09-11-02 12:11 PM
How do I get Dual Head working? Heath NVIDIA Linux 1 08-22-02 01:44 PM

All times are GMT -5. The time now is 04:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.