Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-03-06, 03:55 AM   #1
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Screen Mode problems with Legacy driver in FC6

GPU NVIDIA TNT2
CPU P4 1.8
OS FC6
I have installed Nvidia legacy drivers using the nvidia installation utility and I can load the module but it is limited to 800x600.
I have searched different threads and even tried adding IgnoreEDID to the Monitor section which caused the module not to load at all.
Currently the xorg.conf does not have a "Monitor" section. This is the way it was configred.
The nv driver works fine but I would like to use the acceleration of the nvidia module.
Here is the nvidia-bug-report.log
Attached Files
File Type: log nvidia-bug-report.log (99.6 KB, 94 views)
hadim72 is offline   Reply With Quote
Old 11-03-06, 11:43 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Screen Mode problems with Legacy driver in FC6

You didn't specify Hsync or Vrefresh in your X configuration, so the driver fell back to safe defaults, which will only provide a maximum 800x600 mode.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-03-06, 03:11 PM   #3
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: Screen Mode problems with Legacy driver in FC6

Thanks for the reply!

The xorg.conf file that you see is the default that was made by X, and the nv driver works fine with this. I am sure you noticed that there is no Monitor section in this file. So I went ahead and wrote a section based on the log file from the nv driver, and included the VertRefresh and Hsync ranges as well and the result was the same.
It is interesting that the same nvidia legacy driver worked well with FC5.

I would appreciate more suggestions!
hadim72 is offline   Reply With Quote
Old 11-03-06, 03:16 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Screen Mode problems with Legacy driver in FC6

If adding the appropriate section didn't help, then I'll need to see a new bug report.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-03-06, 03:18 PM   #5
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: Screen Mode problems with Legacy driver in FC6

I will post the new bug report as soon as I get back home. Thanks!
hadim72 is offline   Reply With Quote
Old 11-03-06, 08:16 PM   #6
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: Screen Mode problems with Legacy driver in FC6

I am attaching three files.
1. nvidia-bug-report-1.log:
This is when I added a Monitor section to the xorg.conf
2. nvidia-bug-report.log:
This time I went ahead and added an "IgnoreEDID" and specified the mode "1280x1024".
In both cases it seems that the monitor section does not get parsed and it does not matter if you add anything to the xorg.conf.
3.Xorg.0.log
This is my log with the "nv" driver in place. This will recognize the modes appropriately.

Thanks for your help!
Attached Files
File Type: log nvidia-bug-report-1.log (104.4 KB, 74 views)
File Type: log nvidia-bug-report.log (104.8 KB, 83 views)
File Type: log Xorg.0.log (54.6 KB, 92 views)
hadim72 is offline   Reply With Quote
Old 11-03-06, 09:45 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Screen Mode problems with Legacy driver in FC6

Actually, you still have another problem:
(WW) No monitor specified for screen "Screen0".

You need to add a Monitor to the Screen section, or you'll continue to get this:
(II) NVIDIA(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz
(II) NVIDIA(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-04-06, 12:27 AM   #8
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: Screen Mode problems with Legacy driver in FC6

How should I do this? Should I add a subsection to the section screen? or there is some other way?
hadim72 is offline   Reply With Quote

Old 11-04-06, 12:31 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Screen Mode problems with Legacy driver in FC6

Just add the following to the Screen section:
Monitor "Monitor0"
netllama is offline   Reply With Quote
Old 11-04-06, 01:17 AM   #10
hadim72
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: Screen Mode problems with Legacy driver in FC6

Thanks for your help!
I already changed the xorg.conf and I had to fiddle a little bit more to get the nvidia driver to behave. Now it covers all of the correct modes. I am attaching the nvidia-bug-report.log
I have two little problems:
1. Now the driver only supports some of the valid screen refresh rates. For example I know that this card can support 1400x1050x75 but now it only goes up to 70. Why is that?
2. For some reason the glx is not working so I get the notorious "Xlib: extension "GLX" missing on display ":0.0"." from glxinfo.

Any suggestions?
Attached Files
File Type: log nvidia-bug-report.log (94.0 KB, 97 views)
hadim72 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 09:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 06:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.