Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-14-06, 05:26 AM   #1
nickfixit
Registered User
 
Join Date: Sep 2006
Posts: 5
Default Toshiba 6100 NVidia GForce4 420 Go Black Screen

After much pain and web searching here is how I resolved the nvidia 3d patch:

First patch your system upto date using YAST check your kernel (uname -r)

Download the driver from nvidia.

Upack it it using

sh NVIDIA-Linux-x86-1.0-8774-pkg1.run -x


Goto the folder

/usr/src/nv/


and edit the file

os-registry.c

modify the lines:

NVreg_SoftEDID = 0;
NVreg_Mobile = 2;


go down to init 3

init 3

from the folder run:

nvidia-installer -q

Follow the instructioins then:

sax2 -r -m 0=nvidia

(must run -r otherwise you will end up with an 800x600 fussy screen)

This should give you the screen with black bar down the right hand side.

Modify the

/etc/X11/xorg.conf

under the screen section add:

Section "Screen"
Option "ExactModeTimingsDVI" "TRUE"
Option "ModeValidation" "DFP-0: NoEdidDFPMaxSizeCheck, NoVesaModes"


All things being equal that should do it.

Good luck I hope this helps.
nickfixit is offline   Reply With Quote
Old 09-18-06, 03:06 PM   #2
shanepardue
Registered User
 
shanepardue's Avatar
 
Join Date: Sep 2006
Location: Kansas City, MO
Posts: 12
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

ok, now i'm using ubuntu and have had the same problem with the black screen. when i boot up, it gets all the way to where it loads my login screen, but then it goes black and hangs. i'm guessing this would fix that issue? right now i'm using "nv" as a driver and it's ok, but "nvidia" is what causes problems. any help would be greatly appreciated!
shanepardue is offline   Reply With Quote
Old 09-22-06, 09:03 AM   #3
nickfixit
Registered User
 
Join Date: Sep 2006
Posts: 5
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

I robbed this from lots of places with a lot of trial and error.

You can but try.

Good luck.

If you find anything new please post it.
nickfixit is offline   Reply With Quote
Old 09-24-06, 12:47 AM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

Does this problem persist with the 1.0-9625 beta driver?

-Lonni
netllama is offline   Reply With Quote
Old 09-24-06, 05:01 PM   #5
shanepardue
Registered User
 
shanepardue's Avatar
 
Join Date: Sep 2006
Location: Kansas City, MO
Posts: 12
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

yes i did try it with that driver and the latest stable. still no fix. i couldn't follow the above guide to the "T" because i couldn't find the files that i was supposed to edit. my error logs are saying something along the lines of kernel error or something.

here is a thread i was involved in to get this problem fixed, but never did get it working. http://ubuntuforums.org/showthread.php?t=259034

i appreciate your help and would loooooove to have the nvidia driver installed. thank you!
shanepardue is offline   Reply With Quote
Old 09-24-06, 05:33 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

Please generate and post an nvidia-bug-report.log.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 09-24-06, 06:06 PM   #7
shanepardue
Registered User
 
shanepardue's Avatar
 
Join Date: Sep 2006
Location: Kansas City, MO
Posts: 12
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

i emailed the bug report to the address on the log and i thought i'd post it here also in case of helping the fix. thank you!
Attached Files
File Type: log nvidia-bug-report.log (103.3 KB, 143 views)
shanepardue is offline   Reply With Quote
Old 09-24-06, 06:10 PM   #8
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

This bug report is against 1.0-7174, which is no longer supported. You stated that the problem was also present with 1.0-9625. I'd like to see a bug report against a supported driver version (1.0-8774 or 1.0-9625).

Thanks,
Lonni
netllama is offline   Reply With Quote

Old 09-24-06, 06:43 PM   #9
shanepardue
Registered User
 
shanepardue's Avatar
 
Join Date: Sep 2006
Location: Kansas City, MO
Posts: 12
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

sorry bout that..i removed the old driver and reinstalled the latest driver. the log doesn't seem to recognize the latest driver that is currently installed according to the .sh install file. i've attached the most recent log.

thanks!
Attached Files
File Type: log nvidia-bug-report.log (124.0 KB, 127 views)
shanepardue is offline   Reply With Quote
Old 09-24-06, 07:59 PM   #10
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

This bug report is against the nv X driver, not the nvidia X driver.

-Lonni
netllama is offline   Reply With Quote
Old 09-24-06, 08:03 PM   #11
shanepardue
Registered User
 
shanepardue's Avatar
 
Join Date: Sep 2006
Location: Kansas City, MO
Posts: 12
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

i guess i'm not sure what i'm doing then. i download the driver and reboot in recovery mode (without x running). i then run the installer and it asks me if i want to configure the xserver using the driver i just installed. of course i do then i reboot, get an error, x shuts down, and i generate a bug report using nvidia-bug-report.sh. am i doing something wrong?
shanepardue is offline   Reply With Quote
Old 09-26-06, 05:24 PM   #12
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba 6100 NVidia GForce4 420 Go Black Screen

According to your new bug report, you have the 1.0-9625 X driver installed, with the 1.0-7174 nvidia kernel module.

I'd suggest reading:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
netllama is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Maximus Fires Up Visual Effects In Men in Black 3 News Archived News Items 0 06-26-12 06:00 PM
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
[Ubuntu] nVidia driver 1.0.8762 and black screen Manthis NVIDIA Linux 5 05-26-12 07:03 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM

All times are GMT -5. The time now is 06:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.