Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-04-06, 09:37 AM   #25
jdieter
Registered User
 
Join Date: Nov 2006
Location: Beirut
Posts: 15
Smile [Solved] Display blinks rapidly/random system freezes with AIGLX/1.0-9626

f1f0, you, sir, are a genius!

f1f0 PM'd me about a module option, NVreg_RegistryDwords="PerfLevelSrc=0x2222", that solved the problem.

I read as much as I could on it (which wasn't a whole lot), and found that the option is comparable to an option set in the Windows INF file. I went ahead and checked the INF file for my computer, and, sure enough, it was set. So now I understand where the option came from, though it would have been nice if it was better documented (i.e. in the "if you experience system instability, read this first" thread).

I am quite curious as to what exactly I am setting with this option and would greatly appreciate any explanation by <insert favorite NVIDIA employee here>.

To sum up, AIGLX works without errors (at least until I suspend and resume, but that will go in another thread), and, as an added bonus, it also got rid of some funny dots I had in text-mode.

Once again, thanks f1f0.

Jonathan
jdieter is offline   Reply With Quote
Old 12-04-06, 10:27 AM   #26
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: [Solved] Display blinks rapidly/random system freezes with AIGLX/1.0-9626

Thanks for the info about the PerfLevelSrc=0x2222. Seems to fix my problem with blinking display also (I didn't have stability problems though).

Perhaps a general laptop issue?
See also : http://www.nvnews.net/vbulletin/showthread.php?t=80888
Lithorus is offline   Reply With Quote
Old 12-10-06, 07:55 AM   #27
kingslayer
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Display blinks rapidly/random system freezes with AIGLX/1.0-9626

jdieter,

You're now running stable with desktop effects on? Any other steps you took other than setting NVreg_RegistryDwords="PerfLevelSrc=0x2222"? Which driver version are you using?

Mine still hangs with 9629 and 9742 . Haven't tried with the recently released one.

Update: Just tried with driver 9631. With NVreg_RegistryDwords="PerfLevelSrc=0x2222", Xorg restarted twice during the stress test (instead of just hanging). Then ironically hung when I switched to text-mode. I guess that's an improvement . I give up for now.

Last edited by kingslayer; 12-10-06 at 08:30 AM.
kingslayer is offline   Reply With Quote
Old 12-10-06, 11:17 PM   #28
jdieter
Registered User
 
Join Date: Nov 2006
Location: Beirut
Posts: 15
Default Re: Display blinks rapidly/random system freezes with AIGLX/1.0-9626

I'm using 1.0-9742 with stable desktop effects. The easiest way to check what option you should be using is to open your Windows driver's .INF file and see what PerfLevelSrc option it uses. I noticed there are other possibilities (0x2323, 0x0001), so verify that it's the same as your Windows driver uses.

Hope that helps,

Jonathan
jdieter is offline   Reply With Quote
Old 12-12-06, 07:38 AM   #29
kingslayer
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Display blinks rapidly/random system freezes with AIGLX/1.0-9626

Jonathan,

Thanks. My driver's .INF file didn't have an entry for PerfLevelSrc. Both versions 93.71 from Nvidia and the one supplied by Palit. I accidentally downloaded the driver for geforce go and it had PerfLevelSrc=0x2222.

So I just tried different values. What I do to test is open 230 folders in nautilus. It's fine without desktop effects but hangs at around 150 to 180 folders otherwise. PerfLevelSrc=0x0000 looked promising for a while. At around 150 folders, the window decoration disappeared and it was able to complete loading all folders. I was able to do other effects like the cube switch and arrange windows. It was slow but working. It finally hung when I started beryl to restore the window decorations and tried arrange windows again. But even then I could still switch to the console. I rebooted and tried it again. Hung on 170 folders.

So it could be something in compiz or window decorations that triggers the hang. When I've got lots of free time I'd try other keywords in the .INF file. But for now I guess I'm stuck without desktop effects .
kingslayer is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 11:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.