Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-14-05, 08:08 AM   #1
svemuri
Registered User
 
Join Date: Apr 2005
Posts: 4
Default HDTV (1920x1080) video + nvidia + mythtv = Frustration

I've been tinkering with my mythtv HDTV setup for almost a month now and here are the various problems I've encountered with nVidia driver.

I am using it with a P4 3GHz machines and 6200 TC card. I've tried both pcHDTV and Air2PC cards. I am running 7667 drivers

My Toshiba TV only has Component in (no DVI) and it only likes 1080i (not 720p).

1. Was able to get Component Out to work using Option "TVStandard" "HD1080i". I get 800x600 picture centered and video works fine in that mode. However thats not HDTV. So I tried a standard modeline for 1920x1080. The picture is horribly overscanned and I couldn't find a way to work around that. More importantly, playing any kind of video using xv locks up the machine instantly.
I found the following post with same problem
http://www.nvnews.net/vbulletin/show...ight=component
http://www.nvnews.net/vbulletin/show...ight=component

2. So, I gave up on the component out. Hooked up a RCA transcoder to the VGA port. 920x540p works fine. I was even able to tweak that modeline to get rid of the overscan completely. But its not HDTV. So I tried the standard 1920x1080i modeline (interlaced). As the following post describes, now I get a "split" and "wrapped" screen! So can't win there either.
http://www.nvnews.net/vbulletin/show...ight=component

Both of these problems have been reported a while ago. I haven't seen any one from nVidia acknolwedge these problems. So at this point, I don't think nVidia is a viable video card choice if you need HDTV 1080i unless some one knows a work around for this situation.

If any one knows a work around, or recommendations for alternative video card (nvidia or ATI or other) for 1080i HDTV video, your help is much appreciated.

Thanks
Sarat.
svemuri is offline   Reply With Quote
Old 08-15-05, 10:59 AM   #2
r-woelk
Registered User
 
Join Date: May 2005
Posts: 20
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

I am running a Toshiba 26HF84 tube HDTV from an FX5200 using DVI-HDMI adapter.
with the option "noddc", the 720p modeline I use is;

ModeLine "1280x720" 74.2 1280 1384 1440 1648 720 726 732 750

I did get 1080i working on the 7174 driver at one point, but I can't find the modeline right now.

since I don't have any hi-def content in mythtv(yet) this resolution is fine, however I still have quite high overscan. I use mythtv's settings to shrink the gui to compensate for overscan. It works the same way in 1080i.

I got into the service menu on my tv to change the overscan size, but the geometry at the edges is really bad, so I set it back to normal
r-woelk is offline   Reply With Quote
Old 11-20-05, 01:29 AM   #3
Sewage_Calamari
Registered User
 
Join Date: Nov 2005
Posts: 2
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

Hey, just wondering if anyone has discovered a fix for this? I have a TV attached via component-out also, and everything is great. Except, for the overscan problem, of course. I can't find a custom modeline that the nvidia drivers will accept either. There doesn't seem to be any way to scale the picture down to fit the screen. Anyone have any advice?
Sewage_Calamari is offline   Reply With Quote
Old 11-20-05, 04:19 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

There is currently a known bug where interlaced modes fail to work properly, and will be resolved in a future driver release.

Sewage_Calamari, without seeing a bug report, I can't really comment on the problem you're reporting.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-10-05, 02:45 PM   #5
robfish
robfish
 
Join Date: Jun 2005
Posts: 6
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

I have similar problems to others in this thread.
I just installed the 8134 nvidia drivers and now instead of b/w component output I get blue/white.

Can someone please post (or email me - robert at fisher dot net dot nz) their working xorg.conf file or the relevant sections of it?

I can get high definition output using a knoppix generated file but incorrect resolution and stuttering video using vesa driver.
robfish is offline   Reply With Quote
Old 12-10-05, 03:19 PM   #6
JoshPrismon
Registered User
 
Join Date: Nov 2005
Posts: 24
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

Quote:
Originally Posted by robfish
I have similar problems to others in this thread.
I just installed the 8134 nvidia drivers and now instead of b/w component output I get blue/white.

Can someone please post (or email me - robert at fisher dot net dot nz) their working xorg.conf file or the relevant sections of it?

I can get high definition output using a knoppix generated file but incorrect resolution and stuttering video using vesa driver.
I am seeing the same problems, and have not found a fix for it other then downgrading to S-VIDEO.
JoshPrismon is offline   Reply With Quote
Old 12-22-05, 10:58 AM   #7
korpenkraxar
Registered User
 
Join Date: Dec 2005
Posts: 7
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

I have the same problem with 1920x1080 in 1080i. It overscan's quite badly - I loose about 15% of the total screen area. Has anyone found a custom resolution that can do it, or a virtual resolution-within-resolution (such as 1700x1000 within 1920x1080) that works for both desktop and video modes?
korpenkraxar is offline   Reply With Quote
Old 12-23-05, 01:29 AM   #8
1aggie02
Registered User
 
Join Date: Dec 2005
Posts: 1
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

I have GeForce 6600 GT and using the component out feature. My TV is a Samsung 26" 1080i CRT HDTV. When booting and using the default VESA driver, the picture looks fine. When I load the nvidia driver, i get the Blue/White effect described above. I am trying to confirm whether or not Nvidia driver supports the component out feature... the README only mentions SVIDEO and COMPOSITE as options.
1aggie02 is offline   Reply With Quote

Old 12-23-05, 04:26 AM   #9
colinmcc
Registered User
 
Join Date: Jul 2005
Posts: 14
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

Quote:
Originally Posted by netllama
There is currently a known bug where interlaced modes fail to work properly, and will be resolved in a future driver release.
Is there a list, somewhere, of 'known' bugs? I certainly had no inkling that the 6600 would give me the kind of grief I've had trying to get HDTV and even SDTV working.

I have had difficulty getting 576i to work, with no way of knowing (until now) that it simply would never work. What other difficulties could I avoid?

Colin.
colinmcc is offline   Reply With Quote
Old 08-03-06, 05:34 PM   #10
Tonyt1234563
Registered User
 
Join Date: Aug 2006
Posts: 13
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration


Does anyone know if the issues at the top of this post were solved? I am seeing the exact same problems Surat posted months ago, with the current latest drivers, latest core, etc.

I also have the 6600 and need to run in 1080i. I also got it to run in 1920 with bad overscan, and lockup on video.

Does anyone run Myth in HD mode with a 6600? How the heck did you do it!?

Tony
Tonyt1234563 is offline   Reply With Quote
Old 08-03-06, 05:55 PM   #11
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

Quote:
Originally Posted by Tonyt1234563

Does anyone know if the issues at the top of this post were solved? I am seeing the exact same problems Surat posted months ago, with the current latest drivers, latest core, etc.

I also have the 6600 and need to run in 1080i. I also got it to run in 1920 with bad overscan, and lockup on video.

Does anyone run Myth in HD mode with a 6600? How the heck did you do it!?

Tony
A few workarounds I used:
Fake a twinview config with the VGA port, the video will have video tearing, but at least it's useable.
Ended up just buying a VGA->Component transcoder..... which costs more than motherboard w/6150.

The only successes for 1080i w/ xv(mc) video that I've found are for AGP boards. Everything works fine under MS Windows, so doubt it's a hardware problem and just something quirky under linux.
asdere is offline   Reply With Quote
Old 08-03-06, 06:28 PM   #12
Tonyt1234563
Registered User
 
Join Date: Aug 2006
Posts: 13
Default Re: HDTV (1920x1080) video + nvidia + mythtv = Frustration

Thx Asdere, I'll look into that. It sucks that you have to buy an expensive piece of hardware because of a software problem.
Tonyt1234563 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVIDIA GeForce GTX 670 Video Card Review @ [H] News GeForce GTX 670 Reviews 0 05-10-12 10:11 AM
NVIDIA & EVGA GeForce GTX 670 2GB Video Card Review (LegitReviews) News GeForce GTX 670 Reviews 0 05-10-12 08:52 AM

All times are GMT -5. The time now is 12:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.