Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-04-06, 04:26 PM   #1
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default No 3d TNT2 Ubuntu

Hi all

I have this problem... installed nvidia legacy thru synaptic on ubuntu 6.10 (grafic card ELSA ERAZOR III/ Riva TNT2)... changed xorg.conf from nv to nvidia.... it boots up with the nvidia logo.... but... no 3d... and when i say no 3d i mean absolutely no 3d.... everithing else is ok...

My glxinfo output is:


name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x23 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x24 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x25 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x26 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x27 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x28 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x29 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2a 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2b 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2c 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2d 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2e 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x2f 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x30 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x80 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Segmentation fault (core dumped)

my lsmod is:

Module Size Used by
nls_utf8 2304 1
nls_cp437 6016 1
vfat 13440 1
fat 54556 1 vfat
binfmt_misc 11784 1
nfsd 231844 13
exportfs 6016 1 nfsd
lockd 65800 2 nfsd
sunrpc 160188 8 nfsd,lockd
cpufreq_userspace 4372 0
cpufreq_stats 5892 0
freq_table 4996 1 cpufreq_stats
cpufreq_powersave 2048 0
cpufreq_ondemand 6944 0
cpufreq_conservative 7200 0
video 16644 0
tc1100_wmi 7428 0
sbs 15776 0
sony_acpi 5516 0
pcc_acpi 13184 0
i2c_ec 5376 1 sbs
hotkey 10660 0
dev_acpi 11140 0
button 7056 0
battery 10756 0
container 4736 0
ac 5892 0
asus_acpi 16792 0
sg 35356 0
sd_mod 21648 2
ipv6 257632 16
af_packet 21768 2
dm_mod 60088 4
md_mod 78740 0
lp 11972 0
tsdev 8256 0
nvidia 3931148 8
usbhid 42464 0
snd_via82xx 28696 4
gameport 15368 1 snd_via82xx
snd_ac97_codec 96672 1 snd_via82xx
snd_ac97_bus 2432 1 snd_ac97_codec
snd_mpu401_uart 8704 1 snd_via82xx
snd_pcm_oss 46080 0
snd_pcm 80520 4 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc 10504 2 snd_via82xx,snd_pcm
snd_mixer_oss 18560 2 snd_pcm_oss
snd_seq_dummy 4100 0
snd_seq_oss 34304 0
snd_seq_midi 9088 0
snd_rawmidi 25600 2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event 7808 2 snd_seq_oss,snd_seq_midi
snd_seq 53360 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
snd_timer 23172 2 snd_pcm,snd_seq
snd_seq_device 8972 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
via_rhine 23940 0
mii 6016 1 via_rhine
snd 55428 16 snd_via82xx,snd_ac97_codec,snd_mpu401_uart,snd_pcm _oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi ,snd_seq,snd_timer,snd_seq_device
soundcore 9952 2 snd
shpchp 40856 0
pci_hotplug 31284 1 shpchp
evdev 10496 1
usb_storage 73408 1
scsi_mod 141320 3 sg,sd_mod,usb_storage
libusual 15632 1 usb_storage
psmouse 40072 0
serio_raw 7300 0
floppy 60676 0
pcspkr 3072 0
via_agp 10368 1
agpgart 33456 2 nvidia,via_agp
parport_pc 36132 1
parport 37320 2 lp,parport_pc
i2c_viapro 8980 0
i2c_core 22288 2 i2c_ec,i2c_viapro
rtc 12596 0
ext3 138632 2
jbd 55700 1 ext3
ehci_hcd 32520 0
uhci_hcd 23176 0
usbcore 130304 6 usbhid,usb_storage,libusual,ehci_hcd,uhci_hcd
ide_generic 1536 0
ide_cd 32416 0
cdrom 37792 1 ide_cd
ide_disk 17664 4
via82cxxx 9604 0 [permanent]
generic 4868 0
thermal 14600 0
processor 26028 1 thermal
fan 5124 0
fbcon 40480 0
tileblit 2944 1 fbcon
font 8448 1 fbcon
bitblit 6272 1 fbcon
softcursor 2432 1 bitblit
vesafb 8348 0
capability 5000 0
commoncap 7808 1 capability

The nvidiafb does not load and the vesafb does - has this anything to do with the problem and if how do i fix it?

Please help cause i am gettin desperate

Thx...

JB
jbtito is offline   Reply With Quote
Old 11-04-06, 04:44 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: No 3d TNT2 Ubuntu

Has all of the nvidia readme been followed, eg editing xorg.conf to load the glx X module? Attach a nvidia bug report.
whig is offline   Reply With Quote
Old 11-04-06, 04:52 PM   #3
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

Well...

I followed the instructions on the ubuntu forums....

Used synaptic to install nvidia-glx-legacy and kernel commons to intall.

How do i get the bug report?

My xorg.conf is attached

thx for the quick reply
Attached Files
File Type: txt xorg.conf.txt (4.9 KB, 187 views)
jbtito is offline   Reply With Quote
Old 11-04-06, 05:01 PM   #4
hgb
Registered User
 
Join Date: Jan 2003
Posts: 31
Default Re: No 3d TNT2 Ubuntu

http://www.nvnews.net/vbulletin/showthread.php?t=46678 in "3a".
hgb is offline   Reply With Quote
Old 11-04-06, 05:15 PM   #5
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

My log file...

Anyone?
Attached Files
File Type: txt nvidia-bug-report.log.txt (79.3 KB, 136 views)

Last edited by jbtito; 11-04-06 at 06:40 PM.
jbtito is offline   Reply With Quote
Old 11-04-06, 08:48 PM   #6
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: No 3d TNT2 Ubuntu

Can you tell me what this rootfs is:
Code:
/proc/cmdline
root=UUID=8f05b06e-18d5-4157-bd28-d4113fb9eb81 ro quiet splash
whig is offline   Reply With Quote
Old 11-05-06, 03:38 AM   #7
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

I dont really know...

I thbik the problem with my lack of the 3d support has to do with the kernel modules....

nvidiafb does not load and vesafb does...


Am i right and if how do i change it?
jbtito is offline   Reply With Quote
Old 11-05-06, 09:10 AM   #8
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

Hi

Still not working. Does really noone know how to fix this problem?

JB
jbtito is offline   Reply With Quote

Old 11-05-06, 11:49 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No 3d TNT2 Ubuntu

nvidiafb is a framebuffer console driver, and has no association with the nvidia X driver.

According to your bug report, the NVIDIA glx module is loaded and in use. Are you trying to use XGL, or just a normal X server?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-05-06, 11:55 AM   #10
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

Well, i am runnin the normal boot process of ubuntu Edgy 6.10. with Gnome.

Really dunno what to say here

Thx

Jb
jbtito is offline   Reply With Quote
Old 11-05-06, 11:57 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No 3d TNT2 Ubuntu

Then perhaps you should try reinstalling the driver, as your bug report doesn't seem to correspond with the problem you're reporting.
netllama is offline   Reply With Quote
Old 11-05-06, 12:16 PM   #12
jbtito
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: No 3d TNT2 Ubuntu

Okey...

Uninstalled nvidia-glx-legacy and reinstalled (also kernel-commons, kernel restricted modules). Reboot...


Same thing..

I really dunno what to do..

Again: My card ELSA ERAZOR III LT (Nvidia TNT2)..

Thx

JB
jbtito is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 04:20 PM
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 05:20 AM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 02:20 PM
295.49 fails on Acer 5755G under Ubuntu 10.04 AdrianMay NVIDIA Linux 2 05-09-12 06:07 AM
TNT2 M64 vs Voodoo3 3000 AGP Jake Other Desktop Graphics Cards 11 08-25-02 04:18 AM

All times are GMT -5. The time now is 05:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.