Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-30-06, 11:43 PM   #1
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Default Toshiba TE2100 problem with Beta driver

Hi folks,

I've tried to install the Beta driver with both Mandriva 2007 and SuSE 10.1 and have the same problem on my laptop.

It works great in 3D with an external monitor, but I can't get the laptop display to do anything but stay black.

If I try and set up the second monitor using NVIDIA Settings (which does recognise that there is another monitor on the system, but shows it as disabled) I get thrown out to the login screen with the remote monitor only working.

This happens regardless of the choice I make (TwinView or Seperate X), and as soon as I select the value (don't get the chance to save to a config file or anything like that.).

Any clues to follow here?

I'd really love to get this working on both monitors. Its great on the external one, but useless to me without working on the laptop one naturally.

The card is a GeForce 420 GO

Nvidia Settings reports:

LCD screen: Nvidia default flat panel (DFP-0)
CRT screen: Hyundai (CRT-0)

I've attached the bug-report.

Thanks

Peter
Attached Files
File Type: log nvidia-bug-report.log (90.8 KB, 99 views)

Last edited by pnunn; 10-31-06 at 12:08 AM. Reason: Added log.
pnunn is offline   Reply With Quote
Old 10-31-06, 11:03 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba TE2100 problem with Beta driver

According to your bug report, you've only configured X to use a single display, which is defaulting to the CRT. Are you trying to use both the CRT & DFP simultaneously? If not, then set UseDisplayDevice to DFP.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-31-06, 05:04 PM   #3
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Default Re: Toshiba TE2100 problem with Beta driver

Thanks for this Lonni,

can you give me a clue where to find that setting? Is it in the xorg.conf file?

I'd really like to have both monitors working, but as I said in the message, as soon as I try and enable the LCD monitor in the Nvidia settings program, it kills the current X session and throws me back to the login screen with no changes written anywhere it seems.

I'll have a hunt around for the setting and see what happens.

Thanks.

Peter.
pnunn is offline   Reply With Quote
Old 10-31-06, 05:16 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba TE2100 problem with Beta driver

You need to add the option to xorg.conf. See the driver README for more details on its usage.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-31-06, 06:33 PM   #5
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Default Re: Toshiba TE2100 problem with Beta driver

Tankyou again Lonni, sadly no Joy.

I read the documentation and added the option to force the display.

When I re-started X it dropped me to a text session.

I did startx and errors were thrown (not sure how to capture them to display), but have attached the Xorg logs (.old file remaned as the .log file).

I did the bug-report again (attached)

Anything else I can try?

Thanks.

Peter.
Attached Files
File Type: log Xorg.0.log (17.3 KB, 91 views)
File Type: log nvidia-bug-report.log (75.6 KB, 90 views)
pnunn is offline   Reply With Quote
Old 10-31-06, 06:37 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Toshiba TE2100 problem with Beta driver

Looks like X crashed:

Backtrace:
0: /etc/X11/X(xf86SigHandler+0x88) [0x80c7b78]
1: [0xbfffe420]
2: /usr/lib/xorg/modules/drivers/nvidia_drv.so [0xb71d2985]
Fatal server error:
Caught signal 11. Server aborting

If you disconnect the CRT, and do not use the UseDisplayDevice option, does that have any impact?
netllama is offline   Reply With Quote
Old 10-31-06, 10:41 PM   #7
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Default Re: Toshiba TE2100 problem with Beta driver

If I do that, I just get a blank screen with a little bit of disk activity every so often.

Peter.
pnunn is offline   Reply With Quote
Old 11-01-06, 10:36 PM   #8
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Default Re: Toshiba TE2100 problem with Beta driver

Any more thoughts anyone please?

P.
pnunn is offline   Reply With Quote

Old 11-06-06, 09:45 AM   #9
pnunn
Registered User
 
Join Date: Oct 2006
Posts: 16
Unhappy Re: Toshiba TE2100 problem with Beta driver

Seems we have lost interest in trying to get these problems with the primary monitors fixed.

Looking at the forum's its pretty obvious this is a gereric problem with some laptops.

How about a hand to get it going guys. This is making my ATI one look pretty good at the moment and that's a bit sad for Nvidia.

If there is no more help to be had here, is there another way of getting tis bug report into Nvidia themselfs to get it worked on?

Thanks.

Peter.
pnunn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
304.48 Beta driver out shteve NVIDIA Windows Graphics Drivers 14 06-29-12 07:14 AM
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-16-12 07:35 AM
Graphics driver installation problem (your comments will be highly appreciated) apuurboo NVIDIA GeForce 400/500 Series 0 06-13-12 07:58 AM
Download GeForce GTX 690 Beta Driver 301.34 Here - http://www.nvnews.net#driver MikeC Archived News Items 0 05-03-12 10:39 PM
Problem with Ethernet (nvnet) driver for RH 7.3 bernz NVIDIA Linux 4 08-05-02 10:18 AM

All times are GMT -5. The time now is 08:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.