Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-08-06, 03:58 PM   #13
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9629 - black window bug with Beryl / Compiz persists?

This is a known driver limitation, and was discussed & explained in depth in an older thread on this forum.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-10-06, 05:58 AM   #14
23meg
Registered User
 
Join Date: Sep 2005
Posts: 23
Default Re: 9629 - black window bug with Beryl / Compiz persists?

I see; it seems TurboCache memory cannot be utilized at the moment. Is there any plan to fix this in the next release?
23meg is offline   Reply With Quote
Old 11-10-06, 12:43 PM   #15
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 9629 - black window bug with Beryl / Compiz persists?

There is a plan to resolve this, however the timeframe hasn't been finalized.
netllama is offline   Reply With Quote
Old 11-10-06, 01:11 PM   #16
Ta0
Registered User
 
Join Date: Nov 2006
Posts: 6
Default Re: 9629 - black window bug with Beryl / Compiz persists?

It could be great if NV1X and NV2X (for example 440MX) don't be move to legacy before this tfp memory issue were solved.
Ta0 is offline   Reply With Quote
Old 11-19-06, 01:32 PM   #17
ari.reads
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: 9742 - black window bug with Beryl / Compiz persists?

I have a 6200 card with 128M and I am also experiencing this annoying bug; it shows up with Beryl 0.1.2 only. With Beryl 0.1.1 I don't have this problem. Beryl people claims this is a bug in NVIDIA driver.

I am currently using 9742 and the Bug still persists. This is on ubuntu edgy 6.10, with the official ubuntu 2.6.17 kernel.

What I notice, is that lshw and lspci report an incorrect amount of memory in the card; they report 256MB but my card has only 128MB; I don't know if this is related to the problem or not.

Xorg logs however report the correct 128MB, as seen by nvidia-bug-report.log (see extract copied below).

If someone from NVIDIA can shed more light and tell us when to expect a solution that would be great. I upgraded my nvidia card just to use AIGLX/Beryl.

Thanks!
A


This is from lshw:

*-display
description: VGA compatible controller
product: GeForce 6200
vendor: nVidia Corporation
physical id: 0
bus info: pci@01:00.0
version: a1
size: 256MB
width: 32 bits
clock: 66MHz
capabilities: vga bus_master cap_list
configuration: driver=nvidia
resources: iomemory:f6000000-f6ffffff iomemory:e0000000-efffffff iomemory:f5000000-f5ffffff irq:177



/usr/bin/lspci -d "10de:*" -v -xxx

01:00.0 VGA compatible controller: nVidia Corporation GeForce 6200 (rev a1) (prog-if 00 [VGA])
Subsystem: ASUSTeK Computer Inc. Unknown device 81c7
Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 177
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (32-bit, prefetchable) [size=256M]
Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
[virtual] Expansion ROM at f7de0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 3.0




This is extracted from nvidia-bug-report.log
(I think it comes from xorg or nvidia module logs)

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
(**) NVIDIA(0): Option "TripleBuffer" "true"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 05.44.a2.03.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6200 at PCI:1:0:0:
ari.reads is offline   Reply With Quote
Old 11-20-06, 05:32 AM   #18
zeus78
Registered User
 
Join Date: Nov 2006
Posts: 1
Default Re: 9629 - black window bug with Beryl / Compiz persists?

I report the exact same blank window problems with a Go5200 with a measly 32 MB RAM (which, incidentally, ran okay with Xgl).

In addition, I get the same discrepancy between lshw/lspci and the Xorg log (/var/log/Xorg.0.log) described in the preceding post. lshw/lspci report 256MB, while the log has the correct value of 32 MB...

This is on Ubuntu 6.10 with the 9629 drivers and Beryl 0.1.1.
zeus78 is offline   Reply With Quote
Old 11-20-06, 09:23 PM   #19
ari.reads
Registered User
 
Join Date: Nov 2006
Posts: 17
Default Re: 9629 - black window bug with Beryl / Compiz persists?

Any word, anyone @nvidia?
ari.reads is offline   Reply With Quote
Old 11-22-06, 05:04 AM   #20
23meg
Registered User
 
Join Date: Sep 2005
Posts: 23
Default Re: 9629 - black window bug with Beryl / Compiz persists?

My 64MB Go6200 is also reported to have 256MB in lshw.
23meg is offline   Reply With Quote

Old 11-22-06, 07:53 PM   #21
evilghost
Registered User
 
Join Date: Jul 2005
Posts: 3,606
Default Re: 9629 - black window bug with Beryl / Compiz persists?

I too have this issue with 1.0.9742, a work-around posted in Ubuntu Forums appears to be to run Beryl with the following command-line arguments which work well:

beryl --use-cow --force-aiglx

Update: The SVN repo's have updated beryl-manager to enable COW/AIGLX as an advanced option upon startup. There are numerous other improvements. See http://wiki.beryl-project.org/index....ots_Repository

Last edited by evilghost; 11-22-06 at 08:46 PM.
evilghost is offline   Reply With Quote
Old 11-23-06, 01:11 AM   #22
lloeki
Arch Linux
 
lloeki's Avatar
 
Join Date: Oct 2006
Posts: 122
Default Re: 9629 - black window bug with Beryl / Compiz persists?

Quote:
What I notice, is that lshw and lspci report an incorrect amount of memory in the card; they report 256MB but my card has only 128MB
hey guys, don't you know what turbocache is? the amount is correct: it's real vram+turbocache ram. it has to be reported somewhere as if it was real, lest games wouldn't be able to use the turbocache part
lloeki is offline   Reply With Quote
Old 12-05-06, 10:57 PM   #23
devsk
Registered User
 
Join Date: Jun 2006
Posts: 46
Default Re: 9629 - black window bug with Beryl / Compiz persists?

Is this problem still present in 9631? is the upgrade from 9629 worth it?
devsk is offline   Reply With Quote
Old 12-06-06, 05:25 AM   #24
apatrat2
Registered User
 
Join Date: Nov 2006
Posts: 20
Default Re: 9629 - black window bug with Beryl / Compiz persists?

Hi,
I confirm that the black window bug is still present on 9631 (at least on my ti4200 card). After a look to the changelog I don't think that this release was supposed to fix-it anyway. For me (and if i remember well all NV1X and NV2X cards) 9631 solved a nasty opengl bug that practically made useless the 9629 driver (every opengl application was crashing so practically no 3d acceleration). So far I have not discovered any other bugs with 9631.
Best regards,
Andrei
apatrat2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:18 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.