Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-06, 12:19 PM   #13
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nVidia nForce 680i motherboards

Disabling msi & msix appears to eliminate the problem here for me as well.
netllama is offline   Reply With Quote
Old 11-20-06, 12:39 PM   #14
RemyJ
Registered User
 
Join Date: Nov 2006
Posts: 9
Default Re: nVidia nForce 680i motherboards

Quote:
Originally Posted by netllama
Disabling msi & msix appears to eliminate the problem here for me as well.
Do you think the problem is that the driver thinks the board supports msi and msix but it really doesn't (I.E. the board's reporting an incorrect pci id) or that the board isn't handling it when it should?
RemyJ is offline   Reply With Quote
Old 12-02-06, 06:59 AM   #15
wdiz
Registered User
 
Join Date: Jan 2006
Posts: 9
Default Re: nVidia nForce 680i motherboards

Still no solution ?
wdiz is offline   Reply With Quote
Old 12-02-06, 10:49 AM   #16
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: nVidia nForce 680i motherboards

It has been determined that this is a BIOS bug. EVGA will need to provide a new BIOS to address this problem.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 12-02-06, 11:33 AM   #17
mrnuxi
Registered User
 
Join Date: Dec 2006
Location: Boulder CO
Posts: 1
Default Re: nVidia nForce 680i motherboards

I am putting together a new high-end linux PC and am leaning toward the EVGA 122-CK-NF68-AR [680i] motherboard with core 2 duo E6600. I will likely run Centos, and will by using VMware for running Windows. It sounds like this board works fine (other than the lan problem noted here). Is there any other 680i board I should consider?

Thanks
mrnuxi
mrnuxi is offline   Reply With Quote
Old 12-03-06, 07:40 PM   #18
jaykup
Registered User
 
Join Date: Jun 2005
Posts: 7
Default Re: nVidia nForce 680i motherboards

The fix by editing the /etc/modprobe.conf DOES work. Just go edit the file and add the line:

options forcedeth msi=0 msix=0

and reboot.

You must make sure you have the forcedeth module loaded through your kernel. If you type modprobe forcedeth and it errors, then you don't have support for it and will need to re-compile the kernel.

I am using 2.6.19 and using forcedeth as a module (editing the .config file is sometimes easier, just search for forcedeth)

Everything else on the motherboard is working great.
jaykup is offline   Reply With Quote
Old 12-04-06, 11:24 AM   #19
wdiz
Registered User
 
Join Date: Jan 2006
Posts: 9
Default Re: nVidia nForce 680i motherboards

Sorry jaykup, but it does NOT work on the distro Ubuntu 6.10.
I tried what you said (/etc/modprobe.conf) and tried with this option in the file /etc/modprobe.d/options

What is your distro ?
wdiz is offline   Reply With Quote
Old 12-21-06, 05:46 AM   #20
tohn
Registered User
 
Join Date: Dec 2006
Posts: 1
Default Re: nVidia nForce 680i motherboards

Hi everyone - In case this helps:

I ran into the same problem with my NForce 680i NIC on gentoo 2.6.18-r4. I recompiled my kernel with forcedeth as a module, and the msi settings changed (I used modules.d rather than modules.conf), and I have net again. My motherboard is an ASUS P775.

Also, it seems that the latest gentoo CD for netbooting acutally had the NICs working when I booted off it. It's just that the OS it installed didn't recognize the NICs.

I haven't found any other problems with net so far.
tohn is offline   Reply With Quote

Old 12-29-06, 06:21 PM   #21
wdiz
Registered User
 
Join Date: Jan 2006
Posts: 9
Default Re: nVidia nForce 680i motherboards

P23 bios from EVGA fixed the ethernet bug
wdiz is offline   Reply With Quote
Old 03-12-07, 10:33 AM   #22
tminter
Registered User
 
Join Date: Mar 2007
Posts: 6
Default Re: nVidia nForce 680i motherboards

Quote:
Originally Posted by jaykup
The fix by editing the /etc/modprobe.conf DOES work. Just go edit the file and add the line:

options forcedeth msi=0 msix=0

and reboot.

You must make sure you have the forcedeth module loaded through your kernel. If you type modprobe forcedeth and it errors, then you don't have support for it and will need to re-compile the kernel.

I am using 2.6.19 and using forcedeth as a module (editing the .config file is sometimes easier, just search for forcedeth)

Everything else on the motherboard is working great.
I have tried this on my setup (Asus P5N32-E SLI) but i get the errors to do with msi and msix. how do i recompile the kernel to, hopefully, sort this out?

*I am using Ubuntu 6.10 edgy
tminter is offline   Reply With Quote
Old 03-14-07, 04:20 AM   #23
nvmad
Registered User
 
Join Date: Oct 2005
Posts: 7
Default Re: nVidia nForce 680i motherboards

Hi tminter,

I'm not on a Ubuntu System, but Debian Etch shouldn't be too different from your configuration.

Try the following:
  • Check if forcedeth-Module is available in your config:
    Code:
     
    modprobe -l | grep forcedeth
    Should result in something like (other kernel number):
    /lib/modules/2.6.18-4-686/kernel/drivers/net/forcedeth.ko
  • Check if forcedeth-Module is currently active:
    Code:
    lsmod  | grep forcedeth
    if active, it should result in
    forcedeth              38372  0
  • Unload forcedeth-Module if active
    Code:
    modprobe -r forcedeth
  • Load forcedeth-Module without MSI and MSIX for testing:
    Code:
    modprobe forcedeth msi=0 msix=0
  • Restart Network:
    Code:
    /etc/init.d/networking restart
  • If your ethernet is now working, you can update your module-configuration like described in the previous posts to process the forcedeth-options on system boot.
Quote:
Originally Posted by tminter
I have tried this on my setup (Asus P5N32-E SLI) but i get the errors to do with msi and msix. how do i recompile the kernel to, hopefully, sort this out?

*I am using Ubuntu 6.10 edgy
nvmad is offline   Reply With Quote
Old 03-27-07, 08:17 PM   #24
nhooey
Registered User
 
Join Date: Mar 2007
Posts: 1
Default Re: nVidia nForce 680i motherboards

Okay, to all those suggesting that you do this:

modprobe -v forcedeth msi=0 msix=0

Or putting effectively the same options in your modprobe.conf or modprobe.d/options file, it doesn't always work.

The 2.6.17 kernel does not have a version of the forcedeth driver with these options. I've just tried it with the 2.6.17-11 Ubuntu kernel and dmesg says "unknown option `msi'". So stop suggesting that as a solution.

The question is now, what do you do if you're stuck with a 2.6.17 kernel, and still can't get forcedeth working?

You either have to compile your own version of the 2.6.18 kernel, or get a better version of the forcedeth driver that has these options.

I have Ubuntu Edgy 6.10 with an Asus P5N32-E SLI motherboard, and a 2.6.17-11 kernel, and the forcedeth options don't work for me.
nhooey is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 05:48 PM
Cannot load nvaudio driver (NVidia nforce) thahn01 NVIDIA Linux 4 09-13-02 02:28 AM

All times are GMT -5. The time now is 11:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.