Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-06, 10:42 AM   #1
chantecode
Registered User
 
Join Date: Jul 2006
Posts: 3
Default My screen shutdowns when I use nvidia driver

Hello,

I have a GeForce4 Ti 4200 AGP 8x on my computer, and the driver I use is the "nv"
driver from Linux under Ubuntu Dapper.

When I used Debian (under sarge and etch) with xfree86, the official driver worked perfectly!
But since I use Ubuntu with xorg, the official driver never worked (I tried a lot of releases).

The screen shutdowns when I start xorg. I can hear the song of gdm which starts.
But I can't do anything else.
If I press [ctrl]+[alt]+[F1] I can't come back to a console, and I can't kill X with the keys. The screen stays shutdowned.

I told about it in the Ubuntu forums but they can't find the problem (you can see here the things we tried to do):
http://ubuntuforums.org/showthread.php?t=222262

Since this thread on Ubuntu Forums I tried one or two releases from nvidia website including this one (the last at this time):
http://www.nvidia.com/object/linux_d..._1.0-9629.html
But the problem stay alive.

Here is the last pastebin I have from my Xorg logs:
http://pastebin.com/821892

This is the xorg.conf I use with nvidia official driver (generated by the driver installer):
http://pastebin.com/821893

And at least this is the xorg.conf which works fine (with nv driver from Linux kernel):
http://pastebin.com/821896
chantecode is offline   Reply With Quote
Old 11-11-06, 05:29 PM   #2
TPG
Unregistered User
 
TPG's Avatar
 
Join Date: Apr 2006
Location: Poland, Warsaw
Posts: 203
Default Re: My screen shutdowns when I use nvidia driver

Please read this http://www.nvnews.net/vbulletin/showthread.php?t=46678
__________________
mandriva > all
kthnxbai
TPG is offline   Reply With Quote
Old 11-12-06, 08:52 AM   #3
chantecode
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Re: My screen shutdowns when I use nvidia driver

Ok.

I checked the steps decribed in this link.

1) Stability problems.

* I have only one processor, and only one processor core.
* I'm not using an IA64 processor. I have an athlon XP
* I don't see strange messages on syslog about NVIDIA module. That only what I see
with dmesg: "NVRM: loading NVIDIA Linux x86 Kernel Module 1.0-9629...."

2) I searched for a thread which talk about this. And I see any stories about black screen...
It's difficult to detect a problem which could be the same than mine.

3) Ok. Step by step. When I start gdm, the screen (which have a green LED when all works
and the computer is running) becomes black as if my computer were shutdown. Its LED becomes orange.
I can hear gdm starting. It seems I can control my computer with the keyboard.
But during this session, my screen stay black so I have to reboot...

4) I don't have an other computer to execute remotely nvidia_bug_report.sh.
So I executed it towards the crontab after launching X --verbose 5(only X and not gdm).
The result is in attachment.
Attached Files
File Type: log nvidia-bug-report.log (103.8 KB, 97 views)
chantecode is offline   Reply With Quote
Old 11-14-06, 06:56 AM   #4
promeneur
Registered User
 
Join Date: Aug 2006
Posts: 4
Default Re: My screen shutdowns when I use nvidia driver

i have a similar pb since i updated from MDV 2006 to 2007(with 2006 that was working well)
ASUS A7N8X-X
Sparkle Nvidia GeForce FX 5200
driver 8774

when cold booting and kde session opening
my screen switches to energy saving state and my keyboard and mouse are blocked
then
I do a warm boot
at the very begin of the boot
my screen switches to energy saving state and my keyboard and mouse are blocked
boot stops
then
I do a warm boot
at the very begin of the boot
my screen switches to energy saving state and my keyboard and mouse are blocked
boot stops
then
I do a warm boot
at the very begin of the boot
my screen switches to energy saving state and my keyboard and mouse are blocked
boot stops
then
I do a warm boot
my system starts and works!
promeneur is offline   Reply With Quote
Old 11-18-06, 12:26 PM   #5
chantecode
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Re: My screen shutdowns when I use nvidia driver

Hmm, I don't think I have the same problem since we haven't the same graphic card and my keyboard works even after my screen switches to energy state.

Can anyone help me?
Please tell me if I forgot any details....
chantecode is offline   Reply With Quote
Old 11-18-06, 02:35 PM   #6
piotrq__
Registered User
 
Join Date: Jan 2006
Posts: 193
Default Re: My screen shutdowns when I use nvidia driver

@chantecode:
You can try changing the resolution after GDM starts with a combination of keys:
LCTRL LALT and the "+", or "-" on you numeric pad to respectively increse/decrease the resolution of the screen.
Maybe there's just something wrong with your xorg.conf, or your hardware (monitor probably) and because of that X sets a wrong res, and/or the refresh rate.

Try fixing the resolution with that key combo and post an nvidia-bug-report if that helps.
Or post the nvidia-bug-report after this "crash" occurs. Log-in via ssh, copy the report and post it from another computer (if that's possible of course!).

@promeneur Have you tried a different (newer) driver? 9629 for example?
Are you using the latest BIOS with your motherboard?

Last edited by piotrq__; 11-18-06 at 02:54 PM.
piotrq__ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 01:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 06:48 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 05:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.