Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-06, 03:59 PM   #1
cboehme1
Registered User
 
Join Date: Nov 2006
Posts: 2
Unhappy 7900 gs no 3d accelaration

Update: My bad: I relied on the wrong tools, gnome-xgl-settings and glxgears. Turned out, manually setting Xgl as X-server worked without hitch...

OK, I tried the whole day to get my new 7900gs based card working with Linux (vanilla SuSE 10.1 for x64). It works flawlessly in Winxp; the 6600gt based card I had before also worked well within SuSE.

The problem is that I can't activate 3D accel: glxgears is slow and gnome-xgl-settings says I need to activate 3D. glxinfo says direct rendering is activated, the nvidia module is loaded, and I don't see any errors in in Xorg.0.log (no EE marked lines). I have tried NVIDIA-Linux-x86_64-1.0-8776-pkg2.run and NVIDIA-Linux-x86_64-1.0-9629-pkg2.run without luck.

Interesting sections from xorg.conf:
Section "Module"
Load "type1"
Load "dbe"
Load "freetype"
Load "glx"
Load "v4l"
Load "extmod"
EndSection

Section "Device"
BoardName "GeForce 7900 GS"
BusID "5:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection

It was created by sax. I have attached the nvidia bug report. Any ideas?
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (29.1 KB, 120 views)

Last edited by cboehme1; 11-11-06 at 04:24 PM. Reason: Update
cboehme1 is offline   Reply With Quote
Old 11-11-06, 04:06 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 7900 gs no 3d accelaration

glxgears is not a benchmark. Which real world OpenGL applications are also slow?
netllama is offline   Reply With Quote
Old 11-11-06, 04:21 PM   #3
cboehme1
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: 7900 gs no 3d accelaration

You are right... I thought that it at least should look fast, and also was confused by gnome-xgl-settings refusing to activate 3D effects, because presumably no 3D-acceleration was available. However, simply setting Xgl as default X-Server did the trick. Sorry for wasting your time!
cboehme1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with drivers after 295.40 (OpenSuSE 12.1, GeFroce 7900 GS, Phenom II X4) alawa NVIDIA Linux 0 06-09-12 06:37 PM

All times are GMT -5. The time now is 04:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.