Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-12-06, 06:57 AM   #1
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Exclamation URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hi,

we are assembling ~ 100 Nvidia Cards / Month. So far we have been very lucky with the 6600 Series, poorly they are not buyable here anymore, so we had to move to the 7xxx series and have a very bad behaviour of this cards:

If no screen is connected OR we use VGA Extender (Display & PC are far away. F.e. 200m with Cat.5 Video Xmitters) a "startx" works fine with the 6600 BUT 7600 has no video output.

How to reproduce?
1. Boot your PC with 7xxx card inside, Runlevel 3
2. login root/pass
3. disconnect VGA Cable
4. startx
5. connect VGA Cable again -> display stays off. (HERE WE NEED A SIGNAL)

Else info:
a. We tried all available 32 bit drives. (8776, 8756, 9629) all are the same.
b. If you do a screenshot in this situation (import -window root name.jpg) you
see the full desktop. Seems only that the card does not sent the VGA
signal to the VGA Cable
c. Wen you reproduced you can go by keyboard to a console (Strg-Alt-F2)
and have a signal. When you go back to X-Konsole (Strg-Alt-F7) the
monitor turns off again.

I know it is nice to "talk" with the screen, but all of this we do not need.
What is the correct option to escape this trap?

We tried various options in the xorg.conf but NO documented command helped so far.

THANK YOU!
wahrheit2004 is offline   Reply With Quote
Old 11-12-06, 07:04 AM   #2
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Same behaviour is, when we use a KVM-Switch to have 1 keyb/mouse and 1 monitor for 4 or 8 pc's. When the linux PCs to a reboot and startx (normal configuration in runlevel 5) and they are not in this moment having "access" to the monitor (because we look at PC2 this time) it also stays black .
wahrheit2004 is offline   Reply With Quote
Old 11-12-06, 07:26 AM   #3
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

You do not have this problem with the 6600?
My experience is the same for a 6600GT with 2 displays connected, one via DVI and the second via a DVI-VGA adapter to a VGA TV.
When the TV is off during X startup, the driver complains (in the logfile) about the display not being connected and does not initialize that port. When the TV is turned on later there is no picture. The windowmanager is informed that there is only one screen, not two.

So, the siituation does not seem to be 7xxx-specific. Maybe there is a difference in the driver version or details of the configuration you use for the older cards?
pe1chl is offline   Reply With Quote
Old 11-12-06, 09:19 AM   #4
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Hi Pe1chl,

I tried now with 6200 6600 and 6600 GT are are fine for me. Only 7xxx shows it!
FYI - The best option I ever had for DVI was :
Code:
Section "DEVICE":
Option "FlatPanelProperties" "Scaling = native"
Option "ExactModeTimingsDVI" "true"
Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, 
NoHorizSyncCheck, NoVertRefreshCheck, NoEdidDFPMaxSizeCheck, NoEdidModes"
I am looking for a solution that the card is NOT TALKING with the monitor at all.
This would be the best and finest option for me. But how to do?
wahrheit2004 is offline   Reply With Quote
Old 11-12-06, 01:53 PM   #5
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

I agree with you. I want to be able to configure "there is a VGA monitor with this modeline connected to that connector" without the know-it-all driver second-guessing me that it "is not connected" or "does not accept that modeline".

However the standpoint of NVIDIA, from the responses to questions and lack of response to specific questions I asked on this board, seems to be that what the driver thinks is best should have preference over what the administrator says is correct.

I don't like that at all. And I see several others here who have problems with it. But they probably have a legal department that tells them that they must write their driver so that it cannot blow up an IBM 8513 (wellknown first-generation VGA monitor that you easily blow up using wrong parameters).
That the currently used monitors do not expose this behaviour, and that some users have special wishes like being able to start X without monitor and connect it later, does not really seem to bother them. They just add more checks and more NoXxxxCheck options at each and every release.
pe1chl is offline   Reply With Quote
Old 11-13-06, 07:43 AM   #6
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Currently I got from the PNY Support the information that it seems to be the Handshaking of the DDC infromation. If no DDC exists, than the Card simply turns of this video out.

For windows they know a tweak parameter that allows to override this.
Additionally they informed me that this behaviour is inside the BIOS, wich is from NVIDIA and theyself do not have any knowledge or abillity to change this.

The tweak paramter is only known for Windows by them, but not for Linux.
PLEASE NVIDIA, HELP!
wahrheit2004 is offline   Reply With Quote
Old 11-13-06, 01:46 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

You could try setting the ConnectedMonitor option to CRT.
netllama is offline   Reply With Quote
Old 11-14-06, 01:43 AM   #8
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Section Device:

Code:
Option "ConnectedMonitor" "CRT"
does NOT bring any effect
wahrheit2004 is offline   Reply With Quote

Old 11-14-06, 11:36 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Please generate and post an nvidia-bug-report.log.
netllama is offline   Reply With Quote
Old 11-15-06, 05:32 AM   #10
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Please find attached the NVIDIA BUG Reports. All generated with "-logverbose 5".

nvidia-bug-report.log.zip # default install, default xorg.conf
connected_monitor.zip # default install, xorg.conf with Option "ConnetedMonitor" "CRT"
Attached Files
File Type: zip nvidia-bug-report.log.zip (62.6 KB, 86 views)
File Type: zip connected_monitor.zip (31.4 KB, 96 views)

Last edited by wahrheit2004; 11-15-06 at 07:15 AM.
wahrheit2004 is offline   Reply With Quote
Old 11-15-06, 11:50 AM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

The CRT is not being detected:
(WW) NVIDIA(GPU-0): No connected display devices detected; assuming 1 CRT (CRT-0)
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0

There's really nothing that can be done here in the driver, as your VGA extender seems to have signal integrity/degredation problems. If it can't maintain the quality of the signal, the driver isn't going to be able to work around that.

Have you confirmed that the problem is not present when connecting the CRT directly to the videocard without the VGA-extender and without a KVM?

Also, what kind of CRT are you using?
netllama is offline   Reply With Quote
Old 11-15-06, 11:59 AM   #12
wahrheit2004
Registered User
 
Join Date: Mar 2006
Posts: 15
Thumbs up Re: URGENT! 7600CS (rev 02e1) stays black when screen via VGA extender

Tests we done with VGA cable off. This also must work, because sometimes we plug the vga cables later (after X has started).

As I said:
With 6xxx series everything was fine, with 7xxx not.

I need a option:
Do NOT talk to CRT. Do what admin says!

THANK YOU!
wahrheit2004 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.