Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-14-06, 02:19 PM   #1
Robster
Registered User
 
Join Date: May 2004
Location: Christchurch, New Zealand
Posts: 40
Default Console font problem with 1.0.9742 beta

Hi,

I've noticed that after running X, if I go back to a console window (either by pressing ctrl-alt-f1 or by killing X) then my console font is corrupted. The console font is normally set to 8x8 (for an 80x50 screen) with "vga=0x0f01" given to the kernel as a boot parameter.

You can see the corruption in this picture: http://www.cobbleware.com/files/consolefont.jpg

It seems that the screen has gone back to an 80x28 (or whatever) layout, with the bottom half of each line repeated. Linux still thinks that the console is 80x50, so the command prompt is somewhere off the bottom of the screen.

This is on kernel 2.6.19-rc4-mm2 or something, but it also happens on 2.6.18. The card is a 7800GT.

I'll attach a bug report too, just in case it's useful. Note that this is not a major issue for me, but I thought you might like to know about it
Attached Files
File Type: log nvidia-bug-report.log (131.7 KB, 107 views)
Robster is offline   Reply With Quote
Old 11-15-06, 04:11 AM   #2
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: Console font problem with 1.0.9742 beta

Have you tried vesafb? Might help. I use geforce 6150 with vesafb and 9742 driver - its OK.
zbiggy is offline   Reply With Quote
Old 11-15-06, 04:47 AM   #3
Robster
Registered User
 
Join Date: May 2004
Location: Christchurch, New Zealand
Posts: 40
Default Re: Console font problem with 1.0.9742 beta

Quote:
Originally Posted by zbiggy
Have you tried vesafb? Might help. I use geforce 6150 with vesafb and 9742 driver - its OK.
Thanks for the tip, but I figured since it's never done this with any previous versions, it's a new bug and a bug-report might be the most useful thing to do
Robster is offline   Reply With Quote
Old 11-15-06, 04:56 PM   #4
sylware
Registered User
 
Join Date: Jun 2006
Posts: 5
Default Re: Console font problem with 1.0.9742 beta

Same corruption with vanilla 2.6.19-rc5...
sylware is offline   Reply With Quote
Old 12-27-06, 08:16 PM   #5
Robster
Registered User
 
Join Date: May 2004
Location: Christchurch, New Zealand
Posts: 40
Default Re: Console font problem with 1.0.9742 beta

Just a quick note to say that this issue is still there in 1.0.9746.
Robster is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Console Killers News Archived News Items 0 06-11-12 10:10 PM

All times are GMT -5. The time now is 09:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.