Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-11-06, 09:32 PM   #1
rauchter
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Config XVMC

I am running FC6 with a FX5200 card and trying to enable XVMC support for use with xine. I have installed the latest nvidia drivers and cannot for the life of me find anything about how to enable XVMC. When I tell xine to use it I get a can't find xvmc config file error. Can anyone point me in the right direction?
rauchter is offline   Reply With Quote
Old 11-11-06, 10:52 PM   #2
cellstije
Registered User
 
Join Date: Jul 2005
Posts: 43
Default Re: Config XVMC

Quote:
Originally Posted by rauchter
I am running FC6 with a FX5200 card and trying to enable XVMC support for use with xine. I have installed the latest nvidia drivers and cannot for the life of me find anything about how to enable XVMC. When I tell xine to use it I get a can't find xvmc config file error. Can anyone point me in the right direction?
try to check the file:
Code:
/etc/X11/XvMCConfig
mine reads:

Code:
cat /etc/X11/XvMCConfig
libXvMCNVIDIA.so.1
c.
cellstije is offline   Reply With Quote
Old 11-12-06, 12:52 PM   #3
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Config XVMC

Hmm, with the latest driver it is:

libXvMCNVIDIA_dynamic.so.1
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 11-12-06, 05:36 PM   #4
rauchter
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: Config XVMC

Thanks for the help, I created a file called XvMCConfig and put libXvMCNVIDIA_dynamic.so.1 in it and now I can watch .ts files without stuttering.

Cheers
rauchter is offline   Reply With Quote
Old 11-13-06, 02:09 AM   #5
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Config XVMC

And my mplayer is not runnning with xvmc...
I recompiled ffmpeg and mplayer with the libXvMCNVIDIA_dynamic.so.1.

Then I get this error when I start an wmv-hd vid or any other vid codecs:

Code:
[marcus@inspiron HDTV]$ mplayer -vo xvmc avec_1920_1080_wme.wmv 
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Genuine Intel(R) CPU           T2400  @ 1.83GHz (Family: 6, Model: 14, Stepping: 8)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing avec_1920_1080_wme.wmv.
ASF file format detected.
VIDEO:  [WMV3]  1920x1080  24bpp  50.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: AVEC Testbild
 copyright: BUROSCH Audio-Video-Technik
vo_xvmc: X-Video extension 2.2
vo_xvmc: X-Video MotionCompensation Extension version 1.1
==========================================================================
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:6220800  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32 
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 1920 x 1080 (preferred colorspace: Packed YUY2)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:6220800  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 RGB24 RGB32 
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 1920 x 1080 (preferred colorspace: Packed YUY2)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffwmv3] vfm: ffmpeg (FFmpeg M$ WMV3/WMV9)
==========================================================================
==========================================================================
Opening audio decoder: [dmo] Win32/DMO decoders
GetOutput r=0x0   size:73728  align:1
StreamCount r=0x0  1  1
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [wma9dmo] afm: dmo (Windows Media Audio 9 DMO)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 1080 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.

FATAL: Could not initialize video filters (-vf) or video output (-vo).


Exiting... (End of file)
[marcus@inspiron HDTV]$
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 11-13-06, 03:59 AM   #6
russofris
Registered User
 
Join Date: Jul 2003
Posts: 125
Default Re: Config XVMC

XvMC for Nvidia currently supports only MEPG2 acceleration. So, legacy codecs like VC1, and standard codecs like h264 and mpeg4 are not yet accelerated. You are going to have to wait for either Nvidia or Nouveau to support these codecs.

Quote:
recompiled ffmpeg and mplayer with the libXvMCNVIDIA_dynamic.so.1.
Then I get this error when I start an wmv-hd vid or any other vid codecs:
ffmpeg does not support wmv-hd (as wmv is VC1). I do not imagine that there will ever be XvMC support for VC1 in linux, since there is no native decoder. Use Xv for your output device for VC1.

Thank you for your time,
Frank Russo
russofris is offline   Reply With Quote
Old 11-13-06, 05:09 AM   #7
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Config XVMC

Quote:
Originally Posted by russofris
XvMC for Nvidia currently supports only MEPG2 acceleration. So, legacy codecs like VC1, and standard codecs like h264 and mpeg4 are not yet accelerated. You are going to have to wait for either Nvidia or Nouveau to support these codecs.


ffmpeg does not support wmv-hd (as wmv is VC1). I do not imagine that there will ever be XvMC support for VC1 in linux, since there is no native decoder. Use Xv for your output device for VC1.

Thank you for your time,
Frank Russo
Hmm? I tried an Original DVD with MPEG2 and mplayer. I get the same error...

But ffmpeg seems to support it. Read the changelog for the line VC-1/WMV3/WMV9 video decoder: http://ffmpeg.mplayerhq.hu/changelog.html
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 11-13-06, 10:55 AM   #8
xbobmx
Registered User
 
Join Date: May 2003
Posts: 191
Default Re: Config XVMC

According to the man page for mplayer, you need to use the ffmpeg12mc codec ("-vc ffmpeg12mc" option) to use XvMC.
xbobmx is offline   Reply With Quote

Old 11-14-06, 05:16 AM   #9
pzgren
Registered User
 
pzgren's Avatar
 
Join Date: Jan 2004
Posts: 107
Default Re: Config XVMC

Quote:
Originally Posted by xbobmx
According to the man page for mplayer, you need to use the ffmpeg12mc codec ("-vc ffmpeg12mc" option) to use XvMC.
This works without an video window. Only sound is running.
__________________
Fedora Core 6
Notebook: DELL Inspiron 9400 - Core Duo T2400 - 17" WUXGA 7800 Go 256MB - 2 GB DDR2 667 MHz -
PC: AMD64 3200 - 1 GB Infi. PC400 - MSI K8N Neo Platinum NForce3 250GB - 80GB SATA Samsung - SB Live! 5.1 - GF 6600GT AGP
pzgren is offline   Reply With Quote
Old 11-15-06, 04:45 AM   #10
zbiggy
Registered User
 
Join Date: Sep 2002
Posts: 623
Default Re: Config XVMC

You have to tell mplayer which video output can handle XvMC:
mplayer -vc ffmpeg12mc -vo xvmc dvd://
zbiggy is offline   Reply With Quote
Old 11-15-06, 08:56 AM   #11
russofris
Registered User
 
Join Date: Jul 2003
Posts: 125
Default Re: Config XVMC

Quote:
Originally Posted by pzgren
But ffmpeg seems to support it. Read the changelog for the line VC-1/WMV3/WMV9 video decoder: http://ffmpeg.mplayerhq.hu/changelog.html
It's only "93.8%" complete for the VC-1 main profile. Nowhere near complete for advanced profile. We can always hope to have something in 6 months so it's easier to transcode to mpeg4 or theora.

http://codecs.multimedia.cx/?cat=8

Frank
russofris is offline   Reply With Quote
Old 11-16-06, 10:49 AM   #12
dillwead
Registered User
 
Join Date: Feb 2006
Posts: 10
Default Re: Config XVMC

Quote:
Originally Posted by pzgren
This works without an video window. Only sound is running.
I had the same problem. I think you need to be running svn for xvmc to work properly in mplayer. At least that's what fixed it for me.
dillwead is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual monitor config w/o HDMI avs234 NVIDIA Linux 0 05-11-12 11:23 PM
Please help CAn't get GF 3 working on RH73 RunsWithScissor NVIDIA Linux 3 10-06-02 10:19 PM
Winxp Router Config Help.! styles-T Microsoft Windows XP And Vista 15 08-02-02 11:13 PM

All times are GMT -5. The time now is 07:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.