Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-16-06, 10:24 AM   #1
publicmsu
Registered User
 
Join Date: Oct 2006
Posts: 22
Default NForce4 AC3 Pass Through

Has anyone managed to get AC3 passthrough working with the alsa drivers in linux? I try using the -ac hwac3 with mplayer, but I hear nothing from my receiver. Is there something that i'm doing incorrectly?
publicmsu is offline   Reply With Quote
Old 11-16-06, 10:44 AM   #2
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: NForce4 AC3 Pass Through

Quote:
Originally Posted by publicmsu
Has anyone managed to get AC3 passthrough working with the alsa drivers in linux? I try using the -ac hwac3 with mplayer, but I hear nothing from my receiver. Is there something that i'm doing incorrectly?
I assume you want spdif/coax digital output. You'll need to look around in /proc/asound/devices. Particularly, the digital sound playback. Use the device number for the -ao alsa:device=hw=0.2 (or whatever the device number is instead of 2).
asdere is offline   Reply With Quote
Old 11-16-06, 10:48 AM   #3
publicmsu
Registered User
 
Join Date: Oct 2006
Posts: 22
Default Re: NForce4 AC3 Pass Through

I've got the stereo output working over spdif, however pass through does not work. I've tried using the -ao alsa:device=spdif (iec958, hw0.2), I've attempted all of the above and nothing but silence. I'm getting quite frustrated with this NForce offering, as it has the spdif output. Pass through works in windows, but not in linux. I've read posts indicating that it works with the OSS drivers that were provided by nvidia, but would rather stick with the alsa offering if possible, because I think the OSS solution was quite dated.
publicmsu is offline   Reply With Quote
Old 11-16-06, 06:55 PM   #4
publicmsu
Registered User
 
Join Date: Oct 2006
Posts: 22
Default Re: NForce4 AC3 Pass Through

here is the output of my aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia CK804 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0


when I try to execute the command mplayer -ao alsa:device=hw=0.2 -ac hwac3, it's silent. When I remove both of the audio command lines, I hear normal stereo audio. Is this chipset able to pass through the ac3 signal properly, or am I wasting my time trying to get this to work?
publicmsu is offline   Reply With Quote
Old 11-16-06, 09:39 PM   #5
Jason_25
Registered User
 
Join Date: Mar 2004
Location: Wilmington, NC
Posts: 25
Default Re: NForce4 AC3 Pass Through

I would like to know the answer to this too. It works fine with the OSS drivers but with the more recent drivers you have to change the source for it to compile.
Jason_25 is offline   Reply With Quote
Old 11-16-06, 11:20 PM   #6
asdere
Registered User
 
Join Date: Dec 2005
Posts: 37
Default Re: NForce4 AC3 Pass Through

Try twiddling with the mixer settings.

/usr/bin/amixer set IEC958 off
/usr/bin/amixer set IEC958 on

And also alsamixer.

It is a bit 'wierd', sometimes I'd have to turn the IEC958 off and other times on. Or like the very first audio file comes out screetchy but subsequent audio is fine.

Also, try without any alsa.conf, .asoundrc etc. Go direct hardware naming (ie, hw=0.2). iec958 and spdif are aliases and may not be correct from the defaults.

I also use the comma with "mplayer -ac hwac3, " that should help with none ac-3 sound.
asdere is offline   Reply With Quote
Old 11-19-06, 03:03 PM   #7
publicmsu
Registered User
 
Join Date: Oct 2006
Posts: 22
Default Re: NForce4 AC3 Pass Through

I've attempted nearly every combination known to man, and still have been unable to get any sort of AC3 pass through to work with this chipset. What is the big problem here? Things work just fine in windows, I can't believe that no one has addressed this issue in linux. This is a very popular chipset, and I would come to expect a feature like this to work without such a headache. I'm quite disappointed in the alsa solution at this time, and wish someone could offer some sort of solution!
publicmsu is offline   Reply With Quote
Old 11-20-06, 09:05 PM   #8
publicmsu
Registered User
 
Join Date: Oct 2006
Posts: 22
Default Re: NForce4 AC3 Pass Through

Apparently the alsa drivers do not support AC3 pass through on the nforce4 chipsets? I've not found a solution anywhere, and no one has been able to suggest anything. Quite disappointing.
publicmsu is offline   Reply With Quote

Old 11-29-06, 12:29 AM   #9
J.F.
GeForce FX5600
 
Join Date: Dec 2003
Location: Arizona
Posts: 35
Send a message via AIM to J.F.
Default Re: NForce4 AC3 Pass Through

I'm having the same problem... but I think the problem is in mplayer and xine.

Code:
aplay -Dspdif ~/music/dts/SURROUNDTEST_011212.wav
This works fine, the audio receiver showing dts data coming across the optical connection.

Code:
mplayer -ao alsa:device=spdif -afm hwac3 ~/music/dts/SURROUNDTEST_011212.wav
However doesn't play... it just prints "a52: CRC check failed!" repeatedly until the file ends.

Code:
mplayer -ao alsa:device=spdif ~/music/dts/SURROUNDTEST_011212.wav
Plays fine, with mplayer decoding the dts, downmixing it to stereo, then playing the stereo as PCM across the digital connection.

Code:
mplayer -aid 137 -ao alsa:device=spdif -afm hwac3 dvd://1
Plays the DVD... if the audio track selected is PCM, it plays across the spdif just fine. If it's ac3 or dts, the audio receiver says it's getting ac3 or dts, but there's no sound actually played. Given all of the above, I think it's clear the bug is in mplayer (and xine acts exactly the same).
J.F. is offline   Reply With Quote
Old 11-29-06, 01:29 AM   #10
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: NForce4 AC3 Pass Through

There's an option in Xine, under the Audio tab called "Speaker Arrangement", set it to "Pass Through", and you should hear multichannel audio 5.1 etc.. That's how I have it setup on my system, as I use a Creative Audigy 2 sound card, connected to a Creative 5.1 sound system with decoder (5.1 Dolby/DTS). May work with that card too..

Wolf
Wolfman [TWP] is offline   Reply With Quote
Old 11-29-06, 02:16 AM   #11
J.F.
GeForce FX5600
 
Join Date: Dec 2003
Location: Arizona
Posts: 35
Send a message via AIM to J.F.
Default Re: NForce4 AC3 Pass Through

Quote:
Originally Posted by Wolfman [TWP]
There's an option in Xine, under the Audio tab called "Speaker Arrangement", set it to "Pass Through", and you should hear multichannel audio 5.1 etc.. That's how I have it setup on my system, as I use a Creative Audigy 2 sound card, connected to a Creative 5.1 sound system with decoder (5.1 Dolby/DTS). May work with that card too..

Wolf
I set that... same as mplayer, BUT!!!! I figured it out after noticing that aplay said the dts file was playing at 44100 Hz, but mplayer kept saying playing at 48000 Hz. The deal is, most of these new chipsets (nvidia, via, etc) only play data at 48000 Hz. Period. Most of these ac3 and dts data streams I've been trying want to play at 44100 Hz. aplay apparently handles that, but neither mplayer nor xine handle it. They stubbornly insist on trying to output at 48000 Hz. What you need to do is set up your .asoundrc file to use dmix to change that 48000 stream into 44100.

Code:
pcm.nforce-hw {
        type hw
        card 0
}
pcm.!default {
        type plug
        slave.pcm "nforce"
}
pcm.nforce {
        type dmix
        ipc_key 1234
        ipc_perm 0660
        slave {
                pcm "hw:0,1"
                period_time 0
                period_size 1024
                buffer_size 8192
                rate 44100
        }
}
ctl.nforce-hw {
        type hw
        card 0
}
That got it working for me. I now have no trouble playing dts or ac3 straight through to the receiver... and it sounds GREAT!

Note the line

Code:
pcm "hw:0,1"
Be sure to make that whatever your spdif device ID is. Then all you have to do is direct the audio stream to "nforce", like this

Code:
mplayer -aid 128 -ao alsa:device=nforce -afm hwac3 dvd://1
Hope that helps someone else!
J.F. is offline   Reply With Quote
Old 11-29-06, 02:24 AM   #12
Wolfman [TWP]
Geforce 8800 GTS 512
 
Join Date: Nov 2002
Location: Australia
Posts: 396
Default Re: NForce4 AC3 Pass Through

The Creative sound card is setup for 48000Hz (by Default) as well, yet I haven't had any problems playing any multichannel streams.. *shrug*

The .asoundrc file should work for the OP just fine.. It's quite similar to the Audigy 2 setup..

Wolf
Wolfman [TWP] is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hmmm: Pass Some Time With Passengers News Archived News Items 0 05-11-12 06:40 AM

All times are GMT -5. The time now is 01:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.