Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-05, 10:42 PM   #1
wmauer
Registered User
 
Join Date: Mar 2005
Posts: 2
Default Upgrading to 7167 in Xandros

I'm running Xandros 3.01 OCE (Open Circulation Edition) and I have an FX5900XT. Upon loading the OS, it correctly detects and installs the 6629 drivers. However, this is the unpatched version, so Half Life 2 runs very poorly.

After reading about the 40MB VRAM issue with this driver, I headed over to get 7167. After compiling my kernel, and running the installer, the module fails to pass the runtime sanity check, and susequently causes kdm not to start. I had to edit the xorg.conf file, and use the default nv drivers to be able to post this. Here is the error from nvidia-installer:

-> Running runtime sanity check:
ERROR: The runtime configuration check failed for library
'libnvidia-tls.so.1.0.7167' (expected:
'/usr/lib/tls/libnvidia-tls.so.1', found:
'/usr/lib/nvidia/tls/libnvidia-tls.so.1'). The most likely reason for
this is that conflicting OpenGL libraries are installed in a location
not inspected by nvidia-installer. Please be sure you have uninstalled
any third-party OpenGL and third-party graphics driver packages.
-> done.

Oddly enough, the file it is "expecting" is there, and the file it "found" is not. Could this be a symlink issue, and if so, how can I work around it?

This occurs even after I have rebuilt the machine, and tried to upgrade the driver with just a vanilla install of the OS. If I try to roll back to 6629, the same problem occurs, with the same message.

I have included a copy of my nvidia-bug-report.log which was generated after I got kdm working again. If any other information is needed, I will gladly provide it. Thanks in advance!

Wes
Attached Files
File Type: txt nvidia-bug-report.txt (77.8 KB, 189 views)
wmauer is offline   Reply With Quote
Old 07-18-05, 10:34 PM   #2
lrj013
Registered User
 
Join Date: Jul 2005
Posts: 1
Lightbulb Re: Upgrading to 7167 in Xandros

Hi,

check /usr/lib/tls/libnvidia-tls.so.1and make sure it is linked correctly. You should have it like so:

ls -l /usr/lib/tls/libnvidia-tls.so.1
lrwxrwxrwx 1 root root 25 Jun 11 20:12 /usr/lib/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.7174

it will most likely be linked to /usr/lib/tls/libnvidia-tls.so.1.0.6629 so then you just need to (as root) do:

ln -sf /usr/lib/tls/libnvidia-tls.so.1.0.7174 /usr/lib/tls/libnvidia-tls.so.1

and that should correct the problem. I'm running Xandros 3.0 Standard Edition and had a similiar problem when I did their update to the nVidia drivers and I've run into this situations other times, other linux distros...

I hope this resolves your problem.

Luis
lrj013 is offline   Reply With Quote
Old 07-19-05, 06:05 PM   #3
wmauer
Registered User
 
Join Date: Mar 2005
Posts: 2
Default Re: Upgrading to 7167 in Xandros

Thanks for the response. I just re-loaded Xandros, and found that the 7174 driver now loads after the Service Pack installation. I performed:

ls -l /usr/lib/tls/libnvidia-tls.so.1
lrwxrwxrwx 1 root root 25 Jun 11 20:12 /usr/lib/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.1.0.7174

And saw the readout listed above. I would like to go to the latest nvidia driver (7667), and will follow the instructions you provided. My one question is, do I do this before, or after the driver upgrade? Thanks for your response!

Wes
wmauer is offline   Reply With Quote
Old 11-18-06, 12:15 PM   #4
Peter6218
Registered User
 
Join Date: Nov 2006
Posts: 7
Default Re: Upgrading to 7167 in Xandros

I have a slightly different problem. I'm running Xandros V3 with all the updates. Unfortunately none of the Nvidia drivers supplied by Xandros include the capability of adjusting either contrast, brightness or gamma.

Having just upgraded Win98 with the 7184 driver for my TNT2 card i decided to use the same version number Linux driver to get the screen controls. It's the latest that supports my card.

When I try to install it gives the message "You are running X-server" please Exit X-server and try again.

Try as I might, even asking Xandros Tech Support, nobody can tell me how to exit X??

Can anybody help with this distro?

Thanks

Peter
Peter6218 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
lost ttyv after upgrading from 285 to 295.40 barbara NVIDIA FreeBSD 3 05-15-12 04:48 PM

All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.