Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-06, 07:51 PM   #1
romen
Registered User
 
Join Date: Oct 2006
Posts: 3
Default [beta driver] DVI EDID problem

Is there any workaround for this bug?

Code:
(WW) NVIDIA(0):     Mode is rejected: Mode (1440 x 900) is too large for DFP
(WW) NVIDIA(0):     EDID (Max: 1280 x 1024).
It looks like this happens only when the monitor is linked by DVI cord, while the old style analog cord works without problem (I couldn't test this, I've only desumed it by other people experience).
The same happen with others WideScreen resolution, both in versions 9625 and 9626 (which I'm currently running).

I'd like to know if there's any temporary workaround while waiting it get fixed in further release. (There are already many bugreport about this issue so I don't report mine).

About validation process:
Code:
(II) NVIDIA(0): Frequency information for Samsung SyncMaster (DFP-0):
(II) NVIDIA(0):   HorizSync   : 30.000-81.000 kHz
(II) NVIDIA(0):   VertRefresh : 56.000-75.000 Hz
(II) NVIDIA(0):     (HorizSync from EDID)
(II) NVIDIA(0):     (VertRefresh from EDID)
(II) NVIDIA(0): 
(II) NVIDIA(0): --- Building ModePool for Samsung SyncMaster (DFP-0) ---
(II) NVIDIA(0):   Validating Mode "1440x900":
(II) NVIDIA(0):     1440 x 900 @ 60 Hz
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 106.50 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1440, 1520
(II) NVIDIA(0):       HSyncEnd, HTotal : 1672, 1904
(II) NVIDIA(0):       VRes, VSyncStart :  900,  903
(II) NVIDIA(0):       VSyncEnd, VTotal :  909,  934
(II) NVIDIA(0):       H/V Polarity     : -/+
(WW) NVIDIA(0):     Mode is rejected: Mode (1440 x 900) is too large for DFP
(WW) NVIDIA(0):     EDID (Max: 1280 x 1024).
romen is offline   Reply With Quote
Old 10-22-06, 08:08 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: [beta driver] DVI EDID problem

I've not seen any bug reports for an issue like this (and there are no open bugs for it either). If you want further assistance, please start X with the following command:
startx -- -logverbose 6

and generate and attach an nvidia-bug-report.log


Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-23-06, 01:01 PM   #3
romen
Registered User
 
Join Date: Oct 2006
Posts: 3
Exclamation Re: [beta driver] DVI EDID problem

Some posts I just (re-)found:

http://www.nvnews.net/vbulletin/show...1&postcount=50
http://www.nvnews.net/vbulletin/show...5&postcount=52
http://www.nvnews.net/vbulletin/show...1&postcount=56
http://www.nvnews.net/vbulletin/show...4&postcount=61
http://www.nvnews.net/vbulletin/show...1&postcount=64
http://www.nvnews.net/vbulletin/show...9&postcount=65

Yesterday I've found even other similar ones, but I cannot manage to found them again.

Anyway I've send the report to linux-bugs@nvidia.com.
Attached Files
File Type: gz nvidia-bug-report.tar.gz (27.1 KB, 110 views)
romen is offline   Reply With Quote
Old 10-23-06, 03:01 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: [beta driver] DVI EDID problem

Does adding the following option have any impact?
Option "ModeValidation" "NoEdidDFPMaxSizeCheck"

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-23-06, 03:19 PM   #5
romen
Registered User
 
Join Date: Oct 2006
Posts: 3
Default Re: [beta driver] DVI EDID problem

Yes, it solve the problem temporary. Thank you very much.

Will it be solved in the next release?

Again thank you very much for the great work!!

Nicola
romen is offline   Reply With Quote
Old 10-23-06, 03:24 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: [beta driver] DVI EDID problem

I'd like to see a bug report against 1.0-8776 where that option isn't needed.
netllama is offline   Reply With Quote
Old 10-24-06, 02:15 PM   #7
Bloot
Registered User
 
Join Date: Oct 2006
Location: Barcelona
Posts: 7
Default Re: [beta driver] DVI EDID problem

Hey many thanks for this!. I added that option to my Monitor Section in the xorg.conf and now I can use my 1440x900 native resolution through the DVI connection, I tried almost anything (use edid false, many modelines, 1440x900 only resolution in subsection display...) but nothing did the trick, nothing but this!.

Again many thanks.
Bloot is offline   Reply With Quote
Old 10-26-06, 10:39 AM   #8
crypticreign
Registered User
 
Join Date: Oct 2006
Posts: 4
Default Re: [beta driver] DVI EDID problem

Quote:
Originally Posted by netllama
Does adding the following option have any impact?
Option "ModeValidation" "NoEdidDFPMaxSizeCheck"
This didn't work for me. I have to use the Analog/VGA (instead of DVI) to get my monitor's native resolution (1680x1050). I've tried using Modelines and everything too.

I have a Nvidia GeForce 5600XT w/ Samsung SyncMaster 20.1" 205BW display.
crypticreign is offline   Reply With Quote

Old 10-26-06, 11:30 AM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: [beta driver] DVI EDID problem

please start X with the following command:
startx -- -logverbose 6

and generate and attach an nvidia-bug-report.log


Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-27-06, 08:32 PM   #10
crypticreign
Registered User
 
Join Date: Oct 2006
Posts: 4
Default Re: [beta driver] DVI EDID problem

Received this error

"nvidia-bug-report.log:
Your file of 206.7 KB bytes exceeds the forum's limit of 146.9 KB for this filetype."

So, here -- http://cr.pi.cx/nvidia-bug-report.log
crypticreign is offline   Reply With Quote
Old 10-27-06, 08:36 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: [beta driver] DVI EDID problem

Here's the problem:
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): 140.4 MHz maximum pixel clock


Your 1680x1050 mode requires a 146.25Mhz pixelclock which your graphics card is unable to provide:
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0): 1680 x 1050 @ 60 Hz
(--) NVIDIA(0): Pixel Clock : 146.25 MHz
(--) NVIDIA(0): HRes, HSyncStart : 1680, 1784
(--) NVIDIA(0): HSyncEnd, HTotal : 1960, 2240
(--) NVIDIA(0): VRes, VSyncStart : 1050, 1053
(--) NVIDIA(0): VSyncEnd, VTotal : 1059,
netllama is offline   Reply With Quote
Old 10-27-06, 08:54 PM   #12
crypticreign
Registered User
 
Join Date: Oct 2006
Posts: 4
Default Re: [beta driver] DVI EDID problem

Quote:
Originally Posted by netllama
Here's the problem:
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): 140.4 MHz maximum pixel clock


Your 1680x1050 mode requires a 146.25Mhz pixelclock which your graphics card is unable to provide:
(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0): 1680 x 1050 @ 60 Hz
(--) NVIDIA(0): Pixel Clock : 146.25 MHz
(--) NVIDIA(0): HRes, HSyncStart : 1680, 1784
(--) NVIDIA(0): HSyncEnd, HTotal : 1960, 2240
(--) NVIDIA(0): VRes, VSyncStart : 1050, 1053
(--) NVIDIA(0): VSyncEnd, VTotal : 1059,
I see. Any idea on a cheap video card that will provide that?
crypticreign is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.