Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-14-06, 03:01 AM   #1
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Hi ,

I just tested the new beta driver with "Faces of War" in cedega.
With the beta driver you get artifacts in the game .
You do not get these artifacts wit the 1.08762 driver.

Screenshot with 1.08762 driver:
http://www.christianundclaudia.de/fow_108672.jpg

Screenshot with 1.09625 driver:
http://www.christianundclaudia.de/fow_109625.jpg

As i did not change any settings in cedega, just upgraded from 1.08762 to 1.0925 this could be a driver issue.

Would you please take a look at this ?

Thanks,
Christian
Christian_Frank is offline   Reply With Quote
Old 10-14-06, 10:16 AM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Please generate and attach an nvidia-bug-report.log.

Does this reproduce in every part of the game?

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-14-06, 01:25 PM   #3
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Quote:
Originally Posted by netllama
Please generate and attach an nvidia-bug-report.log.

Does this reproduce in every part of the game?

Thanks,
Lonni
Hi Lonni,

yes, this reproduces in any part of the game that i have played until now..

I attached the nvidia-bug-report.log while 1.09625 is installed

Hope this helps.

Thanks,
Christian
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (28.9 KB, 123 views)
Christian_Frank is offline   Reply With Quote
Old 10-14-06, 02:52 PM   #4
tbeckman
Registered User
 
Join Date: Apr 2003
Posts: 23
Default Similar artifacts with 9625 in civ4

Civ4 under cedega also has artifacts with the 9625 driver that are not present with 8774. The city progress bars in the main display are not being drawn with 9625. They are completely black instead of showing the progress.
tbeckman is offline   Reply With Quote
Old 10-15-06, 01:45 PM   #5
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Hi Lonni,

I did some additional tests now:

In "Warhammer 40k Winter Aussault" i have EXACTLY the same problems !
The trees are full of this black artifacts. Looks exactly like the trees in "Faces of war".
No problem with 1.08762.

So this seems to be a bug of the nvidia driver in the opengl function that cedega uses to "print" the trees.

Hope this helps.

Regards,
Christian
Christian_Frank is offline   Reply With Quote
Old 10-15-06, 03:03 PM   #6
chareos
Registered User
 
Join Date: Jun 2004
Posts: 48
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Same problem and sympthoms for World of Warcraft via Cedega (direct3d).
Using Cedega (opengl) gives no problem, apart the loow performances (wow problem).
chareos is offline   Reply With Quote
Old 10-16-06, 05:02 PM   #7
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Christian_Frank,
I'm having problems getting Faces of War to run with the latest Cedega release. Basically the game never even starts up. Are there any specific Cedega configuration options that are needed?

thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-17-06, 01:00 PM   #8
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Quote:
Originally Posted by netllama
Christian_Frank,
I'm having problems getting Faces of War to run with the latest Cedega release. Basically the game never even starts up. Are there any specific Cedega configuration options that are needed?

thanks,
Lonni
Hi Lonni,

To get it working, you must use a no-cd crack, cause the copy protection of "faces of War" seems not to be supported by cedega.
You also have to place a "dx3d_29.dll" in the game directory.

Afer that, you should get in the game.
Then you have to disable "environment effects" in the graphics menue, or you will get an error while loading.

For further info please take a look at:
http://transgaming.org/forum/viewtopic.php?t=6948

Best regards,
Christian
Christian_Frank is offline   Reply With Quote

Old 10-17-06, 06:38 PM   #9
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

I've reproduced the corruption in Faces of War, and opened bug 261114.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 10-18-06, 01:22 PM   #10
Christian_Frank
Registered User
 
Join Date: Dec 2005
Posts: 85
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Quote:
Originally Posted by netllama
I've reproduced the corruption in Faces of War, and opened bug 261114.

Thanks,
Lonni

Hi Lonni,

Thank you very much for taking care about that issue .
Hope this gets fixed until the final release of 1.0962x .

Regards,
Christian
Christian_Frank is offline   Reply With Quote
Old 11-20-06, 03:07 PM   #11
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

After investigation this was determined to be a cedega bug, not an nvidia driver bug.
netllama is offline   Reply With Quote
Old 11-20-06, 08:48 PM   #12
nukem996
Registered User
 
Join Date: Oct 2005
Posts: 8
Default Re: Artifacts with cedega in "Faces of War" with 1.09625/ 1.08762 works

Im getting this in pretty much any game that uses DirectX instead of OpenGL. While this may be a cedega issue is there any word on when this going to get fixed?
nukem996 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.