Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-06, 02:50 PM   #1
carcifier
Registered User
 
Join Date: Apr 2004
Posts: 7
Default No 3D acceleration after upgrades

I updated from FC5 to FC6. Also, I previously was using 8776 driver(in FC5) and instead tried the newer 9629 driver.

There were no errors with the driver installation. 2D works fine, nothing 3D accelerated works. Either I get a black screen or the application just immediately exits.

I've updated all packages that had available updates, running kernel 2.6.18-1.2849.

SELinux is in permissive mode.

Pentium 4 3 Ghz processor(800 Mhz FSB)
GeForce 4 Titanium 4200 AGP8 128 Mb

Attached dmesg info.

*************************

After the upgrade I played around a little with some things. Originally, there were no kernel sources installed. I installed those, but noticed there were multiple rpm's for the same kernel listed, one i586, one i686. I figured I needed the i686. However, I noticed the i586 kernel rpm was installed. So, I installed that one to be the same. I ran the nvidia installer and it had one error saying a symbolic link was wrong, however it said it successfully completed the install. Same issue as mentioned above. I tried the older driver, and it wouldn't build at all. I then decided to try to change the kernel rpm installed to the i686 version. I did that. I then installed the i686 kernel sources to go with it, removing the other sources. So, now the 9629 builds with no errors apparently, but still no 3D acceleration.

I've searched these forums but was unable to find an identical situation. I found some confusing information regarding "legacy" drivers. I had no issues with the previous driver 8776 running in FC5 which I think I actually was running the same kernel as I am now in FC6.

If someone could enlighten me, I'd appreciate it. Guesses, although possibly helpful, are less desirable to known solutions for this issue.
Attached Files
File Type: txt nvidia_troubleshooting.txt (20.1 KB, 105 views)
carcifier is offline   Reply With Quote
Old 11-21-06, 02:55 PM   #2
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No 3D acceleration after upgrades

Please generate and attach an nvidia-bug-report.log along with the output from glxinfo.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-21-06, 03:12 PM   #3
carcifier
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: No 3D acceleration after upgrades

I've attached the nvidia bug report log file.

I was unclear exactly as to what you wish for with the "glxinfo". In X, if I go to the nvidia x server settings tool and try to go to the "opengl/glx information" section, it crashes, exits. All other areas of the tool seem to work.

I searched for files named "glxinfo" and found only one, which I doubt you are referring to. It appears to be part of my Cedega installation. It resided in /usr/lib/transgaming_cedega/tests.

I ran it anyways and it seg faulted.
Attached Files
File Type: log nvidia-bug-report.log (113.1 KB, 114 views)
carcifier is offline   Reply With Quote
Old 11-21-06, 03:20 PM   #4
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No 3D acceleration after upgrades

This is a known bug in 1.0-9629 which impacts NV2x GPUs (and has been discussed on several other threads on this forum). This bug will be resolved in the next driver release. The current workaround is to downgrade to an older driver.

Thanks,
Lonni
netllama is offline   Reply With Quote
Old 11-21-06, 04:16 PM   #5
carcifier
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: No 3D acceleration after upgrades

Quote:
Originally Posted by netllama
This is a known bug in 1.0-9629 which impacts NV2x GPUs (and has been discussed on several other threads on this forum). This bug will be resolved in the next driver release. The current workaround is to downgrade to an older driver.
Ok, I'm willing to believe this. However, I can't get the old driver to build. It used to previously in FC5. Now, it won't. 8776 won't build. This shouldn't be a result of an issue with the 9629 driver.

I uninstalled the 9629 driver with the --uninstall flag, then upon trying to install 8776 I get an error that the installer cannot build it and it exits.

I've attached the new log file. Any idea why this is occuring?
Attached Files
File Type: log nvidia-installer.log (8.2 KB, 100 views)
carcifier is offline   Reply With Quote
Old 11-21-06, 04:18 PM   #6
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: No 3D acceleration after upgrades

echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \

This has been discussed with solutions in several other threads on this forum.
netllama is offline   Reply With Quote
Old 11-22-06, 01:49 PM   #7
carcifier
Registered User
 
Join Date: Apr 2004
Posts: 7
Default Re: No 3D acceleration after upgrades

Contrary to what may have been hinted to by the llama, it wasn't trivial to find the solution to this problem. However, the solution itself was completely trivial. There were unfortunately, multiple solutions that I eventually stumbled upon for the same situation. I'm gonna mention what worked for others benefit...

It appears that this entire thing boils down to the installer looking for a file that no longer exists. That file being "config.h". One solution I found suggested altering a header file(nv-linux.h after extracting the installer) to make it include "autoconf.h" instead of "config.h". Unfortunately, for me, that didn't work. Even though that file exists in the same location as the other.

The solution was simply to create an "empty" file called "config.h" in the proper location. On my Fecora Core 6 install that was "/usr/src/kernels/2.6.18-1.2849.fc6-i686/include/linux".

This allows the 8776 driver to build in FC6 with the kernel I have installed.
carcifier is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tribes: Ascend 'Accelerate Update' to remove XP cost for upgrades, add 27 weapon News Archived News Items 0 06-11-12 10:50 PM
UBS upgrades NVIDIA to buy from neutral News Archived News Items 0 06-11-12 10:50 AM
$15 Windows 8 upgrades available from Microsoft through January 2013 News Archived News Items 0 06-01-12 12:50 PM
Multi card acceleration Andrew01 NVIDIA Linux 4 11-01-02 07:01 PM
Can I use 3-D acceleration in the framebuffer coredumped NVIDIA Linux 3 08-24-02 02:20 PM

All times are GMT -5. The time now is 04:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.