Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-21-06, 04:11 PM   #1
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Question 1.0-9629 TwinView High CPU load when using OpenGL

Hi,

It looks like hardware acceleration is not working all that well when using TwinView.

On TwinView, when using an OpenGL application (screensaver or Beryl), I get high CPU loads, ending up in relatively slow results, and a fast spinning fan.

All is fine when using a single screen.

With one or 2 screens attached, glxinfo tells me all is dandy, direct rendering and all.

I have attached the requested log and I am providing the following:
  • Brand: Dell
  • Model: Precision M65
  • Type: Laptop
  • CPU: Intel Core Duo T2600 @ 2.16 GHz
  • Memory: 2 GB
  • HDD: 80 GB
  • Video: Quadro FX 350M - 512 MB RAM - PCI Express 16X
  • Internal Screen: LCD 1920x1200 15.4"
  • External Screen: LCD 1920x1200 24"
  • Distribution: Ubuntu
  • Release: 6.10 "Edgy Eft"
  • Kernel: Ubuntu's flavor of 2.6.17-generic
  • xorg: 7.1.1
  • Driver: 1.0-9629 (nv and nvidia ignored from l-r-m config file)

If anything else is needed from me, please ask, I shall provide.

Thanks in advance for any help, hint, and slaps with the obvious.

Nico
Attached Files
File Type: zip nvidia-bug-report.log.zip (32.4 KB, 92 views)
camelreef is offline   Reply With Quote
Old 11-24-06, 08:50 AM   #2
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

A message from your friendly community bumping team

<bump!>

Thank you very much for you attention.

Nico
camelreef is offline   Reply With Quote
Old 11-27-06, 10:39 AM   #3
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

OK, one last bump, and I will cal it quits. Promised.

Am I the only one experiencing this?

Nico
camelreef is offline   Reply With Quote
Old 11-29-06, 02:53 PM   #4
Linuxhippy
Registered User
 
Join Date: Feb 2004
Posts: 585
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

bump
Linuxhippy is offline   Reply With Quote
Old 11-30-06, 02:17 PM   #5
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

So, it appears that I am not the only person with this problem.

Or am I mistaken?

Nico
camelreef is offline   Reply With Quote
Old 12-07-06, 10:31 AM   #6
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

By the way, the issue of bad 3D perfs and high CPU load when using dual 1920x1200 screens in twinview persists with the 9631 release of the driver.

I tried the 9742 beta driver as well, no luck either.

Nico
camelreef is offline   Reply With Quote
Old 01-12-07, 12:00 PM   #7
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

Hi all,

Still the same situation with 9746, using the nvidia installer, no pre-packaged stuff.

When using 1920x1200 on 2 screens, with TwinView, I get high CPU loads (one full core) when direct rendering is indicated as working.

Quadro FX 350M
VBIOS Version 05.72.22.21.ff
256 MB
PCI Express 16X

Dell Precision M65 Laptop, latest BIOS
Ubuntu 6.10 Edgy Eft, stock kernel

Nico
camelreef is offline   Reply With Quote
Old 01-12-07, 12:36 PM   #8
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

What OpenGL application are you using? Just the screensaver and Beryl?
mooninite is offline   Reply With Quote

Old 01-12-07, 01:38 PM   #9
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: 1.0-9629 TwinView High CPU load when using OpenGL

It can be anything using OpenGL, screensaver, Beryl, Google Earth, etc... Either alone, or combinations, it does not matter.

At first, i though it was a Beryl bug, but it is the same with OpenGL apps running without it.

I ended up NOT running Beryl at all when docked and using both screens, but I still find my laptop with fans blazing when I return to my desk after a few minutes of GL screensaver. The system monitor shows a history of high CPU load.

Use of Google Earth does the same.

Nico
camelreef is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 04:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.