Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-23-06, 03:58 AM   #1
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default TwinView on Ubuntu Edgy

Let me start by saying that I'm new to Linux. And that I've been trying for 3 days to get my monitors working the way I'd like with limited success.

Software : Ubuntu Edgy 6.10, Nvidia-GLX drivers, Beryl/Compiz With Emerald, TwinView Enabled.
Hardware : Nvidia GeForce 5500FX video card, Xerox XG-92d LCD monitor (DVI), LG Flatron L1930B LCD monitor (VGA)

Current Problems:

Resolution must be set at 2048x768 or the Xerox goes black and the LG displays half black/half desktop. I would like to be able to use a higher resolution, atleast on the Xerox monitor. Setting metamodes to values which are not equal (IE 1024x768; 2048x1024 has had no effect.

I have two users. Logging in as the second user after restarting X disables the Xerox monitor. Logging in as the second user after i've been logged in as the first user without restarting X fixes this problem. Beryl does not work for the second user under any circumstances.

TwinView does not allow me to maximize a window in only one monitor. The window spans both. I'd like to fix this problem even if it means not being able to drag windows between monitors.

Files:

xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Mon Oct 16 22:13:07 PDT 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "stylus" "SendCoreEvents"
    InputDevice    "cursor" "SendCoreEvents"
    InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
#	Load	"dri"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "stylus"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "stylus"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "eraser"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "eraser"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
    Identifier     "cursor"
    Driver         "wacom"
    Option         "Device" "/dev/wacom"          # Change to 
    Option         "Type" "cursor"
    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier     "L1930B"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Monitor        "L1930B"
    DefaultDepth    24
    Option         "TwinView" "true"
    Option         "MetaModes" "1280x1024, 1280x1024; 1024x768, 1024x768;"
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "SecondMonitorHorizSync" "32-60"
    Option         "SecondMonitorVertRefresh" "60-75"
    Option	   "CoolBits" "1"
    Option 	   "NoLogo" "1"
    Option         "TwinViewOrientation" "LeftOf"
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection
Attached Files
File Type: gz Xorg.0.log.gz (4.7 KB, 103 views)
dirtay is offline   Reply With Quote
Old 11-23-06, 04:26 AM   #2
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: TwinView on Ubuntu Edgy

I have a couple of CRTs set to different resolutions, using separate screens - ie, no window dragging.

I found the easiest way to set it up was to use 'nvidia-settings'. On Ubuntu, I found the best way to run it was to open a Terminal, type 'sudo bash' and enter my password, then type 'nvidia-settings'.

You want the 'X Server Display Configuration' page. On the right hand side, there is a button labelled 'Configure...'. Press that, and select 'Seperate X screen'. Press OK. You can make other adjustments here, like the positioning of the screen, resolutions, etc. When you are finished, press the 'Save to X Configuration File' button. This will generate a new /etc/X11/xorg.conf file for you, backing up the previous file.

Hope that helps



Cambo
Cambo is offline   Reply With Quote
Old 11-23-06, 04:50 AM   #3
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

I just tried this. It threw an error:

ERROR: NV-CONTROL extension not found on this Display.


ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.


ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.

The Nvidia Control dialogue did come up, though. It did not, however, have the option you specified. I went to the synaptic package manager and tried to install the nvidia-settings module, but it wanted to uninstall the nvidia-glx module first.

Would uninstalling GLX cause me any issues?
dirtay is offline   Reply With Quote
Old 11-23-06, 04:56 AM   #4
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: TwinView on Ubuntu Edgy

Ouch. Sounds like something isn't installed right. Probably a good idea to run `nvidia-bug-report.sh` and posting the nvidia-bug-report.log, as described in http://www.nvnews.net/vbulletin/showthread.php?t=46678

Did you install the Nvidia drivers from the Nvidia site, or from the Ubuntu repositories? I removed the Ubuntu version, and installed from the Nvidia site's files.



Cambo
Cambo is offline   Reply With Quote
Old 11-23-06, 05:01 AM   #5
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

Just generated a bug report. I used the ubuntu repository nvidia drivers. I'll try the download from the site now. Thank you for your help. I'll be posting back with the results.
dirtay is offline   Reply With Quote
Old 11-23-06, 05:33 AM   #6
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

Eh, how does one go about shutting X off in Ubuntu Edgy that i might restart it with -- -verbose 5? All of my attempts have only resulted in X restarting and giving me a login screen.
dirtay is offline   Reply With Quote
Old 11-23-06, 06:39 AM   #7
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: TwinView on Ubuntu Edgy

'sudo /etc/init.d/gdm stop' will shut down X for you. You can restart it by changing the 'stop' to 'start'.

Have a quick look at http://www.nvnews.net/vbulletin/showthread.php?t=79966 for some more tips ;-)



Cambo
Cambo is offline   Reply With Quote
Old 11-23-06, 08:16 AM   #8
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

I found that advice shortly after asking the question. I downloaded the drivers off of the nvidia site. Installed them, and now X crashes every time it tries to start.

The Nvidia installer originally threw errors about my needing a SDK/Development x.org package. Said it created the Kernel, and my xorg.config file. Then broke X. So i did "sudo apt-get install xorg-dev" and reinstalled the drivers. This time it didn't throw any errors, but still broke X. I'm on my windows partition right now, but i wrote down the errors X threw.

Failed to initialize nvidia kernel module.
Screens found but none have a usable configuration.
IO error 104(connection reset by peer) on x server ( 0.0 )

i think i may have to reinstall the repository drivers
dirtay is offline   Reply With Quote

Old 11-23-06, 08:25 AM   #9
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: TwinView on Ubuntu Edgy

Have you got the linux-headers package installed?

Would be an idea to post the nvidia-installer.log

You might want to run nvidia-xconfig, and let that create a new xorg.conf for you. It will back up your previous one.



Cambo
Cambo is offline   Reply With Quote
Old 11-23-06, 09:23 AM   #10
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

linux-headers is installed.

Any idea how i might be able to get the installer log out of there? X is down so i cannot upload it with my web browser.

Already ran nvidia-xconfig. I allowed the installer to do that initially.


Also i reinstalled the repository driver and ran nvidia-xconfig, but the official driver installation rewrote the kernel, so x continues to break. Driver version differences.

So i guess my only hope is to get the install log up here and my Xorg.0.log, but how do i do that from the command line?
dirtay is offline   Reply With Quote
Old 11-23-06, 09:54 AM   #11
dirtay
Registered User
 
Join Date: Nov 2006
Posts: 13
Default Re: TwinView on Ubuntu Edgy

Thank god for the command line FTP.

http://www.dirtay.com/nvidia-installer.log
http://www.dirtay.com/Xorg.0.log

This is after reinstalling the nvidia website drivers. Allowing it to once again rewrite the kernel and xorg.conf files.
dirtay is offline   Reply With Quote
Old 11-23-06, 10:22 AM   #12
Cambo
Registered User
 
Join Date: Mar 2004
Location: UK
Posts: 128
Send a message via Yahoo to Cambo
Default Re: TwinView on Ubuntu Edgy

Not sure about those checksum bits after "Validating previous installation". And having those references to version 8776 files, too.... May have to wait for someone a bit more knowledgeable than I, I'm afraid

At least your Xorg.0.log looks good ;-)



Cambo
Cambo is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 05:20 PM
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 06:20 AM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 03:20 PM
Twinview with TV-out karlaugust NVIDIA Linux 10 08-28-02 05:20 PM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 04:20 AM

All times are GMT -5. The time now is 10:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.