Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-03, 12:49 PM   #1
cascao_dv8
Registered User
 
Join Date: Feb 2003
Posts: 2
Default can't install 1.0-4191 w/ kernel 2.4.18-24.8.0

can't install 1.0-4191 w/ kernel 2.4.18-24.8.0 dowloaded from RH site.

in using RH 8.0 w/ the above kernel UP when i try to do rpmbuild --rebuild to 1.0-4191 src.rpm kernel pkg it returns the folowing :



+ LANG=C
+ export LANG
+ rm -f /tmp/files.lst
+ '[' -z '' ']'
++ uname -r
+ export TARGET_KERNEL=2.4.18-24.8.0
+ TARGET_KERNEL=2.4.18-24.8.0
+ '[' -d /lib/modules/2.4.18-24.8.0/kernel ']'
+ INSTALLPATH=/lib/modules/2.4.18-24.8.0/kernel/drivers/video
+ mkdir -p /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-24.8.0/kernel/drivers/video
+ install -m 0444 nvidia.o /var/tmp/NVIDIA_kernel-1.0//lib/modules/2.4.18-24.8.0/kernel/drivers/video
install: cannot stat `nvidia.o': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.10428 (%install)


RPM build errors:
user buildmeister does not exist - using root
group buildmeister does not exist - using root
user buildmeister does not exist - using root
group buildmeister does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.10428 (%install)

ps. im doing it as root and i have all kernel develop. pkg's installed

could anyone tel me whats wrong ... plase.

ps.(2) im not a native english speaker so please forguive any erros in text :-P
__________________
CasCao_:-)
cascao_dv8 is offline   Reply With Quote
Old 02-28-03, 03:43 PM   #2
THE_ODD_ONE
Registered User
 
Join Date: Feb 2003
Posts: 2
Default

read the post from steel it says that trying it in the gui and then doing the glx in text worked.

After 2 weeks of fighting with this thing on and off, I have now got my G3 TI200 working great under linux.
I am playing UT2003 and Its working great.


I am on the same kernel as you. I just tried and tried and it finally worked.
THE_ODD_ONE is offline   Reply With Quote
Old 03-01-03, 10:03 PM   #3
mikef
Registered User
 
Join Date: Mar 2003
Posts: 1
Default

I had exactly the same problem. I first tried to install the kernel rpm NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0.i686.rpm and had all kinds of problems, it said it was installed but startx just produced an error saying it couldn't find the nvidia.o. I tried installing with the source and got the same problem as you. Then I started checking the kernel version numbers using uname -r I found that I was running 2.4.18-14. When I looked under the libs/modules directory I found that I had two directories 2.4.18-18.80 and 2.4.18-14. The first had the nvidia.o installed but n other files, I guest that I must have been trying to install the wrong nvidia driver, so I downloaded NVIDIA_kernel-1.0-4191.rh80up.i686.rpm instead, I tried to install it but it said I all ready had the other installed so I removed the GLX and then the original driver using rpm -e NVIDIA_kernel-1.0-4191.rh80up_2.4.18_18.8.0 etc. and then installed the new drivers using rpm -ivh NVIDIA_kernel-1.0-4191.rh80up.i686.rpm and then the same for the GLX. I then modified my XFree86 file and modules.conf file as per the instructions at http://www.whacked.net/ldl/faq/. when I typed xstart the NVIDIA flash screen came up!!! an end to considerable frustration. I am a bit of a newbie so I am sorry if this doesn't help, and I still dont understand why we should get that problem with the src file but if it worked for me it might work for you. Good luck.

Mike.
mikef is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 06:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.