Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-27-06, 09:32 PM   #1
lordcris
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Apple Cinema Display Goes To Sleep With nvidia drivers

Hi,
suddenly, after 2 years , my Apple Cinema Display 20'' goes to sleep ( turns black and led blinks 3 times every 5 seconds ) whenever
i start X using the nvidia proprietary drivers.
when i use the open source drivers everything is ok.
my video card is an nvidia fx 5600.
I've tried all nvidia drivers : 1.0.8774 1.0.8776 (~)1.0.9626[1] (~)1.0.9629 [M](~)1.0.974
and all xorg version available: 1.0.2-r7 (~)1.1.0-r1 (~)1.1.1 1.1.1-r1 (~)1.1.1-r2 [M](~)1.1.99.902 [M]*1.2.99.0 [M]*9999
but nothing changes

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Sep 14 15:50:24 PDT 2006


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "unix/:-1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
#    Load           "glx"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    DisplaySize     434    270
    HorizSync       28.0 - 90.0
    VertRefresh     43.0 - 72.0
    ModeLine       "1680x1050" 108.0 1600 1616 1656 1704 1024 1027 1030 1056 -hsync -vsync -csync
    Option         "DPMS"
    Option "MonitorLayout" "TMDS,CRT"
    #Option         "DigitalVibrance" "50"
EndSection

Section "Device"

    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "ConnectedMonitor" "DFP"
    Option "UseEdid" "false"
    Option              "DDCMode"               "true"
    #Option          "UseFBDev"           "yes"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"

        #Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
        Depth       24
        Modes      "1680x1050" "1280x800" "1024x640" "800x500"
    EndSubSection
EndSection
any tips?
is it possible to be a sudden failure of my video card?
do you know if there is a tool to check so?
thank you
Attached Files
File Type: log nvidia-bug-report.log (106.6 KB, 100 views)
lordcris is offline   Reply With Quote
Old 11-28-06, 01:55 AM   #2
xbalanque_
tail'er and grep'er user
 
Join Date: Nov 2006
Posts: 17
Default Re: Apple Cinema Display Goes To Sleep With nvidia drivers

Possibly the same problem I reported here.

But just saying this doesn't help you with your problem, unfortunately.
xbalanque_ is offline   Reply With Quote
Old 11-29-06, 05:24 PM   #3
lordcris
Registered User
 
Join Date: Nov 2006
Posts: 3
Default Re: Apple Cinema Display Goes To Sleep With nvidia drivers

i did this.
i downloaded the kororaa live cd with Xgl support.
i booted form it and i all went well.
than i copied the xorg.conf over that of my installation
and rebooted.
now it works buy i have no idea why.
i suspect my video card i getting old and tired
so i bought a FX7800GS+


Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (root@goliath32)  Wed Mar 15 06:44:49 Local time zone must be set--see zic manual page 2006

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/share/X11/rgb"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "unix/:-1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "glx"
    Load           "record"
    Load           "xtrap"
    Load           "freetype"
    Load           "type1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "UseFBDev"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "VideoKey"              # <i>
        #Option     "FlatPanel"             # [<bool>]
        #Option     "FPDither"              # [<bool>]
        #Option     "CrtcNumber"            # <i>
        #Option     "FPScale"               # [<bool>]
        #Option     "FPTweak"               # <i>
   Option     "CursorShadow"       "true"  # [<bool>]
   Option     "CursorShadowAlpha"  "60"    # <i>
   Option     "CursorShadowXOffset" "2"    # <i>
   Option     "CursorShadowYOffset" "2" 
        Option     "NoLogo"           "true"    # <i>
   Option "HWCursor" "true"
   Option    "AddARGBGLXVisuals" "True"
   Option "AllowGLXWithComposite" "1"
   Option "RenderAccel" "true"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "NV31 [GeForce FX 5600]"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
DefaultColorDepth 24
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "DRI"
        Mode 0666
EndSection
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection
lordcris is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Russian Masterpieces Put on Display Using NVIDIA GPU Technology News Archived News Items 0 06-25-12 04:10 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVidia Display Drivers screw up KDE Webgraph NVIDIA Linux 11 10-08-02 08:57 PM
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM

All times are GMT -5. The time now is 06:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.